summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-09-23 08:38:09 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-09-23 08:38:09 +0000
commitd28e96f4991f726ccfc91551c7a115b0a3803834 (patch)
tree942e3d81690debb12dbc4bfaf6e4a90d95aa873c /net-misc
parentStable for amd64 wrt bug #506828 (diff)
downloadgentoo-2-d28e96f4991f726ccfc91551c7a115b0a3803834.tar.gz
gentoo-2-d28e96f4991f726ccfc91551c7a115b0a3803834.tar.bz2
gentoo-2-d28e96f4991f726ccfc91551c7a115b0a3803834.zip
Version bump
(Portage version: 2.2.12-r1/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/quagga/ChangeLog9
-rw-r--r--net-misc/quagga/quagga-0.99.23.1.ebuild116
2 files changed, 123 insertions, 2 deletions
diff --git a/net-misc/quagga/ChangeLog b/net-misc/quagga/ChangeLog
index 31d9c5bd0119..97d6d0aeb6ea 100644
--- a/net-misc/quagga/ChangeLog
+++ b/net-misc/quagga/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/quagga
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/ChangeLog,v 1.165 2013/10/31 07:41:25 pinkbyte Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/ChangeLog,v 1.166 2014/09/23 08:38:09 pinkbyte Exp $
+
+*quagga-0.99.23.1 (23 Sep 2014)
+
+ 23 Sep 2014; Sergey Popov <pinkbyte@gentoo.org> +quagga-0.99.23.1.ebuild:
+ Version bump
31 Oct 2013; Sergey Popov <pinkbyte@gentoo.org> quagga-0.99.22.4.ebuild,
+files/quagga-0.99.22.4-ipctl-forwarding.patch:
diff --git a/net-misc/quagga/quagga-0.99.23.1.ebuild b/net-misc/quagga/quagga-0.99.23.1.ebuild
new file mode 100644
index 000000000000..c236d8417787
--- /dev/null
+++ b/net-misc/quagga/quagga-0.99.23.1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/quagga-0.99.23.1.ebuild,v 1.1 2014/09/23 08:38:09 pinkbyte Exp $
+
+EAPI="5"
+
+CLASSLESS_BGP_PATCH=ht-20040304-classless-bgp.patch
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils eutils flag-o-matic multilib pam readme.gentoo user
+
+DESCRIPTION="A free routing daemon replacing Zebra supporting RIP, OSPF and BGP"
+HOMEPAGE="http://quagga.net/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz
+ bgpclassless? ( http://hasso.linux.ee/stuff/patches/quagga/${CLASSLESS_BGP_PATCH} )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+IUSE="bgpclassless caps doc elibc_glibc ipv6 multipath ospfapi pam +readline snmp tcp-zebra"
+
+COMMON_DEPEND="
+ caps? ( sys-libs/libcap )
+ snmp? ( net-analyzer/net-snmp )
+ readline? (
+ sys-libs/readline
+ pam? ( sys-libs/pam )
+ )
+ !elibc_glibc? ( dev-libs/libpcre )"
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ sys-apps/gawk
+ sys-devel/libtool:2"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/iproute2"
+
+PATCHES=( "${FILESDIR}/${PN}-0.99.22.4-ipctl-forwarding.patch" )
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="Sample configuration files can be found in /usr/share/doc/${PF}/samples
+You have to create config files in /etc/quagga before
+starting one of the daemons.
+
+You can pass additional options to the daemon by setting the EXTRA_OPTS
+variable in their respective file in /etc/conf.d"
+
+pkg_setup() {
+ enewgroup quagga
+ enewuser quagga -1 -1 /var/empty quagga
+}
+
+src_prepare() {
+ # Classless prefixes for BGP
+ # http://hasso.linux.ee/doku.php/english:network:quagga
+ use bgpclassless && epatch "${DISTDIR}/${CLASSLESS_BGP_PATCH}"
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ # do not build PDF docs
+ export ac_cv_prog_PDFLATEX=no
+ export ac_cv_prog_LATEXMK=no
+
+ local myeconfargs=(
+ --enable-exampledir=/usr/share/doc/${PF}/samples
+ --enable-isisd --enable-isis-topology
+ --enable-user=quagga
+ --enable-group=quagga
+ --enable-vty-group=quagga
+ --with-cflags="${CFLAGS}"
+ --with-pkg-extra-version="-gentoo"
+ --sysconfdir=/etc/quagga
+ --localstatedir=/run/quagga
+ --disable-static
+ --disable-pie
+ $(use_enable caps capabilities)
+ $(usex snmp '--enable-snmp' '' '' '')
+ $(use_enable !elibc_glibc pcreposix)
+ $(use_enable tcp-zebra)
+ $(use_enable doc)
+ $(usex multipath $(use_enable multipath) '' '=0' '')
+ $(usex ospfapi '--enable-opaque-lsa --enable-ospf-te --enable-ospfclient' '' '' '')
+ $(use_enable readline vtysh)
+ $(use_with pam libpam)
+ $(use_enable ipv6)
+ $(use_enable ipv6 babeld) # babeld does not build properly with USE="-ipv6", bug #446289
+ $(use_enable ipv6 ripngd)
+ $(use_enable ipv6 ospf6d)
+ $(use_enable ipv6 rtadv)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ readme.gentoo_create_doc
+
+ keepdir /etc/quagga
+ fowners root:quagga /etc/quagga
+ fperms 0770 /etc/quagga
+
+ # install zebra as a file, symlink the rest
+ newinitd "${FILESDIR}"/quagga-services.init.3 zebra
+
+ for service in isisd ripd ospfd bgpd $(use ipv6 && echo babeld ospf6d ripngd); do
+ dosym zebra /etc/init.d/${service}
+ done
+
+ use readline && use pam && newpamd "${FILESDIR}/quagga.pam" quagga
+
+ insinto /etc/logrotate.d
+ newins redhat/quagga.logrotate quagga
+}