summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-01-10 08:13:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-01-10 08:13:42 +0000
commitc8cf9823366ec90f0be13a67857c55e477762b72 (patch)
tree652d7a306c1abb3a45ddd621fb6e4006822af864 /net-misc
parentAdded myself to the long list of maintainers. (diff)
downloadgentoo-2-c8cf9823366ec90f0be13a67857c55e477762b72.tar.gz
gentoo-2-c8cf9823366ec90f0be13a67857c55e477762b72.tar.bz2
gentoo-2-c8cf9823366ec90f0be13a67857c55e477762b72.zip
Bug #283320 cleanup. This package is actually installing just a script and should bring in only linux-info for warnings, not linux-mod.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/htbinit/ChangeLog11
-rw-r--r--net-misc/htbinit/htbinit-0.8.5-r2.ebuild63
2 files changed, 72 insertions, 2 deletions
diff --git a/net-misc/htbinit/ChangeLog b/net-misc/htbinit/ChangeLog
index 72cee206e25e..43d43852a9c0 100644
--- a/net-misc/htbinit/ChangeLog
+++ b/net-misc/htbinit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/htbinit
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/htbinit/ChangeLog,v 1.13 2007/04/28 16:54:36 swegener Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/htbinit/ChangeLog,v 1.14 2010/01/10 08:13:42 robbat2 Exp $
+
+*htbinit-0.8.5-r2 (10 Jan 2010)
+
+ 10 Jan 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +htbinit-0.8.5-r2.ebuild:
+ Bug #283320 cleanup. This package is actually installing just a script and
+ should bring in only linux-info for warnings, not linux-mod.
28 Apr 2007; Sven Wegener <swegener@gentoo.org> htbinit-0.8.5.ebuild:
Fix *initd, *confd and *envd calls (#17388, #174266)
diff --git a/net-misc/htbinit/htbinit-0.8.5-r2.ebuild b/net-misc/htbinit/htbinit-0.8.5-r2.ebuild
new file mode 100644
index 000000000000..9e1526243509
--- /dev/null
+++ b/net-misc/htbinit/htbinit-0.8.5-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/htbinit/htbinit-0.8.5-r2.ebuild,v 1.1 2010/01/10 08:13:42 robbat2 Exp $
+
+EAPI=2
+inherit eutils linux-info
+
+DESCRIPTION="Sets up Hierachical Token Bucket based traffic control (QoS) with iproute2"
+HOMEPAGE="http://www.sourceforge.net/projects/htbinit"
+SRC_URI="mirror://sourceforge/htbinit/htb.init-v${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="ipv6 esfq"
+
+DEPEND="sys-apps/iproute2"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ CONFIG_CHECK="~NET_SCH_HTB ~NET_SCH_SFQ ~NET_CLS_FW ~NET_CLS_U32 ~NET_CLS_ROUTE"
+ for i in NET_SCH_HTB NET_SCH_SFQ NET_CLS_FW NET_CLS_U32 NET_CLS_ROUTE ; do
+ CONFIG_CHECK="${CONFIG_CHECK} ~${i}"
+ eval "export WARNING_${i}='module needed at runtime!'"
+ done
+ use esfq && CONFIG_CHECK="${CONFIG_CHECK} ~NET_SCH_ESFQ"
+ WARNING_NET_SCH_ESFQ='module needed at runtime! Available at http://fatooh.org/esfq-2.6/'
+ export CONFIG_CHECK
+ linux-info_pkg_setup
+}
+
+src_unpack() {
+ cp "${DISTDIR}"/htb.init-v${PV} "${S}"/htb.init
+}
+
+src_prepare() {
+ sed -i 's|/etc/sysconfig/htb|/etc/htb|g' "${S}"/htb.init
+ epatch "${FILESDIR}"/htb.init-v0.8.5_tos.patch
+ use ipv6 && epatch "${FILESDIR}"/htb_0.8.5_ipv6.diff
+ use esfq && epatch "${FILESDIR}"/htb_0.8.5_esfq.diff
+ epatch "${FILESDIR}"/prio_rule.patch
+ epatch "${FILESDIR}"/timecheck_fix.patch
+ epatch "${FILESDIR}"/htb.init_find_fix.patch
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dosbin htb.init
+
+ newinitd "${FILESDIR}"/htbinit.rc htbinit
+
+ keepdir /etc/htb
+}
+
+pkg_postinst() {
+ einfo 'Run "rc-update add htbinit default" to run htb.init at startup.'
+ einfo 'Please, read carefully the htb.init documentation.'
+ einfo 'new directory to store configuration /etc/htb'
+}