summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Fitzgerald <gregf@gentoo.org>2003-12-01 01:59:27 +0000
committerGreg Fitzgerald <gregf@gentoo.org>2003-12-01 01:59:27 +0000
commitc2fe8d246014c03fc06023ce89a84b40bea43025 (patch)
treea585a53757d4c23b468bf4d21ee1a94ee0138849 /net-misc
parentFix german locale, this closes bug #34515 (diff)
downloadgentoo-2-c2fe8d246014c03fc06023ce89a84b40bea43025.tar.gz
gentoo-2-c2fe8d246014c03fc06023ce89a84b40bea43025.tar.bz2
gentoo-2-c2fe8d246014c03fc06023ce89a84b40bea43025.zip
Fix german locale, this closes bug #34515
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wget/ChangeLog7
-rw-r--r--net-misc/wget/Manifest4
-rw-r--r--net-misc/wget/files/digest-wget-1.9.1-r21
-rw-r--r--net-misc/wget/wget-1.9.1-r2.ebuild72
4 files changed, 81 insertions, 3 deletions
diff --git a/net-misc/wget/ChangeLog b/net-misc/wget/ChangeLog
index bd0e76d5c5f3..a766ada1e104 100644
--- a/net-misc/wget/ChangeLog
+++ b/net-misc/wget/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/wget
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.31 2003/11/27 15:19:49 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.32 2003/12/01 01:59:23 gregf Exp $
+
+*wget-1.9.1-r2 (30 Nov 2003)
+
+ 30 Nov 2003; Greg Fitzgerald <gregf@gentoo.org> wget-1.9.1-r2.ebuild:
+ Fix german locale, closes bug #34515
27 Nov 2003; Brad House <brad_mssw@gentoo.org> wget-1.9-r1.ebuild,
wget-1.9.1-r1.ebuild:
diff --git a/net-misc/wget/Manifest b/net-misc/wget/Manifest
index 729af3f6c05d..29e029a9e67d 100644
--- a/net-misc/wget/Manifest
+++ b/net-misc/wget/Manifest
@@ -1,9 +1,9 @@
-MD5 25ce21f9fa54a30c09b39f7a404de469 ChangeLog 5799
+MD5 ca43f84ad02ba37f655a9b140359f5a0 ChangeLog 5795
MD5 2b5fde1ea46870de987e3f078face638 metadata.xml 344
MD5 47765e34328c20c6d1e5eea63ed5f478 wget-1.8.2-r3.ebuild 1867
MD5 f7037b5ffa6c9588ce78b59a1c825643 wget-1.9-r1.ebuild 1600
MD5 76e6e59a3d2c848bdda18b6bd8716eed wget-1.9.1-r1.ebuild 1565
-MD5 84d3b5f20e3c837ab10e556a1aeef3e9 wget-1.9.1-r2.ebuild 1714
+MD5 5a1684182a05ef20dac149432d940022 wget-1.9.1-r2.ebuild 1714
MD5 28f004e72194fae0e65365e48b867c83 files/digest-wget-1.8.2-r3 221
MD5 37da667ed578ec42044b54637f46a3ae files/digest-wget-1.9-r1 127
MD5 3ae4d064cf6e6d112fe89fd8e3fa389c files/digest-wget-1.9.1-r1 63
diff --git a/net-misc/wget/files/digest-wget-1.9.1-r2 b/net-misc/wget/files/digest-wget-1.9.1-r2
new file mode 100644
index 000000000000..fc78fd386c38
--- /dev/null
+++ b/net-misc/wget/files/digest-wget-1.9.1-r2
@@ -0,0 +1 @@
+MD5 e6051f1e1487ec0ebfdbda72bedc70ad wget-1.9.1.tar.gz 1322378
diff --git a/net-misc/wget/wget-1.9.1-r2.ebuild b/net-misc/wget/wget-1.9.1-r2.ebuild
new file mode 100644
index 000000000000..351ead2ce2c7
--- /dev/null
+++ b/net-misc/wget/wget-1.9.1-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.9.1-r2.ebuild,v 1.1 2003/12/01 01:59:23 gregf Exp $
+
+inherit gnuconfig
+
+IUSE="ssl nls static ipv6 debug socks5"
+
+NPVER=20031022
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
+SRC_URI="mirror://gnu/wget/${P}.tar.gz"
+#RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~arm ~mips ~amd64 ~ia64"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )"
+DEPEND="nls? ( sys-devel/autoconf sys-devel/gettext )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}+ipvmisc.patch
+}
+
+src_compile() {
+ #fix bug 34515, REMOVE THIS AFTER 1.9.1
+ if use nls; then
+ cd po
+ cat de.po | iconv -f UTF-8 -t ISO-8859-1 > de.po.new; mv de.po.new de.po
+ cd ..
+ fi
+
+ # Make wget use up-to-date configure scripts
+ gnuconfig_update
+
+ local myconf
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
+
+ use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
+
+ econf \
+ --sysconfdir=/etc/wget \
+ `use_enable ipv6` \
+ `use_enable nls` \
+ `use_enable debug` \
+ `use_with socks5 socks` \
+ ${myconf} || die
+
+ if use static; then
+ emake LDFLAGS="--static" || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ if use build; then
+ insinto /usr
+ dobin ${S}/src/wget
+ return
+ fi
+ make prefix=${D}/usr sysconfdir=${D}/etc/wget \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install || die
+ dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
+ dodoc doc/sample.wgetrc
+}