summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-22 20:56:05 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-22 20:56:05 +0000
commitba55b7c2b6426bc1f17ef9fc0800de70579e4f62 (patch)
treebeeb7fe6f073247ecd74318d1f2fac0480f7345e /net-misc
parentStable on alpha, bug #288261 (diff)
downloadgentoo-2-ba55b7c2b6426bc1f17ef9fc0800de70579e4f62.tar.gz
gentoo-2-ba55b7c2b6426bc1f17ef9fc0800de70579e4f62.tar.bz2
gentoo-2-ba55b7c2b6426bc1f17ef9fc0800de70579e4f62.zip
Version bump. Fix some crashes with gtk+-2.18.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gwget/ChangeLog7
-rw-r--r--net-misc/gwget/gwget-1.0.4.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/net-misc/gwget/ChangeLog b/net-misc/gwget/ChangeLog
index 4670a600111f..dbd41538f277 100644
--- a/net-misc/gwget/ChangeLog
+++ b/net-misc/gwget/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/gwget
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/ChangeLog,v 1.18 2009/10/19 19:45:11 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/ChangeLog,v 1.19 2009/10/22 20:56:05 eva Exp $
+
+*gwget-1.0.4 (22 Oct 2009)
+
+ 22 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> +gwget-1.0.4.ebuild:
+ Version bump. Fix some crashes with gtk+-2.18.
*gwget-1.0.3 (19 Oct 2009)
diff --git a/net-misc/gwget/gwget-1.0.4.ebuild b/net-misc/gwget/gwget-1.0.4.ebuild
new file mode 100644
index 000000000000..fa93b3374311
--- /dev/null
+++ b/net-misc/gwget/gwget-1.0.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/gwget-1.0.4.ebuild,v 1.1 2009/10/22 20:56:05 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GTK2 WGet Frontend"
+HOMEPAGE="http://gnome.org/projects/gwget/"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="epiphany libnotify"
+
+# FIXME: dbus should be optional
+# needs patching for linguas/intltool
+RDEPEND="net-misc/wget
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.16.0
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnomeui-2
+ >=dev-libs/dbus-glib-0.70
+ epiphany? ( >=www-client/epiphany-1.4 )
+ libnotify? ( >=x11-libs/libnotify-0.2.2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0
+ >=sys-devel/gettext-0.10.4"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable epiphany epiphany-extension)
+ $(use_enable libnotify)
+ --disable-static
+ --disable-schemas-install"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # remove /var/lib, which is created without any reason
+ rm -rf "${D}"/var || die "rm failed"
+
+ # remove useless la files
+ find "${D}" -name '*.la' -delete
+}