summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-05-27 11:04:44 +0000
committerJeroen Roovers <jer@gentoo.org>2013-05-27 11:04:44 +0000
commitb6bdb05992ca53df7238349969d0e36446d64d3e (patch)
treecacb4df3f94f23a179db0f57f4dd3fddc3656a7f /net-misc
parentStable on arm, wrt bug #471408 (diff)
downloadgentoo-2-b6bdb05992ca53df7238349969d0e36446d64d3e.tar.gz
gentoo-2-b6bdb05992ca53df7238349969d0e36446d64d3e.tar.bz2
gentoo-2-b6bdb05992ca53df7238349969d0e36446d64d3e.zip
Version bump.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/ChangeLog7
-rw-r--r--net-misc/youtube-dl/youtube-dl-2013.05.23.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/net-misc/youtube-dl/ChangeLog b/net-misc/youtube-dl/ChangeLog
index e2efd747982a..eae035b11de2 100644
--- a/net-misc/youtube-dl/ChangeLog
+++ b/net-misc/youtube-dl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/youtube-dl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/ChangeLog,v 1.169 2013/05/15 01:38:25 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/ChangeLog,v 1.170 2013/05/27 11:04:44 jer Exp $
+
+*youtube-dl-2013.05.23 (27 May 2013)
+
+ 27 May 2013; Jeroen Roovers <jer@gentoo.org> +youtube-dl-2013.05.23.ebuild:
+ Version bump.
*youtube-dl-2013.05.14 (15 May 2013)
diff --git a/net-misc/youtube-dl/youtube-dl-2013.05.23.ebuild b/net-misc/youtube-dl/youtube-dl-2013.05.23.ebuild
new file mode 100644
index 000000000000..c42819e2336e
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2013.05.23.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/youtube-dl-2013.05.23.ebuild,v 1.1 2013/05/27 11:04:44 jer Exp $
+
+EAPI=5
+PYTHON_COMPAT=(python{2_5,2_6,2_7})
+
+inherit bash-completion-r1 eutils python-single-r1
+
+DESCRIPTION="Download videos from YouTube.com (and mores sites...)"
+HOMEPAGE="http://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="test? ( dev-python/nose[coverage(+)] )"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ use offensive || epatch "${FILESDIR}"/${PN}-2013.05.10-offensive.patch
+}
+
+src_install() {
+ rm -vf youtube_dl/*.py[co]
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc CHANGELOG README.txt
+ doman ${PN}.1
+ dobashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}