summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-19 03:32:26 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-19 03:32:26 +0000
commitaaf571e42209accb7fdf17ea7414ff19399d2e53 (patch)
tree7f1dc48af0276b3a316812ca5ee16c644052b41b /net-misc
parentversion bump with patch from fabien Zouaoui via bug #104625 (diff)
downloadgentoo-2-aaf571e42209accb7fdf17ea7414ff19399d2e53.tar.gz
gentoo-2-aaf571e42209accb7fdf17ea7414ff19399d2e53.tar.bz2
gentoo-2-aaf571e42209accb7fdf17ea7414ff19399d2e53.zip
Move default xauth location to /usr/bin/xauth.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/ChangeLog7
-rw-r--r--net-misc/openssh/openssh-3.8.1_p1-r1.ebuild49
-rw-r--r--net-misc/openssh/openssh-3.9_p1-r3.ebuild22
-rw-r--r--net-misc/openssh/openssh-4.0_p1-r2.ebuild26
-rw-r--r--net-misc/openssh/openssh-4.1_p1-r1.ebuild26
-rw-r--r--net-misc/openssh/openssh-4.2_p1.ebuild26
6 files changed, 88 insertions, 68 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index a5382df8ed7f..c12c737b4de8 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/openssh
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.131 2005/09/17 19:36:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.132 2005/10/19 03:32:26 vapier Exp $
+
+ 19 Oct 2005; Mike Frysinger <vapier@gentoo.org>
+ openssh-3.8.1_p1-r1.ebuild, openssh-3.9_p1-r3.ebuild,
+ openssh-4.0_p1-r2.ebuild, openssh-4.1_p1-r1.ebuild, openssh-4.2_p1.ebuild:
+ Move default xauth location to /usr/bin/xauth.
*openssh-4.2_p1 (06 Sep 2005)
diff --git a/net-misc/openssh/openssh-3.8.1_p1-r1.ebuild b/net-misc/openssh/openssh-3.8.1_p1-r1.ebuild
index 89ecdc571381..a3080ab8f319 100644
--- a/net-misc/openssh/openssh-3.8.1_p1-r1.ebuild
+++ b/net-misc/openssh/openssh-3.8.1_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-3.8.1_p1-r1.ebuild,v 1.26 2005/09/08 23:54:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-3.8.1_p1-r1.ebuild,v 1.27 2005/10/19 03:32:26 vapier Exp $
inherit eutils flag-o-matic ccc
@@ -42,20 +42,25 @@ PROVIDE="virtual/ssh"
S=${WORKDIR}/${PARCH}
src_unpack() {
- unpack ${PARCH}.tar.gz ; cd ${S}
+ unpack ${PARCH}.tar.gz
+ cd "${S}"
- epatch ${FILESDIR}/${P}-resolv_functions.patch.bz2
+ sed -i \
+ -e '/_PATH_XAUTH/s:/usr/X11R6/bin/xauth:/usr/bin/xauth:' \
+ pathnames.h || die
- use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}.bz2
- use skey && epatch ${FILESDIR}/${P}-skey.patch.bz2
- use chroot && epatch ${FILESDIR}/${P}-chroot.patch.bz2
- use X509 && epatch ${DISTDIR}/${X509_PATCH}
- use smartcard && epatch ${FILESDIR}/${P}-opensc.patch.bz2
+ epatch "${FILESDIR}"/${P}-resolv_functions.patch.bz2
+
+ use selinux && epatch "${FILESDIR}"/${SELINUX_PATCH}.bz2
+ use skey && epatch "${FILESDIR}"/${P}-skey.patch.bz2
+ use chroot && epatch "${FILESDIR}"/${P}-chroot.patch.bz2
+ use X509 && epatch "${DISTDIR}"/${X509_PATCH}
+ use smartcard && epatch "${FILESDIR}"/${P}-opensc.patch.bz2
if use ldap ; then
if use X509 ; then
ewarn "Sorry, x509 and ldap don't get along"
else
- epatch ${DISTDIR}/${LDAP_PATCH}
+ epatch "${DISTDIR}"/${LDAP_PATCH}
fi
fi
@@ -75,13 +80,7 @@ src_compile() {
use selinux && append-flags -DWITH_SELINUX
use static && append-ldflags -static
- autoconf
-
- local myconf="\
- $( use_with tcpd tcp-wrappers ) \
- $( use_with pam ) \
- $( use_with skey )"
-
+ local myconf=""
use ipv6 || myconf="${myconf} --with-ipv4-default"
use kerberos && myconf="${myconf} --with-kerberos5=/usr" || \
myconf="${myconf} --without-kerberos5"
@@ -96,10 +95,10 @@ src_compile() {
--with-privsep-path=/var/empty \
--with-privsep-user=sshd \
--with-md5-passwords \
- `use_with tcpd tcp-wrappers` \
- `use_with pam` \
- `use_with skey` \
- `use_with smartcard opensc` \
+ $(use_with tcpd tcp-wrappers) \
+ $(use_with pam) \
+ $(use_with skey) \
+ $(use_with smartcard opensc) \
${myconf} \
|| die "bad configure"
@@ -112,11 +111,11 @@ src_compile() {
}
src_install() {
- make install-files DESTDIR=${D} || die
- chmod 600 ${D}/etc/ssh/sshd_config
+ make install-files DESTDIR="${D}" || die
+ chmod 600 "${D}"/etc/ssh/sshd_config
dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
- use pam && ( insinto /etc/pam.d ; newins ${FILESDIR}/sshd.pam sshd )
- exeinto /etc/init.d ; newexe ${FILESDIR}/sshd.rc6 sshd
+ use pam && ( insinto /etc/pam.d ; newins "${FILESDIR}"/sshd.pam sshd )
+ newinitd "${FILESDIR}"/sshd.rc6 sshd
keepdir /var/empty
dosed "/^#Protocol /s:.*:Protocol 2:" /etc/ssh/sshd_config
use pam && dosed "/^#UsePAM /s:.*:UsePAM yes:" /etc/ssh/sshd_config
@@ -137,7 +136,7 @@ pkg_postinst() {
einfo "new one with UID 22. If you have any scripts or programs that"
einfo "that referenced the old UID directly, you will need to update them."
einfo
- use pam >/dev/null 2>&1 && {
+ use pam && {
einfo "Please be aware users need a valid shell in /etc/passwd"
einfo "in order to be allowed to login."
einfo
diff --git a/net-misc/openssh/openssh-3.9_p1-r3.ebuild b/net-misc/openssh/openssh-3.9_p1-r3.ebuild
index 1782e874fda0..3224ab9297b1 100644
--- a/net-misc/openssh/openssh-3.9_p1-r3.ebuild
+++ b/net-misc/openssh/openssh-3.9_p1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-3.9_p1-r3.ebuild,v 1.8 2005/09/08 23:54:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-3.9_p1-r3.ebuild,v 1.9 2005/10/19 03:32:26 vapier Exp $
inherit eutils flag-o-matic ccc pam
@@ -46,6 +46,10 @@ src_unpack() {
unpack ${PARCH}.tar.gz
cd "${S}"
+ sed -i \
+ -e '/_PATH_XAUTH/s:/usr/X11R6/bin/xauth:/usr/bin/xauth:' \
+ pathnames.h || die
+
epatch "${FILESDIR}"/${P}-pamfix.patch.bz2
#epatch "${FILESDIR}"/${P}-largekey.patch.bz2
use X509 || epatch "${FILESDIR}"/${P}-fix_suid.patch
@@ -54,20 +58,20 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-configure-openct.patch #78730
epatch "${FILESDIR}"/${P}-kerberos-detection.patch #80811
- use sftplogging && epatch ${FILESDIR}/${P}-sftplogging-1.2-gentoo.patch.bz2
- use skey && epatch ${FILESDIR}/${P}-skey.patch.bz2
- use chroot && epatch ${FILESDIR}/${P}-chroot.patch
- use X509 && epatch ${DISTDIR}/${X509_PATCH} && epatch "${FILESDIR}"/${P}-fix_suid-x509.patch
- use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}.bz2
- use smartcard && epatch ${FILESDIR}/${P}-opensc.patch.bz2
+ use sftplogging && epatch "${FILESDIR}"/${P}-sftplogging-1.2-gentoo.patch.bz2
+ use skey && epatch "${FILESDIR}"/${P}-skey.patch.bz2
+ use chroot && epatch "${FILESDIR}"/${P}-chroot.patch
+ use X509 && epatch "${DISTDIR}"/${X509_PATCH} && epatch "${FILESDIR}"/${P}-fix_suid-x509.patch
+ use selinux && epatch "${FILESDIR}"/${SELINUX_PATCH}.bz2
+ use smartcard && epatch "${FILESDIR}"/${P}-opensc.patch.bz2
if use ldap ; then
if use X509 || use sftplogging ; then
ewarn "Sorry, x509/sftplogging and ldap don't get along"
else
- epatch ${DISTDIR}/${LDAP_PATCH}
+ epatch "${DISTDIR}"/${LDAP_PATCH}
fi
fi
- use hpn && epatch ${DISTDIR}/${HPN_PATCH}
+ use hpn && epatch "${DISTDIR}"/${HPN_PATCH}
autoconf || die "autoconf failed"
}
diff --git a/net-misc/openssh/openssh-4.0_p1-r2.ebuild b/net-misc/openssh/openssh-4.0_p1-r2.ebuild
index cfa9db5d4189..71cfc0b28acc 100644
--- a/net-misc/openssh/openssh-4.0_p1-r2.ebuild
+++ b/net-misc/openssh/openssh-4.0_p1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.0_p1-r2.ebuild,v 1.7 2005/09/08 23:54:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.0_p1-r2.ebuild,v 1.8 2005/10/19 03:32:26 vapier Exp $
inherit eutils flag-o-matic ccc pam
@@ -49,28 +49,32 @@ src_unpack() {
unpack ${PARCH}.tar.gz
cd "${S}"
+ sed -i \
+ -e '/_PATH_XAUTH/s:/usr/X11R6/bin/xauth:/usr/bin/xauth:' \
+ pathnames.h || die
+
#epatch "${FILESDIR}"/openssh-3.9_p1-largekey.patch.bz2
epatch "${FILESDIR}"/openssh-3.9_p1-configure-openct.patch #78730
epatch "${FILESDIR}"/openssh-3.9_p1-kerberos-detection.patch #80811
- use X509 && epatch ${DISTDIR}/${X509_PATCH}
- use sftplogging && epatch ${FILESDIR}/openssh-4.0_p1-sftplogging-1.2-gentoo.patch.bz2
- use skey && epatch ${FILESDIR}/openssh-3.9_p1-skey.patch.bz2
- use chroot && epatch ${FILESDIR}/openssh-3.9_p1-chroot.patch
- use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}.bz2
- use smartcard && epatch ${FILESDIR}/openssh-3.9_p1-opensc.patch.bz2
+ use X509 && epatch "${DISTDIR}"/${X509_PATCH}
+ use sftplogging && epatch "${FILESDIR}"/openssh-4.0_p1-sftplogging-1.2-gentoo.patch.bz2
+ use skey && epatch "${FILESDIR}"/openssh-3.9_p1-skey.patch.bz2
+ use chroot && epatch "${FILESDIR}"/openssh-3.9_p1-chroot.patch
+ use selinux && epatch "${FILESDIR}"/${SELINUX_PATCH}.bz2
+ use smartcard && epatch "${FILESDIR}"/openssh-3.9_p1-opensc.patch.bz2
if ! use X509 ; then
- use smartcard && epatch ${DISTDIR}/${SECURID_PATCH} ${FILESDIR}/openssh-securid-1.3.1-updates.patch
- use smartcard && use ldap && epatch ${FILESDIR}/openssh-4.0_p1-smartcard-ldap-happy.patch
+ use smartcard && epatch "${DISTDIR}"/${SECURID_PATCH} "${FILESDIR}"/openssh-securid-1.3.1-updates.patch
+ use smartcard && use ldap && epatch "${FILESDIR}"/openssh-4.0_p1-smartcard-ldap-happy.patch
if use sftplogging ; then
ewarn "Sorry, sftplogging and ldap don't get along"
else
- use ldap && epatch ${DISTDIR}/${LDAP_PATCH}
+ use ldap && epatch "${DISTDIR}"/${LDAP_PATCH}
fi
elif use smartcard || use ldap ; then
ewarn "Sorry, x509 and smartcard/ldap don't get along"
fi
- use hpn && epatch ${DISTDIR}/${HPN_PATCH}
+ use hpn && epatch "${DISTDIR}"/${HPN_PATCH}
sed -i '/LD.*ssh-keysign/s:$: -Wl,-z,now:' Makefile.in || die "setuid"
diff --git a/net-misc/openssh/openssh-4.1_p1-r1.ebuild b/net-misc/openssh/openssh-4.1_p1-r1.ebuild
index 96f722dc8a99..51279025d6d6 100644
--- a/net-misc/openssh/openssh-4.1_p1-r1.ebuild
+++ b/net-misc/openssh/openssh-4.1_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.1_p1-r1.ebuild,v 1.8 2005/09/08 23:54:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.1_p1-r1.ebuild,v 1.9 2005/10/19 03:32:26 vapier Exp $
inherit eutils flag-o-matic ccc pam
@@ -49,29 +49,33 @@ src_unpack() {
unpack ${PARCH}.tar.gz
cd "${S}"
+ sed -i \
+ -e '/_PATH_XAUTH/s:/usr/X11R6/bin/xauth:/usr/bin/xauth:' \
+ pathnames.h || die
+
#epatch "${FILESDIR}"/openssh-3.9_p1-largekey.patch.bz2
epatch "${FILESDIR}"/openssh-3.9_p1-kerberos-detection.patch #80811
- use X509 && epatch ${DISTDIR}/${X509_PATCH}
- use sftplogging && epatch ${FILESDIR}/openssh-4.0_p1-sftplogging-1.2-gentoo.patch.bz2
- use skey && epatch ${FILESDIR}/openssh-3.9_p1-skey.patch.bz2
- use chroot && epatch ${FILESDIR}/openssh-3.9_p1-chroot.patch
- use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}.bz2
- use smartcard && epatch ${FILESDIR}/openssh-3.9_p1-opensc.patch.bz2
+ use X509 && epatch "${DISTDIR}"/${X509_PATCH}
+ use sftplogging && epatch "${FILESDIR}"/openssh-4.0_p1-sftplogging-1.2-gentoo.patch.bz2
+ use skey && epatch "${FILESDIR}"/openssh-3.9_p1-skey.patch.bz2
+ use chroot && epatch "${FILESDIR}"/openssh-3.9_p1-chroot.patch
+ use selinux && epatch "${FILESDIR}"/${SELINUX_PATCH}.bz2
+ use smartcard && epatch "${FILESDIR}"/openssh-3.9_p1-opensc.patch.bz2
if ! use X509 ; then
if [[ -n ${SECURID_PATCH} ]] && use smartcard ; then
- epatch ${DISTDIR}/${SECURID_PATCH} ${FILESDIR}/openssh-securid-1.3.1-updates.patch
- use ldap && epatch ${FILESDIR}/openssh-4.0_p1-smartcard-ldap-happy.patch
+ epatch "${DISTDIR}"/${SECURID_PATCH} "${FILESDIR}"/openssh-securid-1.3.1-updates.patch
+ use ldap && epatch "${FILESDIR}"/openssh-4.0_p1-smartcard-ldap-happy.patch
fi
if use sftplogging ; then
ewarn "Sorry, sftplogging and ldap don't get along"
else
- use ldap && epatch ${DISTDIR}/${LDAP_PATCH}
+ use ldap && epatch "${DISTDIR}"/${LDAP_PATCH}
fi
elif use smartcard || use ldap ; then
ewarn "Sorry, x509 and smartcard/ldap don't get along"
fi
- use hpn && epatch ${DISTDIR}/${HPN_PATCH}
+ use hpn && epatch "${DISTDIR}"/${HPN_PATCH}
sed -i '/LD.*ssh-keysign/s:$: -Wl,-z,now:' Makefile.in || die "setuid"
diff --git a/net-misc/openssh/openssh-4.2_p1.ebuild b/net-misc/openssh/openssh-4.2_p1.ebuild
index b4179d88c9c0..910e49829d85 100644
--- a/net-misc/openssh/openssh-4.2_p1.ebuild
+++ b/net-misc/openssh/openssh-4.2_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.2_p1.ebuild,v 1.2 2005/09/08 23:54:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.2_p1.ebuild,v 1.3 2005/10/19 03:32:26 vapier Exp $
inherit eutils flag-o-matic ccc pam
@@ -49,29 +49,33 @@ src_unpack() {
unpack ${PARCH}.tar.gz
cd "${S}"
+ sed -i \
+ -e '/_PATH_XAUTH/s:/usr/X11R6/bin/xauth:/usr/bin/xauth:' \
+ pathnames.h || die
+
#epatch "${FILESDIR}"/openssh-3.9_p1-largekey.patch.bz2
epatch "${FILESDIR}"/openssh-4.2_p1-kerberos-detection.patch #80811
- use X509 && epatch ${DISTDIR}/${X509_PATCH}
- use sftplogging && epatch ${FILESDIR}/openssh-4.2_p1-sftplogging-1.4-gentoo.patch.bz2
- use skey && epatch ${FILESDIR}/openssh-3.9_p1-skey.patch.bz2
- use chroot && epatch ${FILESDIR}/openssh-3.9_p1-chroot.patch
- use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}.bz2
- use smartcard && epatch ${FILESDIR}/openssh-3.9_p1-opensc.patch.bz2
+ use X509 && epatch "${DISTDIR}"/${X509_PATCH}
+ use sftplogging && epatch "${FILESDIR}"/openssh-4.2_p1-sftplogging-1.4-gentoo.patch.bz2
+ use skey && epatch "${FILESDIR}"/openssh-3.9_p1-skey.patch.bz2
+ use chroot && epatch "${FILESDIR}"/openssh-3.9_p1-chroot.patch
+ use selinux && epatch "${FILESDIR}"/${SELINUX_PATCH}.bz2
+ use smartcard && epatch "${FILESDIR}"/openssh-3.9_p1-opensc.patch.bz2
if ! use X509 ; then
if [[ -n ${SECURID_PATCH} ]] && use smartcard ; then
- epatch ${DISTDIR}/${SECURID_PATCH} ${FILESDIR}/openssh-securid-1.3.1-updates.patch
- use ldap && epatch ${FILESDIR}/openssh-4.0_p1-smartcard-ldap-happy.patch
+ epatch "${DISTDIR}"/${SECURID_PATCH} "${FILESDIR}"/openssh-securid-1.3.1-updates.patch
+ use ldap && epatch "${FILESDIR}"/openssh-4.0_p1-smartcard-ldap-happy.patch
fi
if use sftplogging ; then
ewarn "Sorry, sftplogging and ldap don't get along"
else
- use ldap && epatch ${DISTDIR}/${LDAP_PATCH}
+ use ldap && epatch "${DISTDIR}"/${LDAP_PATCH}
fi
elif [[ -n ${SECURID_PATCH} ]] && use smartcard || use ldap ; then
ewarn "Sorry, x509 and smartcard/ldap don't get along"
fi
- [[ -n ${HPN_PATCH} ]] && use hpn && epatch ${DISTDIR}/${HPN_PATCH}
+ [[ -n ${HPN_PATCH} ]] && use hpn && epatch "${DISTDIR}"/${HPN_PATCH}
sed -i '/LD.*ssh-keysign/s:$: -Wl,-z,now:' Makefile.in || die "setuid"