summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-11-04 10:21:27 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-11-04 10:21:27 +0000
commita9bb5c65d6f18be4de936126d7b42d40644f4b32 (patch)
tree7885ef7659f1dc4db5f27c92f7370c696c400daf /net-misc
parentarm/s390/sh stable (diff)
downloadgentoo-2-a9bb5c65d6f18be4de936126d7b42d40644f4b32.tar.gz
gentoo-2-a9bb5c65d6f18be4de936126d7b42d40644f4b32.tar.bz2
gentoo-2-a9bb5c65d6f18be4de936126d7b42d40644f4b32.zip
Version bump
(Portage version: 2.1.4.5)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd/ChangeLog7
-rw-r--r--net-misc/dhcpcd/dhcpcd-4.0.4.ebuild86
2 files changed, 92 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index 6ba49c14ac55..df31a87534b0 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.221 2008/10/29 15:10:50 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.222 2008/11/04 10:21:27 armin76 Exp $
+
+*dhcpcd-4.0.4 (04 Nov 2008)
+
+ 04 Nov 2008; Raúl Porcel <armin76@gentoo.org> +dhcpcd-4.0.4.ebuild:
+ Version bump
*dhcpcd-4.99.3 (29 Oct 2008)
*dhcpcd-4.0.3 (29 Oct 2008)
diff --git a/net-misc/dhcpcd/dhcpcd-4.0.4.ebuild b/net-misc/dhcpcd/dhcpcd-4.0.4.ebuild
new file mode 100644
index 000000000000..0bd6db673657
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-4.0.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-4.0.4.ebuild,v 1.1 2008/11/04 10:21:27 armin76 Exp $
+
+EAPI=1
+
+inherit toolchain-funcs eutils
+
+MY_P="${P/_alpha/-alpha}"
+MY_P="${MY_P/_beta/-beta}"
+MY_P="${MY_P/_rc/-rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A DHCP client"
+HOMEPAGE="http://roy.marples.name/projects/dhcpcd"
+SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
+LICENSE="BSD-2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+SLOT="0"
+IUSE="+compat zeroconf"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use zeroconf; then
+ elog "Disabling zeroconf support"
+ {
+ echo
+ echo "# dhcpcd ebuild requested no zeroconf"
+ echo "noipv4ll"
+ } >> dhcpcd.conf
+ fi
+
+ if use compat; then
+ elog "dhcpcd-3 command line support enabled"
+ {
+ echo
+ echo "/* User indicated command line compatability */"
+ echo "#define CMDLINE_COMPAT"
+ } >> config.h
+ fi
+}
+
+pkg_setup() {
+ MAKE_ARGS="DBDIR=/var/lib/dhcpcd LIBEXECDIR=/lib/dhcpcd"
+}
+
+src_compile() {
+ [ -z "${MAKE_ARGS}" ] && die "MAKE_ARGS is empty"
+ emake CC="$(tc-getCC)" ${MAKE_ARGS} || die
+}
+
+src_install() {
+ local hooks="50-ntp.conf"
+ use elibc_glibc && hooks="${hooks} 50-yp.conf"
+ emake ${MAKE_ARGS} HOOKSCRIPTS="${hooks}" DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ # Upgrade the duid file to the new format if needed
+ local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ local new_duid="${ROOT}"/etc/dhcpcd.duid
+ if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
+ fi
+
+ # Move the duid to /etc, a more sensible location
+ if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
+ cp -p "${old_duid}" "${new_duid}"
+ fi
+
+ if use zeroconf; then
+ elog "You have installed dhcpcd with zeroconf support."
+ elog "This means that it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the -L flag."
+ elog "See the dhcpcd man page for more details."
+ fi
+}