summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-07-22 16:33:49 +0000
committerRoy Marples <uberlord@gentoo.org>2006-07-22 16:33:49 +0000
commit9dec1af82de09e13ed7aa88427bd3ae4e9ad6e33 (patch)
tree294f94bfa80aa2e7724bdedaca42555884105989 /net-misc
parentStable on alpha. (diff)
downloadgentoo-2-9dec1af82de09e13ed7aa88427bd3ae4e9ad6e33.tar.gz
gentoo-2-9dec1af82de09e13ed7aa88427bd3ae4e9ad6e33.tar.bz2
gentoo-2-9dec1af82de09e13ed7aa88427bd3ae4e9ad6e33.zip
Fix incorrect resolving of hostname, thanks to Bert Van Leeuwen, #141207.
(Portage version: 2.1.1_pre3-r3)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd/ChangeLog8
-rw-r--r--net-misc/dhcpcd/dhcpcd-2.0.8-r2.ebuild52
-rw-r--r--net-misc/dhcpcd/files/dhcpcd-2.0.8-no_resolve_hostname.patch13
-rw-r--r--net-misc/dhcpcd/files/digest-dhcpcd-2.0.8-r23
4 files changed, 75 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index d26061c0b2cc..0cc49a9ae39e 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.101 2006/07/21 09:59:52 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.102 2006/07/22 16:33:49 uberlord Exp $
+
+*dhcpcd-2.0.8-r2 (22 Jul 2006)
+
+ 22 Jul 2006; Roy Marples <uberlord@gentoo.org>
+ +files/dhcpcd-2.0.8-no_resolve_hostname.patch, +dhcpcd-2.0.8-r2.ebuild:
+ Fix incorrect resolving of hostname, thanks to Bert Van Leeuwen, #141207.
*dhcpcd-2.0.8-r1 (21 Jul 2006)
diff --git a/net-misc/dhcpcd/dhcpcd-2.0.8-r2.ebuild b/net-misc/dhcpcd/dhcpcd-2.0.8-r2.ebuild
new file mode 100644
index 000000000000..eed115e75def
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-2.0.8-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-2.0.8-r2.ebuild,v 1.1 2006/07/22 16:33:49 uberlord Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="A DHCP client only"
+HOMEPAGE="http://developer.berlios.de/projects/dhcpcd/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="build debug static"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+pkg_setup() {
+ if use debug ; then
+ ewarn "WARNING: dhcpcd will provide good debugging output with the"
+ ewarn "debug USE flag enabled but will not actually configure the"
+ ewarn "interface or setup /etc/resolv.conf"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Redefine the location of ntp.drift
+ sed -i 's:/etc/ntp\.drift:/var/lib/ntp/ntp.drift:' src/dhcpconfig.c
+
+ epatch "${FILESDIR}/${P}-loglevel.patch"
+ epatch "${FILESDIR}/${P}-no_resolve_hostname.patch"
+}
+
+src_compile() {
+ use static && append-flags -static
+ econf $(use_enable debug) || die
+ emake || die
+}
+
+src_install() {
+ into /
+ dosbin src/dhcpcd || die
+
+ if ! use build ; then
+ dodoc AUTHORS ChangeLog NEWS README
+ doman src/dhcpcd.8
+ fi
+}
diff --git a/net-misc/dhcpcd/files/dhcpcd-2.0.8-no_resolve_hostname.patch b/net-misc/dhcpcd/files/dhcpcd-2.0.8-no_resolve_hostname.patch
new file mode 100644
index 000000000000..ec1917a23091
--- /dev/null
+++ b/net-misc/dhcpcd/files/dhcpcd-2.0.8-no_resolve_hostname.patch
@@ -0,0 +1,13 @@
+Index: src/dhcpconfig.c
+===================================================================
+--- src/dhcpconfig.c (revision 70)
++++ src/dhcpconfig.c (working copy)
+@@ -511,7 +511,7 @@
+ else
+ logger(LOG_ERR,"dhcpConfig: fopen %s: %s", ntp_file, strerror(errno));
+ }
+- if ( ! DhcpOptions.len[hostName] )
++ if ( SetHostName && ! DhcpOptions.len[hostName] )
+ {
+ hp=gethostbyaddr((char *)&DhcpIface.ciaddr,
+ sizeof(DhcpIface.ciaddr),AF_INET);
diff --git a/net-misc/dhcpcd/files/digest-dhcpcd-2.0.8-r2 b/net-misc/dhcpcd/files/digest-dhcpcd-2.0.8-r2
new file mode 100644
index 000000000000..2177e02191bf
--- /dev/null
+++ b/net-misc/dhcpcd/files/digest-dhcpcd-2.0.8-r2
@@ -0,0 +1,3 @@
+MD5 ec91c33b6d9cb46a42f9564e573fd249 dhcpcd-2.0.8.tar.bz2 125090
+RMD160 719d65e257bea28db58a0ee6a4c200da88e616d2 dhcpcd-2.0.8.tar.bz2 125090
+SHA256 bf7b09f26be60485d888f88f63688d16feeb022cd7954cfc05a912e273757db1 dhcpcd-2.0.8.tar.bz2 125090