summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-16 18:32:09 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-16 18:32:09 +0000
commit9cbb2310bd86ed8edd6f19560c67309467cbfb7f (patch)
tree5ed137abb1f0ebeaffa5da098440e63d2bbbd823 /net-misc
parentclean up ugly ebuild and add alpha/ia64 in the process (Manifest recommit) (diff)
downloadgentoo-2-9cbb2310bd86ed8edd6f19560c67309467cbfb7f.tar.gz
gentoo-2-9cbb2310bd86ed8edd6f19560c67309467cbfb7f.tar.bz2
gentoo-2-9cbb2310bd86ed8edd6f19560c67309467cbfb7f.zip
ver bump #49629, no maketest #59327, support countries #43470
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/whois/ChangeLog8
-rw-r--r--net-misc/whois/files/digest-whois-4.6.221
-rw-r--r--net-misc/whois/whois-4.6.22.ebuild44
3 files changed, 52 insertions, 1 deletions
diff --git a/net-misc/whois/ChangeLog b/net-misc/whois/ChangeLog
index 2236e27d9f45..eebd34f59f27 100644
--- a/net-misc/whois/ChangeLog
+++ b/net-misc/whois/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/whois
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.41 2004/10/16 18:08:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.42 2004/10/16 18:32:09 vapier Exp $
+
+*whois-4.6.22 (16 Oct 2004)
+
+ 16 Oct 2004; Mike Frysinger <vapier@gentoo.org> +whois-4.6.22.ebuild:
+ Version bump #49629 by Marcin Kryczek. Restrict maketest #59327 by Daniel
+ Black. Add support for country domains #43470 by Bernd Wurst.
16 Oct 2004; Mike Frysinger <vapier@gentoo.org> whois-4.6.13-r1.ebuild:
Dont install mkpasswd anymore, shadow does #6428 by Paul Thompson.
diff --git a/net-misc/whois/files/digest-whois-4.6.22 b/net-misc/whois/files/digest-whois-4.6.22
new file mode 100644
index 000000000000..bfd2089feb99
--- /dev/null
+++ b/net-misc/whois/files/digest-whois-4.6.22
@@ -0,0 +1 @@
+MD5 b509d55935946b443fc6481f04bc8314 whois_4.6.22.tar.gz 51479
diff --git a/net-misc/whois/whois-4.6.22.ebuild b/net-misc/whois/whois-4.6.22.ebuild
new file mode 100644
index 000000000000..e9b8e75a60a4
--- /dev/null
+++ b/net-misc/whois/whois-4.6.22.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-4.6.22.ebuild,v 1.1 2004/10/16 18:32:09 vapier Exp $
+
+inherit eutils
+
+MY_P=${P/-/_}
+DESCRIPTION="improved Whois Client"
+HOMEPAGE="http://www.linux.it/~md/software/"
+SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+RESTRICT="maketest" #59327
+
+RDEPEND="virtual/libc
+ net-dns/libidn"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-4.6.13-gentoo-security.patch
+
+ if use nls ; then
+ cd po
+ sed -i -e "s:/usr/bin/install:install:" Makefile
+ else
+ sed -i -e "s:cd po.*::" Makefile
+ fi
+}
+
+src_compile() {
+ emake OPTS="${CFLAGS}" HAVE_LIBIDN=1 || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ make BASEDIR=${D} prefix=/usr install || die
+ dodoc README whois.conf
+}