summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-09-14 12:32:09 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-09-14 12:32:09 +0000
commit8e665e870d08142e17ceda75df87316db32a77dd (patch)
treeed17fdcd836be7fd5216c18f0fbe8959adb698f7 /net-misc
parentold (diff)
downloadgentoo-2-8e665e870d08142e17ceda75df87316db32a77dd.tar.gz
gentoo-2-8e665e870d08142e17ceda75df87316db32a77dd.tar.bz2
gentoo-2-8e665e870d08142e17ceda75df87316db32a77dd.zip
Version bump, two patches now upstream. With thanks to Jaco Kroon for a new non-Digium hardware support patch. Closes bug #336525.
(Portage version: 2.1.9.2/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dahdi/ChangeLog8
-rw-r--r--net-misc/dahdi/dahdi-2.4.0.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/net-misc/dahdi/ChangeLog b/net-misc/dahdi/ChangeLog
index 3d7d03d12094..8f5d469ff62a 100644
--- a/net-misc/dahdi/ChangeLog
+++ b/net-misc/dahdi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/dahdi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dahdi/ChangeLog,v 1.8 2010/06/08 16:49:47 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dahdi/ChangeLog,v 1.9 2010/09/14 12:32:09 chainsaw Exp $
+
+*dahdi-2.4.0 (14 Sep 2010)
+
+ 14 Sep 2010; <chainsaw@gentoo.org> +dahdi-2.4.0.ebuild:
+ Version bump, two patches now upstream. With thanks to Jaco Kroon for a
+ new non-Digium hardware support patch. Closes bug #336525.
*dahdi-2.3.0.1 (08 Jun 2010)
diff --git a/net-misc/dahdi/dahdi-2.4.0.ebuild b/net-misc/dahdi/dahdi-2.4.0.ebuild
new file mode 100644
index 000000000000..57e3ed872102
--- /dev/null
+++ b/net-misc/dahdi/dahdi-2.4.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dahdi/dahdi-2.4.0.ebuild,v 1.1 2010/09/14 12:32:09 chainsaw Exp $
+
+EAPI=3
+
+inherit base linux-mod eutils flag-o-matic
+
+MY_P="${P/dahdi/dahdi-linux}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Kernel modules for Digium compatible hardware (formerly known as Zaptel)."
+HOMEPAGE="http://www.asterisk.org"
+SRC_URI="http://downloads.asterisk.org/pub/telephony/dahdi-linux/releases/${MY_P}.tar.gz
+http://downloads.digium.com/pub/telephony/firmware/releases/dahdi-fwload-vpmadt032-1.25.0.tar.gz
+http://downloads.digium.com/pub/telephony/firmware/releases/dahdi-fw-oct6114-064-1.05.01.tar.gz
+http://downloads.digium.com/pub/telephony/firmware/releases/dahdi-fw-oct6114-128-1.05.01.tar.gz
+http://downloads.digium.com/pub/telephony/firmware/releases/dahdi-fw-tc400m-MR6.12.tar.gz
+http://downloads.digium.com/pub/telephony/firmware/releases/dahdi-fwload-vpmadt032-1.20.0.tar.gz
+http://downloads.digium.com/pub/telephony/firmware/releases/dahdi-fw-hx8-2.06.tar.gz
+mirror://gentoo/gentoo-dahdi-patchset-0.4.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+EPATCH_SUFFIX="diff"
+PATCHES=( "${WORKDIR}/dahdi-patchset" )
+
+src_unpack() {
+ unpack ${A}
+ # Copy the firmware tarballs over, the makefile will try and download them otherwise
+ for file in ${A} ; do
+ cp "${DISTDIR}"/${file} "${MY_P}"/drivers/dahdi/firmware/
+ done
+ # But without the .bin's it'll still fall over and die, so copy those too.
+ cp *.bin "${MY_P}"/drivers/dahdi/firmware/
+}
+
+src_compile() {
+ unset ARCH
+ emake KSRC="${KERNEL_DIR}" DESTDIR="${D}" all || die "Compilation failed"
+}
+
+src_install() {
+ # setup directory structure so udev rules get installed
+ mkdir -p "${D}"/etc/udev/rules.d
+
+ einfo "Installing kernel module"
+ emake KSRC="${KERNEL_DIR}" DESTDIR="${D}" install || die "Installation failed"
+ rm -rf "$D"/lib/modules/*/modules.*
+}