summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-09-16 09:38:12 +0000
committerPacho Ramos <pacho@gentoo.org>2012-09-16 09:38:12 +0000
commit8b75f9c74cd489f44942bf4726454e5e322ffe61 (patch)
treebb15799acbb352a511ca72691d7277c81f64451d /net-misc
parentApply debian patches to fix compilation errors like gcc-4.7 compat issues, al... (diff)
downloadgentoo-2-8b75f9c74cd489f44942bf4726454e5e322ffe61.tar.gz
gentoo-2-8b75f9c74cd489f44942bf4726454e5e322ffe61.tar.bz2
gentoo-2-8b75f9c74cd489f44942bf4726454e5e322ffe61.zip
Don't collide with mgetty, bug #429808 by flameeyes.
(Portage version: 2.1.11.17/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/efax/ChangeLog7
-rw-r--r--net-misc/efax/efax-0.9a-r4.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/net-misc/efax/ChangeLog b/net-misc/efax/ChangeLog
index e408c708ff24..917e6c008d7f 100644
--- a/net-misc/efax/ChangeLog
+++ b/net-misc/efax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/efax
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/efax/ChangeLog,v 1.19 2012/06/27 16:54:39 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/efax/ChangeLog,v 1.20 2012/09/16 09:38:12 pacho Exp $
+
+*efax-0.9a-r4 (16 Sep 2012)
+
+ 16 Sep 2012; Pacho Ramos <pacho@gentoo.org> +efax-0.9a-r4.ebuild:
+ Don't collide with mgetty, bug #429808 by flameeyes.
27 Jun 2012; Michael Palimaka <kensington@gentoo.org> -efax-0.9a-r2.ebuild,
-efax-0.9a.ebuild:
diff --git a/net-misc/efax/efax-0.9a-r4.ebuild b/net-misc/efax/efax-0.9a-r4.ebuild
new file mode 100644
index 000000000000..fd35ed4df0f6
--- /dev/null
+++ b/net-misc/efax/efax-0.9a-r4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/efax/efax-0.9a-r4.ebuild,v 1.1 2012/09/16 09:38:12 pacho Exp $
+
+EAPI=4
+inherit eutils
+
+S="${WORKDIR}/${P}-001114"
+
+DESCRIPTION="A simple fax program for single-user systems"
+HOMEPAGE="http://www.cce.com/efax"
+SRC_URI="http://www.cce.com/efax/download/${P}-001114.tar.gz
+ mirror://debian/pool/main/e/efax/efax_0.9a-19.diff.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+
+src_prepare () {
+ epatch "${WORKDIR}/${PN}_${PV}-19.diff"
+ rm -f "${S}"/${P}/debian/patches/series "${S}"/${P}/debian/patches/00list
+ EPATCH_FORCE="yes" epatch "${S}"/${P}/debian/patches/*
+
+ epatch "${FILESDIR}/${P}-fax-command.patch" #327737
+
+ # remove strip command as per bug #240932
+ sed -i -e '/strip/d' Makefile
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install () {
+ dobin efax efix fax
+ doman efax.1 efix.1
+ newman fax.1 efax-fax.1 # Don't collide with net-dialup/mgetty, bug #429808
+ dodoc README
+}