summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-07-23 18:17:19 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-07-23 18:17:19 +0000
commit85e351e2dd993cd11cc5e868f4f677c3aba9fbc6 (patch)
treee4e9c36be705cfc08b087f7b774747e346e67853 /net-misc
parentNew prerelease version of the EVMS tools that works with the mjc kernels, (diff)
downloadgentoo-2-85e351e2dd993cd11cc5e868f4f677c3aba9fbc6.tar.gz
gentoo-2-85e351e2dd993cd11cc5e868f4f677c3aba9fbc6.tar.bz2
gentoo-2-85e351e2dd993cd11cc5e868f4f677c3aba9fbc6.zip
Version bump
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/nt/ChangeLog8
-rw-r--r--net-misc/nt/files/digest-nt-2.021
-rw-r--r--net-misc/nt/nt-2.02.ebuild74
3 files changed, 82 insertions, 1 deletions
diff --git a/net-misc/nt/ChangeLog b/net-misc/nt/ChangeLog
index 8c52e2b9b128..2d723bd452b1 100644
--- a/net-misc/nt/ChangeLog
+++ b/net-misc/nt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/nt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nt/ChangeLog,v 1.6 2002/07/09 10:05:47 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nt/ChangeLog,v 1.7 2002/07/23 18:17:19 aliz Exp $
+
+*nt-2.0.2 (23 Jul 2002)
+
+ 18 Jul 2002; Daniel Ahlberg <aliz@gentoo.org> nt-2.02.ebuild :
+
+ New version that should fix GCC 3.1 compile problems.
*nt-2.01 (7 Jun 2002)
diff --git a/net-misc/nt/files/digest-nt-2.02 b/net-misc/nt/files/digest-nt-2.02
new file mode 100644
index 000000000000..b379f8e63cb3
--- /dev/null
+++ b/net-misc/nt/files/digest-nt-2.02
@@ -0,0 +1 @@
+MD5 54a134fe5edfb3558fe07ac76f08a901 d4x-2.02.tar.gz 1253235
diff --git a/net-misc/nt/nt-2.02.ebuild b/net-misc/nt/nt-2.02.ebuild
new file mode 100644
index 000000000000..1e8b53f5bae7
--- /dev/null
+++ b/net-misc/nt/nt-2.02.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nt/nt-2.02.ebuild,v 1.1 2002/07/23 18:17:19 aliz Exp $
+
+#name of tarball changed
+MY_P="${P/nt/d4x}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="GTK based download manager for X."
+SRC_URI="http://www.krasu.ru/soft/chuchelo/files/${MY_P}.tar.gz"
+HOMEPAGE="http://www.krasu.ru/soft/chuchelo/"
+KEYWORDS="x86"
+LICENSE="nt"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=dev-libs/glib-1.2.10
+ >=media-libs/gdk-pixbuf-0.2.5
+ esd? ( >=media-sound/esound-0.2.7 )"
+RDEPEND=${DEPEND}
+
+SLOT="0"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # Use our own $CXXFLAGS
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:CXXFLAGS=\"-O2\":CXXFLAGS=\"${CXXFLAGS}\":g" \
+ configure.orig >configure
+}
+
+src_compile() {
+
+ myconf=""
+ use nls || myconf="${myconf} --disable-nls"
+ use esd || myconf="${myconf} --disable-esd"
+ use oss || myconf="${myconf} --disable-oss"
+
+ ./configure --host=${HOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-release \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+
+ dodir /usr/bin
+ dodir /usr/share/d4x
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog* NEWS PLANS README TODO
+ cd ${S}/DOC
+ dodoc FAQ* LICENSE NAMES TROUBLES THANKS
+
+ cd ${S}
+ insinto /usr/share/pixmaps
+ doins *.png *.xpm
+
+ if [ "`use gnome`" ] ; then
+ insinto /usr/share/gnome/apps/Internet
+ doins nt.desktop
+ fi
+}
+
+