summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2010-01-13 14:09:57 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2010-01-13 14:09:57 +0000
commit8355dfc6b0842ebe695a8759235f5fac8bc48bf8 (patch)
treee66923f947a7d7259cdaf51fae4df1e6d717fa35 /net-misc
parentadd hp-jdk-bin as alternative (diff)
downloadgentoo-2-8355dfc6b0842ebe695a8759235f5fac8bc48bf8.tar.gz
gentoo-2-8355dfc6b0842ebe695a8759235f5fac8bc48bf8.tar.bz2
gentoo-2-8355dfc6b0842ebe695a8759235f5fac8bc48bf8.zip
upgrade from qt3 to qt4 using Qt3Support. fix some prefix issues.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/mico/ChangeLog10
-rw-r--r--net-misc/mico/files/mico-2.3.13-qt4-nothread.patch23
-rw-r--r--net-misc/mico/mico-2.3.13-r2.ebuild119
3 files changed, 150 insertions, 2 deletions
diff --git a/net-misc/mico/ChangeLog b/net-misc/mico/ChangeLog
index 01e5f5f1e655..18275d767cf6 100644
--- a/net-misc/mico/ChangeLog
+++ b/net-misc/mico/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/mico
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/ChangeLog,v 1.23 2009/09/28 09:35:28 haubi Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/ChangeLog,v 1.24 2010/01/13 14:09:57 haubi Exp $
+
+*mico-2.3.13-r2 (13 Jan 2010)
+
+ 13 Jan 2010; Michael Haubenwallner <haubi@gentoo.org>
+ +mico-2.3.13-r2.ebuild, +files/mico-2.3.13-qt4-nothread.patch:
+ upgrade from qt3 to qt4 using Qt3Support. fix some prefix issues.
28 Sep 2009; Michael Haubenwallner <haubi@gentoo.org>
mico-2.3.13-r1.ebuild, +files/mico-2.3.13-winnt.patch.bz2:
diff --git a/net-misc/mico/files/mico-2.3.13-qt4-nothread.patch b/net-misc/mico/files/mico-2.3.13-qt4-nothread.patch
new file mode 100644
index 000000000000..d87c33e45feb
--- /dev/null
+++ b/net-misc/mico/files/mico-2.3.13-qt4-nothread.patch
@@ -0,0 +1,23 @@
+qt4 doesn't provide different libraries for threading.
+--- configure.in.orig 2010-01-12 16:40:06.935594142 +0100
++++ configure.in 2010-01-12 16:40:37.742311509 +0100
+@@ -1124,7 +1124,7 @@
+ AC_MSG_WARN(cannot find moc. QT parts disabled.)
+ HAVE_QT=no
+ fi
+- if test X"$HAVE_THREADS" = Xyes; then
++ if false && test X"$HAVE_THREADS" = Xyes; then
+ AC_CHECK_LIB(qt-mt, open, qt_mt=yes, qt_mt=no)
+ if test X"$qt_mt" = Xno; then
+ AC_MSG_WARN(cannot find multi-threaded version of QT library. QT parts disabled.)
+--- configure.orig 2010-01-12 16:40:11.555621774 +0100
++++ configure 2010-01-12 16:40:51.125633810 +0100
+@@ -4197,7 +4197,7 @@
+ echo "configure: warning: cannot find moc. QT parts disabled." 1>&2
+ HAVE_QT=no
+ fi
+- if test X"$HAVE_THREADS" = Xyes; then
++ if false && test X"$HAVE_THREADS" = Xyes; then
+ echo $ac_n "checking for open in -lqt-mt""... $ac_c" 1>&6
+ echo "configure:4189: checking for open in -lqt-mt" >&5
+ ac_lib_var=`echo qt-mt'_'open | sed 'y%./+-%__p_%'`
diff --git a/net-misc/mico/mico-2.3.13-r2.ebuild b/net-misc/mico/mico-2.3.13-r2.ebuild
new file mode 100644
index 000000000000..924d18847e28
--- /dev/null
+++ b/net-misc/mico/mico-2.3.13-r2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.13-r2.ebuild,v 1.1 2010/01/13 14:09:57 haubi Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A freely available and fully compliant implementation of the CORBA standard"
+HOMEPAGE="http://www.mico.org/"
+SRC_URI="http://www.mico.org/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~ppc-aix ~ia64-hpux ~amd64-linux ~x86-linux ~sparc-solaris ~x86-winnt"
+IUSE="gtk postgres qt4 ssl tcl threads X"
+
+# doesn't compile:
+# bluetooth? ( net-wireless/bluez-libs )
+
+RDEPEND="
+ gtk? ( x11-libs/gtk+:2 )
+ postgres? ( dev-db/postgresql )
+ qt4? ( x11-libs/qt-gui:4[qt3support] )
+ ssl? ( dev-libs/openssl )
+ tcl? ( dev-lang/tcl )
+ X? ( x11-libs/libXt )
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/flex-2.5.2
+ >=sys-devel/bison-1.22
+"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nolibcheck.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-pthread.patch
+ epatch "${FILESDIR}"/${P}-aix.patch
+ epatch "${FILESDIR}"/${P}-hpux.patch
+ epatch "${FILESDIR}"/${P}-as-needed.patch #280678
+ epatch "${FILESDIR}"/${P}-qt4-nothread.patch
+
+ [[ ${CHOST} == *-winnt* ]] && epatch "${FILESDIR}"/${P}-winnt.patch.bz2
+
+ # cannot use big TOC (AIX only), gdb doesn't like it.
+ # This assumes that the compiler (or -wrapper) uses
+ # gcc flag '-mminimal-toc' for compilation.
+ sed -i -e 's/,-bbigtoc//' "${S}"/configure
+
+ if use qt4; then
+ sed -i -e "s, -lqt\", $(pkg-config --libs Qt3Support)\"," configure ||
+ die "cannot update to use Qt3Support of qt4"
+ fi
+}
+
+src_configure() {
+ tc-export CC CXX
+
+ if use gtk; then
+ # set up gtk-1 wrapper for gtk-2
+ mkdir "${T}"/path || die "failed to create temporary path"
+ cp "${FILESDIR}"/gtk-config "${T}"/path || die "failed to dupe gtk-config"
+ chmod +x "${T}"/path/gtk-config || die "failed to arm gtk-config"
+ export PATH="${T}"/path:${PATH}
+ fi
+
+ # Don't know which version of JavaCUP would suffice, but there is no
+ # configure argument to disable checking for JavaCUP.
+ # So we override the configure check to not find 'javac'.
+ export ac_cv_path_JAVAC=no
+
+ # '--without-ssl' just does not add another search path - the only way
+ # to disable openssl utilization seems to override the configure check.
+ use ssl || export ac_cv_lib_ssl_open=no
+
+ # CFLAGS aren't used when checking for <qapplication.h>, but CPPFLAGS are.
+ use qt4 && append-cppflags $(pkg-config --cflags Qt3Support)
+
+ local winopts=
+ if [[ ${CHOST} == *-winnt* ]]; then
+ # disabling static libs, since ar on interix takes nearly
+ # one hour per library, thanks to mico's monster objects.
+ winopts="${winopts} --disable-threads --disable-static --enable-final"
+ append-flags -D__STDC__
+ fi
+
+ # http://www.mico.org/pipermail/mico-devel/2009-April/010285.html
+ [[ ${CHOST} == *-hpux* ]] && append-cppflags -D_XOPEN_SOURCE_EXTENDED
+
+ # '--without-*' or '--with-*=no' does not disable some features, the value
+ # needs to be empty instead. This applies to: bluetooth, gtk, pgsql, qt, tcl.
+ # But --without-x works.
+
+ # bluetooth and wireless both don't compile cleanly
+ econf \
+ --disable-mini-stl \
+ $(use_enable threads) \
+ --with-gtk=$(use gtk && echo "${EPREFIX}"/usr) \
+ --with-pgsql=$(use postgres && echo "${EPREFIX}"/usr) \
+ --with-qt=$(use qt4 && echo "${EPREFIX}"/usr) \
+ --with-tcl=$(use tcl && echo "${EPREFIX}"/usr) \
+ $(use_with X x "${EPREFIX}"/usr) \
+ --with-bluetooth='' \
+ --disable-wireless \
+ ${winopts}
+}
+
+src_install() {
+ emake INSTDIR="${D}${EPREFIX}"/usr SHARED_INSTDIR="${D}${EPREFIX}"/usr install LDCONFIG=: || die "install failed"
+
+ dodir /usr/share || die
+ mv "${D}${EPREFIX}"/usr/man "${D}${EPREFIX}"/usr/share || die
+ dodir /usr/share/doc/${PF} || die
+ mv "${D}${EPREFIX}"/usr/doc "${D}${EPREFIX}"/usr/share/doc/${PF} || die
+
+ dodoc BUGS CHANGES* CONVERT FAQ README* ROADMAP TODO VERSION WTODO || die
+}