summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2013-05-03 07:56:29 +0000
committerDirkjan Ochtman <djc@gentoo.org>2013-05-03 07:56:29 +0000
commit7bd9dce768d1ca0c5b6b2cfcfd727fadad2da927 (patch)
treeebe2ccea5978e961d9e4bb4208ce59600dc57b06 /net-misc
parentUpstream renamed sys-process/crtools to sys-process/criu. (diff)
downloadgentoo-2-7bd9dce768d1ca0c5b6b2cfcfd727fadad2da927.tar.gz
gentoo-2-7bd9dce768d1ca0c5b6b2cfcfd727fadad2da927.tar.bz2
gentoo-2-7bd9dce768d1ca0c5b6b2cfcfd727fadad2da927.zip
Add polarssl support to openvpn-9999 ebuild.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 6B065BFB)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openvpn/ChangeLog5
-rw-r--r--net-misc/openvpn/openvpn-9999.ebuild12
2 files changed, 13 insertions, 4 deletions
diff --git a/net-misc/openvpn/ChangeLog b/net-misc/openvpn/ChangeLog
index 1ece8f360e3b..707eac6d665a 100644
--- a/net-misc/openvpn/ChangeLog
+++ b/net-misc/openvpn/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/openvpn
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/ChangeLog,v 1.248 2013/05/03 07:49:14 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/ChangeLog,v 1.249 2013/05/03 07:56:29 djc Exp $
+
+ 03 May 2013; Dirkjan Ochtman <djc@gentoo.org> openvpn-9999.ebuild:
+ Add polarssl for 9999 ebuild (thanks to josh.cepek@usa.net).
*openvpn-2.3.1 (03 May 2013)
diff --git a/net-misc/openvpn/openvpn-9999.ebuild b/net-misc/openvpn/openvpn-9999.ebuild
index 8677589d856e..6aadd1bb6ac5 100644
--- a/net-misc/openvpn/openvpn-9999.ebuild
+++ b/net-misc/openvpn/openvpn-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-9999.ebuild,v 1.6 2013/01/12 14:43:29 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-9999.ebuild,v 1.7 2013/05/03 07:56:29 djc Exp $
EAPI=4
@@ -13,9 +13,10 @@ HOMEPAGE="http://openvpn.net/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="examples down-root iproute2 pam passwordsave pkcs11 +plugins selinux +ssl +lzo static userland_BSD"
+IUSE="examples down-root iproute2 pam passwordsave pkcs11 +plugins polarssl selinux +ssl +lzo static userland_BSD"
REQUIRED_USE="static? ( !plugins !pkcs11 )
+ polarssl? ( ssl )
!plugins? ( !pam !down-root )"
DEPEND="
@@ -24,7 +25,9 @@ DEPEND="
)
pam? ( virtual/pam )
selinux? ( sec-policy/selinux-openvpn )
- ssl? ( >=dev-libs/openssl-0.9.7 )
+ ssl? (
+ !polarssl? ( >=dev-libs/openssl-0.9.7 ) polarssl? ( >=net-libs/polarssl-1.1.0 )
+ )
lzo? ( >=dev-libs/lzo-1.07 )
pkcs11? ( >=dev-libs/pkcs11-helper-1.05 )"
RDEPEND="${DEPEND}"
@@ -35,7 +38,10 @@ src_prepare() {
src_configure() {
use static && LDFLAGS="${LDFLAGS} -Xcompiler -static"
+ local myconf
+ use polarssl && myconf="--with-crypto-library=polarssl"
econf \
+ ${myconf} \
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
--with-plugindir="${ROOT}/usr/$(get_libdir)/$PN" \
$(use_enable passwordsave password-save) \