summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2011-12-10 17:34:01 +0000
committerThomas Kahle <tomka@gentoo.org>2011-12-10 17:34:01 +0000
commit75fe40cbe4b32cd03d8be396a2b2b9c9c5908b5b (patch)
treef19264d9d135beac048d72603d8d8902ed638f63 /net-misc
parentHandle sparc64-* in arch configuration. (diff)
downloadgentoo-2-75fe40cbe4b32cd03d8be396a2b2b9c9c5908b5b.tar.gz
gentoo-2-75fe40cbe4b32cd03d8be396a2b2b9c9c5908b5b.tar.bz2
gentoo-2-75fe40cbe4b32cd03d8be396a2b2b9c9c5908b5b.zip
Bump to snapshot of 1.7.1 beta 3 to fix accumulated bugs like bug 391397.
Added Systemd file (bug 393505) (Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wicd/ChangeLog10
-rw-r--r--net-misc/wicd/files/wicd-1.7.1_pre20111210-wpa-psk-hex-template.patch30
-rw-r--r--net-misc/wicd/wicd-1.7.1_pre20111210.ebuild114
3 files changed, 153 insertions, 1 deletions
diff --git a/net-misc/wicd/ChangeLog b/net-misc/wicd/ChangeLog
index 3e37a4e7c70c..2322837b92fa 100644
--- a/net-misc/wicd/ChangeLog
+++ b/net-misc/wicd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/wicd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.99 2011/12/07 13:28:41 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.100 2011/12/10 17:34:01 tomka Exp $
+
+*wicd-1.7.1_pre20111210 (10 Dec 2011)
+
+ 10 Dec 2011; Thomas Kahle <tomka@gentoo.org> +wicd-1.7.1_pre20111210.ebuild,
+ +files/wicd-1.7.1_pre20111210-wpa-psk-hex-template.patch:
+ Bump to snapshot of 1.7.1 beta 3 to fix accumulated bugs like bug 391397.
+
+ Added Systemd file (bug 393505)
07 Dec 2011; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Whitespace.
diff --git a/net-misc/wicd/files/wicd-1.7.1_pre20111210-wpa-psk-hex-template.patch b/net-misc/wicd/files/wicd-1.7.1_pre20111210-wpa-psk-hex-template.patch
new file mode 100644
index 000000000000..6736cb7b8d1b
--- /dev/null
+++ b/net-misc/wicd/files/wicd-1.7.1_pre20111210-wpa-psk-hex-template.patch
@@ -0,0 +1,30 @@
+diff -U 3 -dHrN wicd.org/encryption/templates/active wicd/encryption/templates/active
+--- wicd.org/encryption/templates/active 2011-12-05 16:22:49.584224158 +0100
++++ wicd/encryption/templates/active 2011-12-05 16:16:10.736172566 +0100
+@@ -1,6 +1,7 @@
+ wpa
+ wpa-peap
+ wpa-psk
++wpa-psk-hex
+ wpa2-leap
+ wpa2-peap
+ wep-hex
+diff -U 3 -dHrN wicd.org/encryption/templates/wpa-psk-hex wicd/encryption/templates/wpa-psk-hex
+--- wicd.org/encryption/templates/wpa-psk-hex 1970-01-01 01:00:00.000000000 +0100
++++ wicd/encryption/templates/wpa-psk-hex 2011-12-05 16:16:43.428012863 +0100
+@@ -0,0 +1,15 @@
++name = WPA 1/2 (Preshared Hex Key)
++author = Thomas Kahle
++version = 1
++require apsk *Preshared_Key
++-----
++ctrl_interface=/var/run/wpa_supplicant
++network={
++ ssid="$_ESSID"
++ scan_ssid=$_SCAN
++ proto=WPA RSN
++ key_mgmt=WPA-PSK
++ pairwise=CCMP TKIP
++ group=CCMP TKIP
++ psk=$_APSK
++}
diff --git a/net-misc/wicd/wicd-1.7.1_pre20111210.ebuild b/net-misc/wicd/wicd-1.7.1_pre20111210.ebuild
new file mode 100644
index 000000000000..900e6523e28d
--- /dev/null
+++ b/net-misc/wicd/wicd-1.7.1_pre20111210.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/wicd-1.7.1_pre20111210.ebuild,v 1.1 2011/12/10 17:34:01 tomka Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="ncurses? xml"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
+inherit eutils distutils systemd
+
+MY_PV="${PN}-1.7.1"
+S="${WORKDIR}/${MY_PV}"
+
+DESCRIPTION="A lightweight wired and wireless network manager for Linux"
+HOMEPAGE="http://wicd.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~tomka/files/${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="X +gtk ioctl libnotify ncurses nls +pm-utils"
+
+DEPEND=""
+# Maybe virtual/dhcp would work, but there are enough problems with
+# net-misc/dhcp that I want net-misc/dhcpcd to be guarenteed to be considered
+# first if none are installed.
+RDEPEND="
+ dev-python/dbus-python
+ X? ( gtk? ( dev-python/pygtk
+ || (
+ x11-libs/gksu
+ kde-base/kdesu
+ )
+ )
+ )
+ || (
+ net-misc/dhcpcd
+ net-misc/dhcp
+ net-misc/pump
+ )
+ net-wireless/wireless-tools
+ net-wireless/wpa_supplicant
+ || (
+ sys-apps/net-tools
+ sys-apps/ethtool
+ )
+ !gtk? ( dev-python/pygobject:2 )
+ ioctl? ( dev-python/python-iwscan dev-python/python-wpactrl )
+ libnotify? ( dev-python/notify-python )
+ ncurses? (
+ dev-python/urwid
+ dev-python/pygobject:2
+ )
+ pm-utils? ( >=sys-power/pm-utils-1.1.1 )
+ "
+DOCS="CHANGES NEWS AUTHORS README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.7.1_beta2-init.patch
+ epatch "${FILESDIR}"/${PN}-init-sve-start.patch
+ # Add a template for hex psk's and wpa (Bug 306423)
+ epatch "${FILESDIR}"/${P}-wpa-psk-hex-template.patch
+ # get rid of opts variable to fix bug 381885
+ sed -i "/opts/d" "in/init=gentoo=wicd.in"
+ # Need to ensure that generated scripts use Python 2 at run time.
+ sed -e "s:self.python = '/usr/bin/python':self.python = '/usr/bin/python2':" \
+ -i setup.py || die "sed failed"
+ python_copy_sources
+}
+
+src_configure() {
+ local myconf
+ use gtk || myconf="${myconf} --no-install-gtk"
+ use libnotify || myconf="${myconf} --no-use-notifications"
+ use ncurses || myconf="${myconf} --no-install-ncurses"
+ use pm-utils || myconf="${myconf} --no-install-pmutils"
+ configuration() {
+ $(PYTHON) ./setup.py configure --no-install-docs --resume=/usr/share/wicd/scripts/ --suspend=/usr/share/wicd/scripts/ --verbose ${myconf}
+ }
+ python_execute_function -s configuration
+}
+
+src_install() {
+ distutils_src_install
+ keepdir /var/lib/wicd/configurations \
+ || die "keepdir failed, critical for this app"
+ keepdir /etc/wicd/scripts/{postconnect,disconnect,preconnect} \
+ || die "keepdir failed, critical for this app"
+ keepdir /var/log/wicd \
+ || die "keepdir failed, critical for this app"
+ use nls || rm -rf "${D}"/usr/share/locale
+ systemd_dounit "${S}/other/wicd.service"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "You may need to restart the dbus service after upgrading wicd."
+ echo
+ elog "To start wicd at boot, add /etc/init.d/wicd to a runlevel and:"
+ elog "- Remove all net.* initscripts (except for net.lo) from all runlevels"
+ elog "- Add these scripts to the RC_PLUG_SERVICES line in /etc/rc.conf"
+ elog "(For example, rc_hotplug=\"!net.eth* !net.wlan*\")"
+ # Maintainer's note: the consolekit use flag short circuits a dbus rule and
+ # allows the connection. Else, you need to be in the group.
+ if ! has_version sys-auth/pambase[consolekit]; then
+ ewarn "Wicd-1.6 and newer requires your user to be in the 'users' group. If"
+ ewarn "you are not in that group, then modify /etc/dbus-1/system.d/wicd.conf"
+ fi
+}