summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-04 17:33:18 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-04 17:33:18 +0000
commit726f44a0d2559b002663e3b271c1d5134c0c5df1 (patch)
tree966bd60b2b6caba020d424157b6277a68ed7f654 /net-misc
parentadd use-dep for libsdl (diff)
downloadgentoo-2-726f44a0d2559b002663e3b271c1d5134c0c5df1.tar.gz
gentoo-2-726f44a0d2559b002663e3b271c1d5134c0c5df1.tar.bz2
gentoo-2-726f44a0d2559b002663e3b271c1d5134c0c5df1.zip
Version bump.
(Portage version: 2.2_rc55/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/unison/ChangeLog8
-rw-r--r--net-misc/unison/unison-2.32.52.ebuild85
2 files changed, 92 insertions, 1 deletions
diff --git a/net-misc/unison/ChangeLog b/net-misc/unison/ChangeLog
index be8082a67bc0..521174c97615 100644
--- a/net-misc/unison/ChangeLog
+++ b/net-misc/unison/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/unison
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.60 2009/08/28 21:59:21 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.61 2009/12/04 17:33:18 flameeyes Exp $
+
+*unison-2.32.52 (04 Dec 2009)
+
+ 04 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +unison-2.32.52.ebuild:
+ Version bump.
28 Aug 2009; Petteri Räty <betelgeuse@gentoo.org>
unison-2.27.57-r1.ebuild:
diff --git a/net-misc/unison/unison-2.32.52.ebuild b/net-misc/unison/unison-2.32.52.ebuild
new file mode 100644
index 000000000000..53ab61679cc2
--- /dev/null
+++ b/net-misc/unison/unison-2.32.52.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.32.52.ebuild,v 1.1 2009/12/04 17:33:18 flameeyes Exp $
+
+EAPI="2"
+
+inherit eutils versionator
+
+IUSE="gtk doc static debug threads +ocamlopt"
+
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="http://www.cis.upenn.edu/~bcpierce/unison/"
+LICENSE="GPL-2"
+SLOT="$(get_version_component_range 1-2 ${PV})"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+# ocaml version so we are sure it has ocamlopt use flag
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ gtk? ( >=dev-ml/lablgtk-2.2 )"
+
+RDEPEND="gtk? ( >=dev-ml/lablgtk-2.2
+ || ( net-misc/x11-ssh-askpass net-misc/ssh-askpass-fullscreen ) )
+ !net-misc/unison:0
+ app-admin/eselect-unison"
+
+#PDEPEND="gtk? ( media-fonts/font-schumacher-misc )"
+
+SRC_URI="http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}.tar.gz
+ doc? ( http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.pdf
+ http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.html )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.27.57-as-needed.patch"
+}
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ myconf="$myconf THREADS=true"
+ fi
+
+ if use static; then
+ myconf="$myconf STATIC=true"
+ fi
+
+ if use debug; then
+ myconf="$myconf DEBUGGING=true"
+ fi
+
+ if use gtk; then
+ myconf="$myconf UISTYLE=gtk2"
+ else
+ myconf="$myconf UISTYLE=text"
+ fi
+
+ use ocamlopt || myconf="$myconf NATIVE=false"
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake $myconf CFLAGS="" buildexecutable || die "error making unsion"
+}
+
+src_test() {
+ emake selftest || die "selftest failed"
+}
+
+src_install () {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ newbin unison unison-${SLOT} || die
+ dodoc BUGS.txt CONTRIB INSTALL NEWS \
+ README ROADMAP.txt TODO.txt || die
+
+ if use doc; then
+ dohtml "${DISTDIR}/${P}-manual.html" || die
+ dodoc "${DISTDIR}/${P}-manual.pdf" || die
+ fi
+ use ocamlopt || export STRIP_MASK="*/bin/*"
+}
+
+pkg_postinst() {
+ elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
+ elog "in your profile files to access exactly this version over ssh."
+ elog "Or you can use 'eselect unison' to set the version."
+}