summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-09-08 11:19:19 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-09-08 11:19:19 +0000
commit64a4d9bb6a6b8dff6659d277e7b86352e579f8b0 (patch)
tree64b38902b2053f206e8295ad6f40ffa44720dbc4 /net-misc
parentRemove unneeded IUSE. (diff)
downloadgentoo-2-64a4d9bb6a6b8dff6659d277e7b86352e579f8b0.tar.gz
gentoo-2-64a4d9bb6a6b8dff6659d277e7b86352e579f8b0.tar.bz2
gentoo-2-64a4d9bb6a6b8dff6659d277e7b86352e579f8b0.zip
Revision bump: EAPI 5, add subslot to dev-libs/boost dependency, fix building with newer boost, wrt bug #497320. Thanks to Franz Fellner <alpine.art.de AT gmail.com> for provided patch. Drop old revision
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/cocaine-core/ChangeLog12
-rw-r--r--net-misc/cocaine-core/cocaine-core-0.9.2-r1.ebuild (renamed from net-misc/cocaine-core/cocaine-core-0.9.2.ebuild)16
-rw-r--r--net-misc/cocaine-core/files/cocaine-core-0.9.2-boost-1.53.patch13
3 files changed, 32 insertions, 9 deletions
diff --git a/net-misc/cocaine-core/ChangeLog b/net-misc/cocaine-core/ChangeLog
index 1596dd02be15..452a7be66e7d 100644
--- a/net-misc/cocaine-core/ChangeLog
+++ b/net-misc/cocaine-core/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/cocaine-core
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cocaine-core/ChangeLog,v 1.1 2013/01/28 08:00:44 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cocaine-core/ChangeLog,v 1.2 2014/09/08 11:19:19 pinkbyte Exp $
+
+*cocaine-core-0.9.2-r1 (08 Sep 2014)
+
+ 08 Sep 2014; Sergey Popov <pinkbyte@gentoo.org> -cocaine-core-0.9.2.ebuild,
+ +cocaine-core-0.9.2-r1.ebuild, +files/cocaine-core-0.9.2-boost-1.53.patch:
+ Revision bump: EAPI 5, add subslot to dev-libs/boost dependency, fix building
+ with newer boost, wrt bug #497320. Thanks to Franz Fellner <alpine.art.de AT
+ gmail.com> for provided patch. Drop old revision
*cocaine-core-0.9.2 (28 Jan 2013)
diff --git a/net-misc/cocaine-core/cocaine-core-0.9.2.ebuild b/net-misc/cocaine-core/cocaine-core-0.9.2-r1.ebuild
index bae4e2433cc1..09486e3bd016 100644
--- a/net-misc/cocaine-core/cocaine-core-0.9.2.ebuild
+++ b/net-misc/cocaine-core/cocaine-core-0.9.2-r1.ebuild
@@ -1,23 +1,25 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cocaine-core/cocaine-core-0.9.2.ebuild,v 1.1 2013/01/28 08:00:44 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cocaine-core/cocaine-core-0.9.2-r1.ebuild,v 1.1 2014/09/08 11:19:19 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils cmake-utils
-EAPI=4
DESCRIPTION="Cloud platform, core parts"
HOMEPAGE="http://reverbrain.com/cocaine/"
SRC_URI="https://github.com/cocaine/${PN}/archive/${PV}.tar.gz"
-inherit eutils cmake-utils
-
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="dev-libs/boost
+DEPEND="dev-libs/boost:=
<net-libs/zeromq-3
dev-libs/libev
dev-libs/msgpack
dev-libs/libcgroup
"
RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-boost-1.53.patch" )
diff --git a/net-misc/cocaine-core/files/cocaine-core-0.9.2-boost-1.53.patch b/net-misc/cocaine-core/files/cocaine-core-0.9.2-boost-1.53.patch
new file mode 100644
index 000000000000..2f03a328e0a9
--- /dev/null
+++ b/net-misc/cocaine-core/files/cocaine-core-0.9.2-boost-1.53.patch
@@ -0,0 +1,13 @@
+Nur in cocaine-core-0.9.2: build.
+Nur in cocaine-core-0.9.2/include/cocaine: config.hpp.
+diff -ru cocaine-core-0.9.2_org/include/cocaine/interfaces/storage.hpp cocaine-core-0.9.2/include/cocaine/interfaces/storage.hpp
+--- cocaine-core-0.9.2_org/include/cocaine/interfaces/storage.hpp 2012-08-29 15:54:35.000000000 +0200
++++ cocaine-core-0.9.2/include/cocaine/interfaces/storage.hpp 2014-07-29 13:49:40.130375695 +0200
+@@ -22,6 +22,7 @@
+ #define COCAINE_STORAGE_INTERFACE_HPP
+
+ #include <boost/thread/mutex.hpp>
++#include <boost/thread/lock_guard.hpp>
+ #include <boost/tuple/tuple.hpp>
+
+ #include "cocaine/common.hpp"