summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-08-26 20:56:23 +0000
committerJeroen Roovers <jer@gentoo.org>2010-08-26 20:56:23 +0000
commit5f8f8043050d6c28a480cd8eeefff055794ce07c (patch)
tree2750301f36e4a11708ed96b4f774a331e6ee734e /net-misc
parentRemove commented patch calls. (diff)
downloadgentoo-2-5f8f8043050d6c28a480cd8eeefff055794ce07c.tar.gz
gentoo-2-5f8f8043050d6c28a480cd8eeefff055794ce07c.tar.bz2
gentoo-2-5f8f8043050d6c28a480cd8eeefff055794ce07c.zip
Respect CC. Respect LDFLAGS (bug #334633).
(Portage version: 2.2_rc69/cvs/Linux i686)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/netkit-timed/ChangeLog9
-rw-r--r--net-misc/netkit-timed/netkit-timed-0.17-r9.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/net-misc/netkit-timed/ChangeLog b/net-misc/netkit-timed/ChangeLog
index cbd5ac09d457..add180ea47ca 100644
--- a/net-misc/netkit-timed/ChangeLog
+++ b/net-misc/netkit-timed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/netkit-timed
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-timed/ChangeLog,v 1.22 2009/09/23 19:40:57 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-timed/ChangeLog,v 1.23 2010/08/26 20:56:23 jer Exp $
+
+*netkit-timed-0.17-r9 (26 Aug 2010)
+
+ 26 Aug 2010; Jeroen Roovers <jer@gentoo.org> +netkit-timed-0.17-r9.ebuild:
+ Respect CC. Respect LDFLAGS (bug #334633).
23 Sep 2009; Patrick Lauer <patrick@gentoo.org>
netkit-timed-0.17-r7.ebuild, netkit-timed-0.17-r8.ebuild:
diff --git a/net-misc/netkit-timed/netkit-timed-0.17-r9.ebuild b/net-misc/netkit-timed/netkit-timed-0.17-r9.ebuild
new file mode 100644
index 000000000000..458b5b2b8d1e
--- /dev/null
+++ b/net-misc/netkit-timed/netkit-timed-0.17-r9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-timed/netkit-timed-0.17-r9.ebuild,v 1.1 2010/08/26 20:56:23 jer Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+IUSE=""
+DESCRIPTION="Netkit - timed"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND=""
+
+src_prepare() {
+ epatch ${FILESDIR}/0.17-CFLAG-DEF-fix.patch
+ epatch ${FILESDIR}/0.17-timed-opt-parsing.patch
+ sed -i configure \
+ -e '/^LDFLAGS=/d' \
+ || die "sed configure"
+}
+
+src_configure() {
+ # Note this is not an autoconf configure script. econf fails
+ append-flags -DCLK_TCK=CLOCKS_PER_SEC
+ ./configure --prefix=/usr --with-c-compiler=$(tc-getCC) || die "bad configure"
+}
+
+src_install() {
+ dosbin timed/timed/timed
+ doman timed/timed/timed.8
+ dosbin timed/timedc/timedc
+ doman timed/timedc/timedc.8
+ dodoc README ChangeLog BUGS
+
+ newinitd ${FILESDIR}/timed.rc6 timed
+}