summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-03-01 07:42:08 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-03-01 07:42:08 +0000
commit5d30dd5facc562417dd4f812aedb95b6092f2adb (patch)
treeb9d45bbf684484f900b4ae2d2318e3f1844e6947 /net-misc
parentVersion bumped. Closes 43232 (Manifest recommit) (diff)
downloadgentoo-2-5d30dd5facc562417dd4f812aedb95b6092f2adb.tar.gz
gentoo-2-5d30dd5facc562417dd4f812aedb95b6092f2adb.tar.bz2
gentoo-2-5d30dd5facc562417dd4f812aedb95b6092f2adb.zip
improved low-end switches compatiblity.
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/e1000/ChangeLog7
-rw-r--r--net-misc/e1000/e1000-5.2.30.1.ebuild16
-rw-r--r--net-misc/e1000/files/README.Gentoo28
3 files changed, 47 insertions, 4 deletions
diff --git a/net-misc/e1000/ChangeLog b/net-misc/e1000/ChangeLog
index 2054eeb2507a..ff61617ebcdf 100644
--- a/net-misc/e1000/ChangeLog
+++ b/net-misc/e1000/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/e1000
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/e1000/ChangeLog,v 1.13 2004/02/03 12:15:07 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/e1000/ChangeLog,v 1.14 2004/03/01 07:42:08 mholzer Exp $
+
+ 01 Mar 2004; Martin Holzer <mholzer@gentoo.org> e1000-5.2.30.1.ebuild,
+ files/README.Gentoo:
+ improved low-end switches compatiblity. Submitted by
+ Dennis Nienhüser <fragfred@gmx.de> in 43306.
*e1000-5.2.30.1 (03 Feb 2004)
diff --git a/net-misc/e1000/e1000-5.2.30.1.ebuild b/net-misc/e1000/e1000-5.2.30.1.ebuild
index f043f2e90ce5..b035dd32767a 100644
--- a/net-misc/e1000/e1000-5.2.30.1.ebuild
+++ b/net-misc/e1000/e1000-5.2.30.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/e1000/e1000-5.2.30.1.ebuild,v 1.1 2004/02/03 12:15:07 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/e1000/e1000-5.2.30.1.ebuild,v 1.2 2004/03/01 07:42:08 mholzer Exp $
DESCRIPTION="Kernel driver for Intel Pro/1000 ethernet adapters."
HOMEPAGE="http://support.intel.com/support/network/adapter/1000/index.htm"
@@ -26,7 +26,14 @@ src_unpack() {
src_compile() {
check_KV
cd "${S}/src"
- make KSRC=/usr/src/linux clean e1000.o
+
+ # workaround needed for some ethernet controllers to work with low end switches
+ if [[ ${USE_INCOMPATIBLE_SWITCH} ]]
+ then CFLAGS_EXTRA="CFLAGS_EXTRA=-DE_1000_MASTER_SLAVE=1"
+ else CFLAGS_EXTRA=""
+ fi
+
+ make ${CFLAGS_EXTRA} KSRC=/usr/src/linux clean e1000.o
}
@@ -34,8 +41,11 @@ src_install() {
insinto "/lib/modules/${KV}/kernel/drivers/net"
doins "${S}/src/e1000.o"
doman e1000.7
- dodoc LICENSE README SUMS e1000.spec ldistrib.txt
+ dodoc LICENSE README SUMS e1000.spec ldistrib.txt ${FILESDIR}/README.Gentoo
einfo ""
einfo "In case you have problems, loading the module, try to run depmod -A"
einfo ""
+ einfo "If you experience problems with low-end switches, read"
+ einfo "/usr/share/doc/${PF}/README.Gentoo.gz for a possible workaround"
+ einfo ""
}
diff --git a/net-misc/e1000/files/README.Gentoo b/net-misc/e1000/files/README.Gentoo
new file mode 100644
index 000000000000..91cfb1b9a115
--- /dev/null
+++ b/net-misc/e1000/files/README.Gentoo
@@ -0,0 +1,28 @@
+Workaround for some cards and low end switches
+==============================================
+
+There is a known problem with some cards and low-end switches where the
+ethernet controller is not able to establish a link (see README). In case
+you are experiencing this problem, try the following:
+
+# Stop networking for e1000
+$ /etc/init.d/net.eth0 stop
+$ rmmod e1000
+
+# compile e1000 with workaround
+$ USE_INCOMPATIBLE_SWITCH="yes" emerge e1000
+
+# load e1000 with parameters limiting its speed
+$ echo "alias eth0 e1000" > /etc/modules.d/e1000
+$ echo "options e1000 Speed=10 Duplex=2,1" >> /etc/modules.d/e1000
+$ update-modules
+
+# Start networking again
+$ modprobe e1000
+$ /etc/init.d/net.eth0 start
+
+This assumes /etc/conf.d/net is set up correctly and your kernel is
+configured without support for e1000 (neither as module nor compiled in)
+as it is needed for net-misc/e1000 to work.
+eth0 has to be replaced with the adapter you are using. You might need
+different settings for Speed and Duplex.