summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-12-22 09:47:27 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-12-22 09:47:27 +0000
commit5d25fe23eec31dcb2f0460b3a591d71d62eb78af (patch)
treeb6ab88ed38afec695149d6d2fece2be3ffa44f81 /net-misc
parentInstall dovecot.m4 - bug 349338 (diff)
downloadgentoo-2-5d25fe23eec31dcb2f0460b3a591d71d62eb78af.tar.gz
gentoo-2-5d25fe23eec31dcb2f0460b3a591d71d62eb78af.tar.bz2
gentoo-2-5d25fe23eec31dcb2f0460b3a591d71d62eb78af.zip
Make nxprint install optional with USE=cups, bug #347011
(Portage version: 2.2.0_alpha9/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/nxclient/ChangeLog8
-rw-r--r--net-misc/nxclient/nxclient-3.4.0.7-r1.ebuild71
2 files changed, 78 insertions, 1 deletions
diff --git a/net-misc/nxclient/ChangeLog b/net-misc/nxclient/ChangeLog
index c6a4623b007f..6565b9b328e7 100644
--- a/net-misc/nxclient/ChangeLog
+++ b/net-misc/nxclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/nxclient
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxclient/ChangeLog,v 1.89 2010/07/19 09:04:15 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxclient/ChangeLog,v 1.90 2010/12/22 09:47:27 voyageur Exp $
+
+*nxclient-3.4.0.7-r1 (22 Dec 2010)
+
+ 22 Dec 2010; Bernard Cafarelli <voyageur@gentoo.org>
+ +nxclient-3.4.0.7-r1.ebuild:
+ Make nxprint install optional with USE=cups, bug #347011
19 Jul 2010; Bernard Cafarelli <voyageur@gentoo.org>
nxclient-3.4.0.5.ebuild, nxclient-3.4.0.7.ebuild:
diff --git a/net-misc/nxclient/nxclient-3.4.0.7-r1.ebuild b/net-misc/nxclient/nxclient-3.4.0.7-r1.ebuild
new file mode 100644
index 000000000000..53d9d9b6ab66
--- /dev/null
+++ b/net-misc/nxclient/nxclient-3.4.0.7-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxclient/nxclient-3.4.0.7-r1.ebuild,v 1.1 2010/12/22 09:47:27 voyageur Exp $
+
+EAPI=2
+inherit eutils versionator
+
+MAJOR_PV="$(get_version_component_range 1-3)"
+FULL_PV="${MAJOR_PV}-$(get_version_component_range 4)"
+DESCRIPTION="X11/VNC/NXServer client (remote desktops over low-bandwidth links)"
+HOMEPAGE="http://www.nomachine.com/"
+SRC_URI="amd64? ( http://64.34.161.181/download/${MAJOR_PV}/Linux/nxclient-${FULL_PV}.x86_64.tar.gz )
+ x86? ( http://64.34.161.181/download/${MAJOR_PV}/Linux/nxclient-${FULL_PV}.i386.tar.gz )"
+LICENSE="nomachine"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="cups"
+RESTRICT="strip"
+
+DEPEND=""
+RDEPEND="dev-libs/expat
+ =dev-libs/openssl-0.9.8*
+ media-libs/audiofile
+ =media-libs/jpeg-6*
+ =media-libs/libpng-1.2*
+ media-libs/freetype
+ media-libs/fontconfig
+ cups? ( net-print/cups )
+ x11-libs/libXft
+ x11-libs/libX11
+ x11-libs/libXdmcp
+ x11-libs/libXrender
+ x11-libs/libXau
+ x11-libs/libXext
+ sys-libs/zlib"
+
+S=${WORKDIR}/NX
+
+src_install()
+{
+ # we install nxclient into /usr/NX, to make sure it doesn't clash
+ # with libraries installed for FreeNX
+ local binaries="nxclient nxesd nxkill nxservice nxssh"
+ use cups && binaries="$binaries nxprint"
+
+ for x in $binaries; do
+ into /usr/NX
+ dobin bin/$x
+ into /usr
+ make_wrapper $x ./$x /usr/NX/bin /usr/NX/lib || die
+ done
+
+ dodir /usr/NX/lib
+ cp -P lib/libXcompsh.so* lib/libXcomp.so* "${D}"/usr/NX/lib
+
+ dodir /usr/NX/share
+ cp -R share "${D}"/usr/NX
+
+ # Add icons/desktop entries (missing in the tarball)
+ cd share/icons
+ for size in *; do
+ dodir /usr/share/icons/hicolor/${size}/apps
+ for icon in admin desktop icon wizard; do
+ dosym /usr/NX/share/icons/${size}/nxclient-${icon}.png \
+ /usr/share/icons/hicolor/${size}/apps
+ done
+ done
+ make_desktop_entry "nxclient" "NX Client" nxclient-icon
+ make_desktop_entry "nxclient -admin" "NX Session Administrator" nxclient-admin
+ make_desktop_entry "nxclient -wizard" "NX Connection Wizard" nxclient-wizard
+}