summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-09-17 09:41:38 +0000
committerMike Frysinger <vapier@gentoo.org>2008-09-17 09:41:38 +0000
commit5200bc635f629c84e72b6b7d0e3f7f21d3db6e45 (patch)
treee8fbb56789b1f75d6f62fbf7483c0bc8586c485f /net-misc
parentarm/s390/sh stable (diff)
downloadgentoo-2-5200bc635f629c84e72b6b7d0e3f7f21d3db6e45.tar.gz
gentoo-2-5200bc635f629c84e72b6b7d0e3f7f21d3db6e45.tar.bz2
gentoo-2-5200bc635f629c84e72b6b7d0e3f7f21d3db6e45.zip
Version bump #237169 by Conrad Kostecki.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rsync/ChangeLog7
-rw-r--r--net-misc/rsync/rsync-3.0.4.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/net-misc/rsync/ChangeLog b/net-misc/rsync/ChangeLog
index ed72231c5608..369dc146dc4a 100644
--- a/net-misc/rsync/ChangeLog
+++ b/net-misc/rsync/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/rsync
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/ChangeLog,v 1.170 2008/08/16 17:36:09 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/ChangeLog,v 1.171 2008/09/17 09:41:38 vapier Exp $
+
+*rsync-3.0.4 (17 Sep 2008)
+
+ 17 Sep 2008; Mike Frysinger <vapier@gentoo.org> +rsync-3.0.4.ebuild:
+ Version bump #237169 by Conrad Kostecki.
16 Aug 2008; nixnut <nixnut@gentoo.org> rsync-3.0.2.ebuild:
Stable on ppc wrt bug 228673
diff --git a/net-misc/rsync/rsync-3.0.4.ebuild b/net-misc/rsync/rsync-3.0.4.ebuild
new file mode 100644
index 000000000000..1182981e7c9d
--- /dev/null
+++ b/net-misc/rsync/rsync-3.0.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-3.0.4.ebuild,v 1.1 2008/09/17 09:41:38 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs autotools
+
+DESCRIPTION="File transfer program to keep remote files into sync"
+HOMEPAGE="http://rsync.samba.org/"
+SRC_URI="http://rsync.samba.org/ftp/rsync/${P/_/}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="acl iconv ipv6 static xattr xinetd"
+
+DEPEND=">=dev-libs/popt-1.5
+ acl? ( kernel_linux? ( sys-apps/acl ) )
+ xattr? ( kernel_linux? ( sys-apps/attr ) )
+ xinetd? ( sys-apps/xinetd )
+ iconv? ( virtual/libiconv )"
+
+S=${WORKDIR}/${P/_/}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf \
+ --without-included-popt \
+ $(use_enable acl acl-support) \
+ $(use_enable xattr xattr-support) \
+ $(use_enable ipv6) \
+ $(use_enable iconv) \
+ --with-rsyncd-conf=/etc/rsyncd.conf \
+ || die
+ emake || die "emake failed"
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/etc/rsync/rsyncd.conf ]] && [[ ! -e ${ROOT}/etc/rsyncd.conf ]] ; then
+ mv "${ROOT}"/etc/rsync/rsyncd.conf "${ROOT}"/etc/rsyncd.conf
+ rm -f "${ROOT}"/etc/rsync/.keep
+ rmdir "${ROOT}"/etc/rsync >& /dev/null
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ newconfd "${FILESDIR}"/rsyncd.conf.d rsyncd
+ newinitd "${FILESDIR}"/rsyncd.init.d rsyncd
+ dodoc NEWS OLDNEWS README TODO tech_report.tex
+ insinto /etc
+ doins "${FILESDIR}"/rsyncd.conf
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/rsyncd.logrotate rsyncd
+
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/rsyncd.xinetd rsyncd
+ fi
+}
+
+pkg_postinst() {
+ ewarn "The rsyncd.conf file has been moved for you to /etc/rsyncd.conf"
+ echo
+ ewarn "Please make sure you do NOT disable the rsync server running"
+ ewarn "in a chroot. Please check /etc/rsyncd.conf and make sure"
+ ewarn "it says: use chroot = yes"
+}