summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-09-03 08:09:46 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-09-03 08:09:46 +0000
commit4e04673e765c30a15271ed8b3190d09790f4ab07 (patch)
tree8074b2fa685d3204eda384d2ed06eed214e49b0f /net-misc
parentvnc revision masked (diff)
downloadgentoo-2-4e04673e765c30a15271ed8b3190d09790f4ab07.tar.gz
gentoo-2-4e04673e765c30a15271ed8b3190d09790f4ab07.tar.bz2
gentoo-2-4e04673e765c30a15271ed8b3190d09790f4ab07.zip
many fixes and patches; new revision of vnc
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vnc/ChangeLog18
-rw-r--r--net-misc/vnc/files/digest-vnc-3.3.3-r32
-rw-r--r--net-misc/vnc/vnc-3.3.3-r2.ebuild23
-rw-r--r--net-misc/vnc/vnc-3.3.3-r3.ebuild71
4 files changed, 102 insertions, 12 deletions
diff --git a/net-misc/vnc/ChangeLog b/net-misc/vnc/ChangeLog
index 1b8d4f133194..f5a0f8a3a94c 100644
--- a/net-misc/vnc/ChangeLog
+++ b/net-misc/vnc/ChangeLog
@@ -1,6 +1,22 @@
# ChangeLog for net-misc/vnc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/ChangeLog,v 1.3 2002/07/09 11:32:31 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/ChangeLog,v 1.4 2002/09/03 08:09:46 seemant Exp $
+
+*vnc-3.3.3-r3 (03 Sep 2002)
+
+ 03 Sep 2002; Seemant Kulleen <seemant@gentoo.org> vnc-3.3.3-r3.ebuild
+ files/digest-vnc-3.3.3-r3 :
+
+ Added a bunch of packages, courtesy of Mandrake's src.rpm. The following
+ patches are applied: imake, xauth, tightvnc encoding, using xinit's
+ XClients script to start the session, vncpassword creates ~/.vnc if
+ non-existent, system libs (zlib) and shared memory patch. Additionally,
+ there is a patch to let it use the X font server (closing bug #6614 by:
+ kelsall@dsl.pipex.com (Chris Paulson-Ellis)) and a patch to compile even
+ though the manpage isn';t present (closing bug #7365 by: gentoo@inrevo.com
+ (Alistair McDonald)). Additionally, an optional patch is applied if
+ "tcpd" is in USE to use tcp wrappers. Finally, for ppc users a patch is
+ applied so that vnc is compilable/installable/runnable on ppc systems.
*vnc-3.3.3-r2 (1 Feb 2002)
diff --git a/net-misc/vnc/files/digest-vnc-3.3.3-r3 b/net-misc/vnc/files/digest-vnc-3.3.3-r3
new file mode 100644
index 000000000000..005da025fcbb
--- /dev/null
+++ b/net-misc/vnc/files/digest-vnc-3.3.3-r3
@@ -0,0 +1,2 @@
+MD5 6fc83e1b6153d3252649953267713f17 vnc-3.3.3r2_unixsrc.tgz 2072772
+MD5 41d8436525edec2931e77a335b885deb vnc-3.3.3-gentoo-extra.tar.bz2 46065
diff --git a/net-misc/vnc/vnc-3.3.3-r2.ebuild b/net-misc/vnc/vnc-3.3.3-r2.ebuild
index 6bd16aa3e730..907696790388 100644
--- a/net-misc/vnc/vnc-3.3.3-r2.ebuild
+++ b/net-misc/vnc/vnc-3.3.3-r2.ebuild
@@ -1,38 +1,40 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# /home/cvsroot/gentoo-x86/skel.build,v 1.2 2001/02/15 18:17:31 achim Exp
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/vnc-3.3.3-r2.ebuild,v 1.10 2002/08/14 12:08:08 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/vnc-3.3.3-r2.ebuild,v 1.11 2002/09/03 08:09:46 seemant Exp $
MY_P="vnc-3.3.3r2_unixsrc"
S=${WORKDIR}/vnc_unixsrc
DESCRIPTION="A remote display system which allows you to view a computing 'desktop' environment from anywhere."
SRC_URI="http://www.uk.research.att.com/vnc/dist/${MY_P}.tgz"
HOMEPAGE="http://www.uk.research.att.com/vnc/index.html"
-KEYWORDS="x86 sparc sparc64"
-LICENSE="GPL-2"
+
SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
-DEPEND="virtual/x11"
+DEPEND="virtual/x11
+ java? virtual/jre"
src_compile() {
#imake and the vnc build process possess amazing suckage skills
#hoping some poor developer takes pitty on vnc and fixes it
- cd ${S}
- cd Xvnc/config/cf
+ #cd Xvnc/config/cf
#mv Imake.cf Imake.cf.orig
#insist that the machine is an i386 for the Xvnc build
#sed -e '/#ifdef linux/a\# define i386' Imake.cf.orig > Imake.cf
- cd ${S}
+
xmkmf || die
#FIXME: my dirty little fix to fix imake brain damage
make Makefiles || die
make depend || die
#cp ${FILESDIR}/vncviewer-makefile-3.3.3r2 ${S}/vncviewer/Makefile
-
- make all || die
+
+ touch ${S}/vncviewer/vncviewer.man
+ make World || die
#FIXME: Xvnc build doesn't respect user CFLAGS settings
cd Xvnc
@@ -42,8 +44,7 @@ src_compile() {
src_install () {
- cd ${S}
- mkdir -p ${D}/usr/bin
+ dodir /usr/bin
./vncinstall ${D}/usr/bin || die
}
diff --git a/net-misc/vnc/vnc-3.3.3-r3.ebuild b/net-misc/vnc/vnc-3.3.3-r3.ebuild
new file mode 100644
index 000000000000..4ea237df764f
--- /dev/null
+++ b/net-misc/vnc/vnc-3.3.3-r3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /home/cvsroot/gentoo-x86/skel.build,v 1.2 2001/02/15 18:17:31 achim Exp
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/vnc-3.3.3-r3.ebuild,v 1.1 2002/09/03 08:09:46 seemant Exp $
+
+inherit flag-o-matic
+
+MY_P="vnc-3.3.3r2_unixsrc"
+S=${WORKDIR}/vnc_unixsrc
+S2=${WORKDIR}/vnc-gentoo-extra
+DESCRIPTION="A remote display system which allows you to view a computing 'desktop' environment from anywhere."
+SRC_URI="http://www.uk.research.att.com/vnc/dist/${MY_P}.tgz
+ mirror://gentoo/${P}-gentoo-extra.tar.bz2"
+HOMEPAGE="http://www.uk.research.att.com/vnc/index.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND="virtual/x11
+ tcpd? ( sys-apps/tcp-wrappers )
+ java? ( virtual/jre )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # apply Mandrake's patches
+ bzcat ${S2}/${P}-gentoo.diff.bz2 | patch -p1 || die
+
+ if use tcpd
+ then
+ bzcat ${S2}/${P}r2-tcpwrappers.patch.bz2 | patch -p1 || die
+ fi
+
+ if use ppc
+ then
+ bzcat ${S2}/vnc-ppc.patch.bz2 | patch -p0 || die
+ fi
+
+}
+
+src_compile() {
+ xmkmf || die
+
+ make \
+ CDEBUGFLAGS="${CFLAGS}" \
+ World || die
+
+ cd Xvnc
+ if use tcpd
+ then
+ make \
+ EXTRA_LIBRARIES="-lwrap -lnss_nis" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ World || die
+ else
+ make \
+ CDEBUGFLAGS="${CFLAGS}" \
+ World || die
+ fi
+}
+
+src_install () {
+ dodir /usr/bin
+ ./vncinstall ${D}/usr/bin || die
+
+ #install manpages
+ doman ${S2}/*.1
+}