summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-04-06 11:09:41 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-04-06 11:09:41 +0000
commit4a17a43289a705d32644b56e68cd8f9acb85334e (patch)
tree254ab3c46e16d330311bf264f39c47babd1ed704 /net-misc
parentold (diff)
downloadgentoo-2-4a17a43289a705d32644b56e68cd8f9acb85334e.tar.gz
gentoo-2-4a17a43289a705d32644b56e68cd8f9acb85334e.tar.bz2
gentoo-2-4a17a43289a705d32644b56e68cd8f9acb85334e.zip
Version bump, thanks to Dmitry S. Kulyabov <yamadharma@gmail.com> in bug #264350
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/freenet6/ChangeLog10
-rw-r--r--net-misc/freenet6/freenet6-6.0.ebuild95
2 files changed, 103 insertions, 2 deletions
diff --git a/net-misc/freenet6/ChangeLog b/net-misc/freenet6/ChangeLog
index 5b79abf6b0da..4b97a9b5a8fd 100644
--- a/net-misc/freenet6/ChangeLog
+++ b/net-misc/freenet6/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/freenet6
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/freenet6/ChangeLog,v 1.39 2008/12/30 13:36:53 voyageur Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/freenet6/ChangeLog,v 1.40 2009/04/06 11:09:41 voyageur Exp $
+
+*freenet6-6.0 (06 Apr 2009)
+
+ 06 Apr 2009; Bernard Cafarelli <voyageur@gentoo.org> +freenet6-6.0.ebuild:
+ Version bump, thanks to Dmitry S. Kulyabov <yamadharma@gmail.com> in bug
+ #264350
30 Dec 2008; Bernard Cafarelli <voyageur@gentoo.org> files/gw6c.rc:
Stopping the tunnel needs SIGHUP, thanks Christian Limberg
diff --git a/net-misc/freenet6/freenet6-6.0.ebuild b/net-misc/freenet6/freenet6-6.0.ebuild
new file mode 100644
index 000000000000..f8919ddc8c3c
--- /dev/null
+++ b/net-misc/freenet6/freenet6-6.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/freenet6/freenet6-6.0.ebuild,v 1.1 2009/04/06 11:09:41 voyageur Exp $
+
+inherit eutils versionator toolchain-funcs
+
+MY_P=gw6c-$(replace_all_version_separators "_")
+MY_P=${MY_P/_beta/-BETA}
+
+DESCRIPTION="Client to configure an IPv6 tunnel to freenet6"
+HOMEPAGE="http://www.freenet6.net"
+SRC_URI="http://go6.net/4105/file.asp?file_id=158&file=/${MY_P}.tar.gz"
+
+LICENSE="VPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="radvd"
+
+DEPEND="dev-libs/openssl
+ sys-apps/iproute2
+ radvd? ( net-misc/radvd )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-5.1-gcc43.patch
+ epatch "${FILESDIR}"/${PN}-6.0_beta4-no-template-validation.patch
+
+ for i in gw6c-config gw6c-messaging ; do
+ sed -i -e "s/-O2//" \
+ -e "s/CXXFLAGS=/CXXFLAGS+=/" \
+ -e "s/CFLAGS=/CFLAGS+=/" \
+ -e "s/LDFAGS=/LDFLAGS+=/" \
+ ${i}/Makefile || die "sed failed in ${i}"
+ done
+
+ cd tspc-advanced
+ for i in platform/linux platform/unix-common src/lib src/net src/tsp src/xml ; do
+ sed -i -e "s/-O2//" \
+ -e "s/CXXFLAGS=/CXXFLAGS+=/" \
+ -e "s/CFLAGS=/CFLAGS+=/" \
+ -e "s/LDFAGS=/LDFLAGS+=/" \
+ ${i}/Makefile || die "sed failed in ${i}"
+ done
+}
+
+src_compile() {
+ # Parallel compilation broken
+ emake -j1\
+ AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+ all configdir=/etc/freenet6 target=linux || die "Build Failed"
+}
+
+src_install() {
+ cd "${S}"/tspc-advanced
+ dosbin bin/gw6c
+
+ insopts -m 600
+ insinto /etc/freenet6
+ doins "${FILESDIR}"/gw6c.conf
+ exeinto /etc/freenet6/template
+ doexe template/linux.sh
+
+ newinitd "${FILESDIR}"/gw6c.rc gw6c
+
+ doman man/{man5/gw6c.conf.5,man8/gw6c.8}
+ dodir /var/lib/freenet6
+
+ dodoc "${S}"/*.pdf
+}
+
+pkg_preinst() {
+ has_version "=${CATEGORY}/${PN}-1*"
+ upgrade_from_1_x=$?
+}
+
+pkg_postinst() {
+ if [[ $upgrade_from_1_x = 0 ]] ; then
+ ewarn "Warning: you are upgrading from an older version"
+ ewarn "The configuration file has been renamed to gw6c.conf"
+ ewarn "Remember to port your personal settings from tspc.conf to it"
+ ewarn "The init script has been renamed to 'gw6c',"
+ else
+ elog "The freenet6 ebuild installs an init script named 'gw6c'"
+ fi
+ elog "to coincide with the name of the client binary installed"
+ elog "To add support for a freenet6 connection at startup, do"
+ elog ""
+ elog "# rc-update add gw6c default"
+}