summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-29 08:26:44 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-29 08:26:44 +0000
commit484397cbfd770c8d594d2affccc67cde04d2c884 (patch)
tree8f30701ba763b613833b413138af4920a2f4ae9a /net-misc
parentMerge patches and changes by Pacho Ramos from bug 184869, thanks. (diff)
downloadgentoo-2-484397cbfd770c8d594d2affccc67cde04d2c884.tar.gz
gentoo-2-484397cbfd770c8d594d2affccc67cde04d2c884.tar.bz2
gentoo-2-484397cbfd770c8d594d2affccc67cde04d2c884.zip
Merge ebuild changes from bug 115106, thanks to Chris Mayo.
(Portage version: 2.1.3)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ices/ChangeLog8
-rw-r--r--net-misc/ices/files/digest-ices-2.0.1-r1 (renamed from net-misc/ices/files/digest-ices-2.0.1)0
-rw-r--r--net-misc/ices/files/ices.initd17
-rw-r--r--net-misc/ices/ices-2.0.1-r1.ebuild44
-rw-r--r--net-misc/ices/ices-2.0.1.ebuild47
5 files changed, 68 insertions, 48 deletions
diff --git a/net-misc/ices/ChangeLog b/net-misc/ices/ChangeLog
index f28a0e475366..be10a1c59f95 100644
--- a/net-misc/ices/ChangeLog
+++ b/net-misc/ices/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/ices
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ices/ChangeLog,v 1.22 2007/02/03 23:27:43 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ices/ChangeLog,v 1.23 2007/07/29 08:26:44 drac Exp $
+
+*ices-2.0.1-r1 (29 Jul 2007)
+
+ 29 Jul 2007; Samuli Suominen <drac@gentoo.org> +files/ices.initd,
+ +ices-2.0.1-r1.ebuild:
+ Merge ebuild changes from bug 115106, thanks to Chris Mayo.
03 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/net-misc/ices/files/digest-ices-2.0.1 b/net-misc/ices/files/digest-ices-2.0.1-r1
index 3ebcbcfca23d..3ebcbcfca23d 100644
--- a/net-misc/ices/files/digest-ices-2.0.1
+++ b/net-misc/ices/files/digest-ices-2.0.1-r1
diff --git a/net-misc/ices/files/ices.initd b/net-misc/ices/files/ices.initd
new file mode 100644
index 000000000000..595bfb300019
--- /dev/null
+++ b/net-misc/ices/files/ices.initd
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting IceS 2"
+ start-stop-daemon --background --start --pidfile /var/run/ices.pid --make-pidfile --exec /usr/bin/ices /etc/ices2/ices.xml
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping IceS 2"
+ start-stop-daemon --stop --pidfile /var/run/ices.pid --name ices
+ eend $?
+}
diff --git a/net-misc/ices/ices-2.0.1-r1.ebuild b/net-misc/ices/ices-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..aadaf36fb59d
--- /dev/null
+++ b/net-misc/ices/ices-2.0.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ices/ices-2.0.1-r1.ebuild,v 1.1 2007/07/29 08:26:44 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="icecast OGG streaming client. supports on the fly re-encoding"
+HOMEPAGE="http://www.icecast.org/ices.php"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxml2
+ >=media-libs/libshout-2.0
+ >=media-libs/libvorbis-1.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ enewgroup ices
+ enewuser ices -1 -1 -1 ices
+}
+
+src_compile() {
+ econf --sysconfdir=/etc/ices2
+ emake || die "emake failed."
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS README TODO
+ insinto /etc/ices2
+ doins conf/*.xml
+ dohtml doc/{*.html,*.css}
+ newman debian/ices2.1 ices.1
+ newinitd "${FILESDIR}"/ices.initd ices
+ keepdir /var/log/ices
+ fperms 660 /var/log/ices
+ fowners ices:ices /var/log/ices
+ rm -rf "${D}"/usr/share/ices
+}
diff --git a/net-misc/ices/ices-2.0.1.ebuild b/net-misc/ices/ices-2.0.1.ebuild
deleted file mode 100644
index 2b84726cbb63..000000000000
--- a/net-misc/ices/ices-2.0.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ices/ices-2.0.1.ebuild,v 1.3 2006/04/03 19:56:34 tcort Exp $
-
-IUSE=""
-
-DESCRIPTION="icecast OGG streaming client. supports on the fly re-encoding"
-SRC_URI="http://downloads.xiph.org/releases/ices/${P}.tar.bz2"
-HOMEPAGE="http://www.icecast.org/ices.php"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~ppc64 ~sparc ~x86"
-
-DEPEND="dev-libs/libxml2
- dev-util/pkgconfig
- >=media-libs/libshout-2.0
- >=media-libs/libvorbis-1.0"
-
-src_compile ()
-{
- econf --sysconfdir=/etc/ices2 || die "configure failed"
-
- emake || die "make failed"
-}
-
-src_install ()
-{
- make DESTDIR=${D} install || die "make install failed"
-
- dodoc AUTHORS README TODO
-
- # Add the stock configs...
- dodir /etc/ices2
- mv ${D}usr/share/ices/ices-live.xml \
- ${D}etc/ices2/ices-live.xml.dist
- mv ${D}usr/share/ices/ices-playlist.xml \
- ${D}etc/ices2/ices-playlist.xml.dist
-
- # Move the html to it's proper location...
- dodir /usr/share/doc/${P}/html
- mv ${D}usr/share/ices/*.html ${D}usr/share/doc/${P}/html
- mv ${D}usr/share/ices/style.css ${D}usr/share/doc/${P}/html
-
- # Nothing is left here after things are moved...
- rmdir ${D}usr/share/ices
-}