summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-03-23 22:49:47 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-03-23 22:49:47 +0000
commit43372d4235d37946e28cf3c05eeaf2086ffeb9e4 (patch)
treed6705491d1a63e2648e741147b856ed225542550 /net-misc
parentversion bump (diff)
downloadgentoo-2-43372d4235d37946e28cf3c05eeaf2086ffeb9e4.tar.gz
gentoo-2-43372d4235d37946e28cf3c05eeaf2086ffeb9e4.tar.bz2
gentoo-2-43372d4235d37946e28cf3c05eeaf2086ffeb9e4.zip
clean up
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tor/ChangeLog7
-rw-r--r--net-misc/tor/files/tor-0.2.1.19-openssl.patch93
-rw-r--r--net-misc/tor/tor-0.2.1.19-r2.ebuild79
-rw-r--r--net-misc/tor/tor-0.2.1.20-r1.ebuild79
-rw-r--r--net-misc/tor/tor-0.2.1.21.ebuild78
5 files changed, 6 insertions, 330 deletions
diff --git a/net-misc/tor/ChangeLog b/net-misc/tor/ChangeLog
index 6c6156e99ba2..6d269def6d04 100644
--- a/net-misc/tor/ChangeLog
+++ b/net-misc/tor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/tor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.197 2010/03/23 22:46:05 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.198 2010/03/23 22:49:47 fauli Exp $
+
+ 23 Mar 2010; Christian Faulhammer <fauli@gentoo.org>
+ -tor-0.2.1.19-r2.ebuild, -files/tor-0.2.1.19-openssl.patch,
+ -tor-0.2.1.20-r1.ebuild, -tor-0.2.1.21.ebuild:
+ clean up
*tor-0.2.1.25 (23 Mar 2010)
diff --git a/net-misc/tor/files/tor-0.2.1.19-openssl.patch b/net-misc/tor/files/tor-0.2.1.19-openssl.patch
deleted file mode 100644
index 73ac476329ba..000000000000
--- a/net-misc/tor/files/tor-0.2.1.19-openssl.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-diff --git a/src/common/tortls.c b/src/common/tortls.c
-index c6b11e9..bcc6780 100644
---- a/src/common/tortls.c
-+++ b/src/common/tortls.c
-@@ -154,6 +154,7 @@ static X509* tor_tls_create_certificate(crypto_pk_env_t *rsa,
- const char *cname,
- const char *cname_sign,
- unsigned int lifetime);
-+static void tor_tls_unblock_renegotiation(tor_tls_t *tls);
-
- /** Global tls context. We keep it here because nobody else needs to
- * touch it. */
-@@ -904,6 +905,36 @@ tor_tls_set_renegotiate_callback(tor_tls_t *tls,
- #endif
- }
-
-+/** If this version of openssl requires it, turn on renegotiation on
-+ * <b>tls</b>. (Our protocol never requires this for security, but it's nice
-+ * to use belt-and-suspenders here.)
-+ */
-+static void
-+tor_tls_unblock_renegotiation(tor_tls_t *tls)
-+{
-+#ifdef SSL3_FLAGS_ALLOW_UNSAFE_LEGACY_RENEGOTIATION
-+ /* Yes, we know what we are doing here. No, we do not treat a renegotiation
-+ * as authenticating any earlier-received data. */
-+ tls->ssl->s3->flags |= SSL3_FLAGS_ALLOW_UNSAFE_LEGACY_RENEGOTIATION;
-+#else
-+ (void)tls;
-+#endif
-+}
-+
-+/** If this version of openssl supports it, turn off renegotiation on
-+ * <b>tls</b>. (Our protocol never requires this for security, but it's nice
-+ * to use belt-and-suspenders here.)
-+ */
-+void
-+tor_tls_block_renegotiation(tor_tls_t *tls)
-+{
-+#ifdef SSL3_FLAGS_ALLOW_UNSAFE_LEGACY_RENEGOTIATION
-+ tls->ssl->s3->flags &= ~SSL3_FLAGS_ALLOW_UNSAFE_LEGACY_RENEGOTIATION;
-+#else
-+ (void)tls;
-+#endif
-+}
-+
- /** Return whether this tls initiated the connect (client) or
- * received it (server). */
- int
-@@ -1026,6 +1057,9 @@ tor_tls_handshake(tor_tls_t *tls)
- } else {
- r = SSL_connect(tls->ssl);
- }
-+ /* We need to call this here and not earlier, since OpenSSL has a penchant
-+ * for clearing its flags when you say accept or connect. */
-+ tor_tls_unblock_renegotiation(tls);
- r = tor_tls_get_error(tls,r,0, "handshaking", LOG_INFO);
- if (ERR_peek_error() != 0) {
- tls_log_errors(tls, tls->isServer ? LOG_INFO : LOG_WARN,
-diff --git a/src/common/tortls.h b/src/common/tortls.h
-index d006909..871fec3 100644
---- a/src/common/tortls.h
-+++ b/src/common/tortls.h
-@@ -65,6 +65,7 @@ int tor_tls_read(tor_tls_t *tls, char *cp, size_t len);
- int tor_tls_write(tor_tls_t *tls, const char *cp, size_t n);
- int tor_tls_handshake(tor_tls_t *tls);
- int tor_tls_renegotiate(tor_tls_t *tls);
-+void tor_tls_block_renegotiation(tor_tls_t *tls);
- int tor_tls_shutdown(tor_tls_t *tls);
- int tor_tls_get_pending_bytes(tor_tls_t *tls);
- size_t tor_tls_get_forced_write_size(tor_tls_t *tls);
-diff --git a/src/or/connection_or.c b/src/or/connection_or.c
-index b4e8092..2a52b3f 100644
---- a/src/or/connection_or.c
-+++ b/src/or/connection_or.c
-@@ -844,6 +844,7 @@ connection_or_tls_renegotiated_cb(tor_tls_t *tls, void *_conn)
-
- /* Don't invoke this again. */
- tor_tls_set_renegotiate_callback(tls, NULL, NULL);
-+ tor_tls_block_renegotiation(tls);
-
- if (connection_tls_finish_handshake(conn) < 0) {
- /* XXXX_TLS double-check that it's ok to do this from inside read. */
-@@ -1087,6 +1088,7 @@ connection_tls_finish_handshake(or_connection_t *conn)
- connection_or_init_conn_from_address(conn, &conn->_base.addr,
- conn->_base.port, digest_rcvd, 0);
- }
-+ tor_tls_block_renegotiation(conn->tls);
- return connection_or_set_state_open(conn);
- } else {
- conn->_base.state = OR_CONN_STATE_OR_HANDSHAKING;
---
-1.5.6.5
diff --git a/net-misc/tor/tor-0.2.1.19-r2.ebuild b/net-misc/tor/tor-0.2.1.19-r2.ebuild
deleted file mode 100644
index 165207affffa..000000000000
--- a/net-misc/tor/tor-0.2.1.19-r2.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.1.19-r2.ebuild,v 1.6 2009/12/26 20:32:04 armin76 Exp $
-
-EAPI=2
-
-inherit eutils
-
-DESCRIPTION="Anonymizing overlay network for TCP"
-HOMEPAGE="http://www.torproject.org/"
-MY_PV=${PV/_/-}
-SRC_URI="http://www.torproject.org/dist/${PN}-${MY_PV}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="debug"
-
-DEPEND="dev-libs/openssl
- >=dev-libs/libevent-1.2"
-RDEPEND="${DEPEND}
- net-proxy/tsocks"
-
-pkg_setup() {
- enewgroup tor
- enewuser tor -1 -1 /var/lib/tor tor
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/torrc.sample-0.1.2.6.patch
- epatch "${FILESDIR}"/${P}-logrotate.patch
- epatch "${FILESDIR}"/${P}-openssl.patch
- # Normally tor uses a bundled libevent fragment to provide
- # asynchronous DNS requests. This is generally a bad idea, but at
- # the moment the official libevent does not have the 0x20 hack, so
- # anonymity is higher with the bundled variant. Remove patch as
- # soon as upstream has installed the autoconf option to use
- # system's libevent. This hasn't happened, so we
- # have to live with the bundled libevent for this release, as the
- # current version in tree won't suffice for tor to build
- # See http://bugs.noreply.org/flyspray/index.php?do=details&id=920
- # for upstream's report
- # Let's revisit this when libevent-2* is unmasked
- # use bundledlibevent || epatch "${FILESDIR}"/${PN}-0.2.1.5-no-internal-libevent.patch
-}
-
-src_configure() {
- econf $(use_enable debug)
-}
-
-src_install() {
- newinitd "${FILESDIR}"/tor.initd-r4 tor
- emake DESTDIR="${D}" install || die
- keepdir /var/{lib,log,run}/tor
-
- dodoc README ChangeLog AUTHORS ReleaseNotes \
- doc/{HACKING,TODO} \
- doc/spec/*.txt
-
- fperms 750 /var/lib/tor /var/log/tor
- fperms 755 /var/run/tor
- fowners tor:tor /var/lib/tor /var/log/tor /var/run/tor
-
- insinto /etc/logrotate.d
- newins contrib/tor.logrotate tor
-
- # allow the tor user more open files to avoid errors, see bug 251171
- insinto /etc/security/limits.d/
- doins "${FILESDIR}"/tor.conf
-}
-
-pkg_postinst() {
- elog "You must create /etc/tor/torrc, you can use the sample that is in that directory"
- elog "To have privoxy and tor working together you must add:"
- elog "forward-socks4a / localhost:9050 ."
- elog "(notice the . at the end of the line)"
- elog "to /etc/privoxy/config"
-}
diff --git a/net-misc/tor/tor-0.2.1.20-r1.ebuild b/net-misc/tor/tor-0.2.1.20-r1.ebuild
deleted file mode 100644
index cc9ebde653ad..000000000000
--- a/net-misc/tor/tor-0.2.1.20-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.1.20-r1.ebuild,v 1.1 2009/12/06 14:36:45 fauli Exp $
-
-EAPI=2
-
-inherit eutils
-
-DESCRIPTION="Anonymizing overlay network for TCP"
-HOMEPAGE="http://www.torproject.org/"
-MY_PV=${PV/_/-}
-SRC_URI="http://www.torproject.org/dist/${PN}-${MY_PV}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug"
-
-DEPEND="dev-libs/openssl
- >=dev-libs/libevent-1.2"
-RDEPEND="${DEPEND}
- net-proxy/tsocks"
-
-pkg_setup() {
- enewgroup tor
- enewuser tor -1 -1 /var/lib/tor tor
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/torrc.sample-0.1.2.6.patch
- epatch "${FILESDIR}"/${PN}-0.2.1.19-logrotate.patch
- epatch "${FILESDIR}"/${PN}-0.2.1.19-openssl.patch
- # Normally tor uses a bundled libevent fragment to provide
- # asynchronous DNS requests. This is generally a bad idea, but at
- # the moment the official libevent does not have the 0x20 hack, so
- # anonymity is higher with the bundled variant. Remove patch as
- # soon as upstream has installed the autoconf option to use
- # system's libevent. This hasn't happened, so we
- # have to live with the bundled libevent for this release, as the
- # current version in tree won't suffice for tor to build
- # See http://bugs.noreply.org/flyspray/index.php?do=details&id=920
- # for upstream's report
- # Let's revisit this when libevent-2* is unmasked
- # use bundledlibevent || epatch "${FILESDIR}"/${PN}-0.2.1.5-no-internal-libevent.patch
-}
-
-src_configure() {
- econf $(use_enable debug)
-}
-
-src_install() {
- newinitd "${FILESDIR}"/tor.initd-r4 tor
- emake DESTDIR="${D}" install || die
- keepdir /var/{lib,log,run}/tor
-
- dodoc README ChangeLog AUTHORS ReleaseNotes \
- doc/{HACKING,TODO} \
- doc/spec/*.txt
-
- fperms 750 /var/lib/tor /var/log/tor
- fperms 755 /var/run/tor
- fowners tor:tor /var/lib/tor /var/log/tor /var/run/tor
-
- insinto /etc/logrotate.d
- newins contrib/tor.logrotate tor
-
- # allow the tor user more open files to avoid errors, see bug 251171
- insinto /etc/security/limits.d/
- doins "${FILESDIR}"/tor.conf
-}
-
-pkg_postinst() {
- elog "You must create /etc/tor/torrc, you can use the sample that is in that directory"
- elog "To have privoxy and tor working together you must add:"
- elog "forward-socks4a / localhost:9050 ."
- elog "(notice the . at the end of the line)"
- elog "to /etc/privoxy/config"
-}
diff --git a/net-misc/tor/tor-0.2.1.21.ebuild b/net-misc/tor/tor-0.2.1.21.ebuild
deleted file mode 100644
index 9522568df974..000000000000
--- a/net-misc/tor/tor-0.2.1.21.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.1.21.ebuild,v 1.1 2010/01/16 11:14:46 fauli Exp $
-
-EAPI=2
-
-inherit eutils
-
-DESCRIPTION="Anonymizing overlay network for TCP"
-HOMEPAGE="http://www.torproject.org/"
-MY_PV=${PV/_/-}
-SRC_URI="http://www.torproject.org/dist/${PN}-${MY_PV}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug"
-
-DEPEND="dev-libs/openssl
- >=dev-libs/libevent-1.2"
-RDEPEND="${DEPEND}
- net-proxy/tsocks"
-
-pkg_setup() {
- enewgroup tor
- enewuser tor -1 -1 /var/lib/tor tor
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/torrc.sample-0.1.2.6.patch
- epatch "${FILESDIR}"/${PN}-0.2.1.19-logrotate.patch
- # Normally tor uses a bundled libevent fragment to provide
- # asynchronous DNS requests. This is generally a bad idea, but at
- # the moment the official libevent does not have the 0x20 hack, so
- # anonymity is higher with the bundled variant. Remove patch as
- # soon as upstream has installed the autoconf option to use
- # system's libevent. This hasn't happened, so we
- # have to live with the bundled libevent for this release, as the
- # current version in tree won't suffice for tor to build
- # See http://bugs.noreply.org/flyspray/index.php?do=details&id=920
- # for upstream's report
- # Let's revisit this when libevent-2* is unmasked
- # use bundledlibevent || epatch "${FILESDIR}"/${PN}-0.2.1.5-no-internal-libevent.patch
-}
-
-src_configure() {
- econf $(use_enable debug)
-}
-
-src_install() {
- newinitd "${FILESDIR}"/tor.initd-r4 tor
- emake DESTDIR="${D}" install || die
- keepdir /var/{lib,log,run}/tor
-
- dodoc README ChangeLog AUTHORS ReleaseNotes \
- doc/{HACKING,TODO} \
- doc/spec/*.txt
-
- fperms 750 /var/lib/tor /var/log/tor
- fperms 755 /var/run/tor
- fowners tor:tor /var/lib/tor /var/log/tor /var/run/tor
-
- insinto /etc/logrotate.d
- newins contrib/tor.logrotate tor
-
- # allow the tor user more open files to avoid errors, see bug 251171
- insinto /etc/security/limits.d/
- doins "${FILESDIR}"/tor.conf
-}
-
-pkg_postinst() {
- elog "You must create /etc/tor/torrc, you can use the sample that is in that directory"
- elog "To have privoxy and tor working together you must add:"
- elog "forward-socks4a / localhost:9050 ."
- elog "(notice the . at the end of the line)"
- elog "to /etc/privoxy/config"
-}