summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-11 05:55:34 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-11 05:55:34 +0000
commit3cb3f9b73c48a436d01d9cae1775d96cd7a22804 (patch)
tree988f2adb6652574019f84f8a7e6c696c166a0407 /net-misc
parentBump. (diff)
downloadgentoo-2-3cb3f9b73c48a436d01d9cae1775d96cd7a22804.tar.gz
gentoo-2-3cb3f9b73c48a436d01d9cae1775d96cd7a22804.tar.bz2
gentoo-2-3cb3f9b73c48a436d01d9cae1775d96cd7a22804.zip
old
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rsync/rsync-3.0.0_pre6.ebuild68
-rw-r--r--net-misc/rsync/rsync-3.0.0_pre7.ebuild68
2 files changed, 0 insertions, 136 deletions
diff --git a/net-misc/rsync/rsync-3.0.0_pre6.ebuild b/net-misc/rsync/rsync-3.0.0_pre6.ebuild
deleted file mode 100644
index 912b7554ff25..000000000000
--- a/net-misc/rsync/rsync-3.0.0_pre6.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-3.0.0_pre6.ebuild,v 1.1 2007/12/01 18:32:21 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs autotools
-
-DESCRIPTION="File transfer program to keep remote files into sync"
-HOMEPAGE="http://rsync.samba.org/"
-SRC_URI="http://rsync.samba.org/ftp/rsync/${P/_/}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="acl ipv6 static xattr xinetd"
-
-DEPEND=">=dev-libs/popt-1.5
- acl? ( kernel_linux? ( sys-apps/acl ) )
- xattr? ( sys-apps/attr )
- xinetd? ( sys-apps/xinetd )"
-
-S=${WORKDIR}/${P/_/}
-
-src_unpack() {
- unpack ${P/_/}.tar.gz
- cd "${S}"
- rm -f configure.sh
-}
-
-src_compile() {
- use static && append-ldflags -static
- econf \
- --without-included-popt \
- $(use_enable acl acl-support) \
- $(use_enable xattr xattr-support) \
- $(use_enable ipv6) \
- --with-rsyncd-conf=/etc/rsyncd.conf \
- || die
- emake || die "emake failed"
-}
-
-pkg_preinst() {
- if [[ -e ${ROOT}/etc/rsync/rsyncd.conf ]] && [[ ! -e ${ROOT}/etc/rsyncd.conf ]] ; then
- mv "${ROOT}"/etc/rsync/rsyncd.conf "${ROOT}"/etc/rsyncd.conf
- rm -f "${ROOT}"/etc/rsync/.keep
- rmdir "${ROOT}"/etc/rsync >& /dev/null
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- newconfd "${FILESDIR}"/rsyncd.conf.d rsyncd
- newinitd "${FILESDIR}"/rsyncd.init.d rsyncd
- dodoc NEWS OLDNEWS README TODO tech_report.tex
- insinto /etc
- doins "${FILESDIR}"/rsyncd.conf
- if use xinetd ; then
- insinto /etc/xinetd.d
- newins "${FILESDIR}"/rsyncd.xinetd rsyncd
- fi
-}
-
-pkg_postinst() {
- ewarn "The rsyncd.conf file has been moved for you to /etc/rsyncd.conf"
- echo
- ewarn "Please make sure you do NOT disable the rsync server running"
- ewarn "in a chroot. Please check /etc/rsyncd.conf and make sure"
- ewarn "it says: use chroot = yes"
-}
diff --git a/net-misc/rsync/rsync-3.0.0_pre7.ebuild b/net-misc/rsync/rsync-3.0.0_pre7.ebuild
deleted file mode 100644
index 8dbd9d3f3031..000000000000
--- a/net-misc/rsync/rsync-3.0.0_pre7.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-3.0.0_pre7.ebuild,v 1.1 2007/12/17 00:27:51 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs autotools
-
-DESCRIPTION="File transfer program to keep remote files into sync"
-HOMEPAGE="http://rsync.samba.org/"
-SRC_URI="http://rsync.samba.org/ftp/rsync/${P/_/}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="acl ipv6 static xattr xinetd"
-
-DEPEND=">=dev-libs/popt-1.5
- acl? ( kernel_linux? ( sys-apps/acl ) )
- xattr? ( sys-apps/attr )
- xinetd? ( sys-apps/xinetd )"
-
-S=${WORKDIR}/${P/_/}
-
-src_unpack() {
- unpack ${P/_/}.tar.gz
- cd "${S}"
- rm -f configure.sh
-}
-
-src_compile() {
- use static && append-ldflags -static
- econf \
- --without-included-popt \
- $(use_enable acl acl-support) \
- $(use_enable xattr xattr-support) \
- $(use_enable ipv6) \
- --with-rsyncd-conf=/etc/rsyncd.conf \
- || die
- emake || die "emake failed"
-}
-
-pkg_preinst() {
- if [[ -e ${ROOT}/etc/rsync/rsyncd.conf ]] && [[ ! -e ${ROOT}/etc/rsyncd.conf ]] ; then
- mv "${ROOT}"/etc/rsync/rsyncd.conf "${ROOT}"/etc/rsyncd.conf
- rm -f "${ROOT}"/etc/rsync/.keep
- rmdir "${ROOT}"/etc/rsync >& /dev/null
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- newconfd "${FILESDIR}"/rsyncd.conf.d rsyncd
- newinitd "${FILESDIR}"/rsyncd.init.d rsyncd
- dodoc NEWS OLDNEWS README TODO tech_report.tex
- insinto /etc
- doins "${FILESDIR}"/rsyncd.conf
- if use xinetd ; then
- insinto /etc/xinetd.d
- newins "${FILESDIR}"/rsyncd.xinetd rsyncd
- fi
-}
-
-pkg_postinst() {
- ewarn "The rsyncd.conf file has been moved for you to /etc/rsyncd.conf"
- echo
- ewarn "Please make sure you do NOT disable the rsync server running"
- ewarn "in a chroot. Please check /etc/rsyncd.conf and make sure"
- ewarn "it says: use chroot = yes"
-}