summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-07-31 11:03:01 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-07-31 11:03:01 +0000
commit3c57ca857329c2a037f2d97d4f88becc892cf088 (patch)
treedd3932699185fe2441d149a5050ec52155391f0e /net-misc
parentUpdate headers. (diff)
downloadgentoo-2-3c57ca857329c2a037f2d97d4f88becc892cf088.tar.gz
gentoo-2-3c57ca857329c2a037f2d97d4f88becc892cf088.tar.bz2
gentoo-2-3c57ca857329c2a037f2d97d4f88becc892cf088.zip
Rename pentium useflag to sse. Get rid of old ebuild. Thx to sedzimir on sunrise for patch.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/hamachi/ChangeLog8
-rw-r--r--net-misc/hamachi/files/hamachi.initd58
-rw-r--r--net-misc/hamachi/hamachi-0.9.9.9_p20-r2.ebuild107
-rw-r--r--net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild38
-rw-r--r--net-misc/hamachi/metadata.xml3
5 files changed, 14 insertions, 200 deletions
diff --git a/net-misc/hamachi/ChangeLog b/net-misc/hamachi/ChangeLog
index 6ed27fb53975..fb53da5efe69 100644
--- a/net-misc/hamachi/ChangeLog
+++ b/net-misc/hamachi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/hamachi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hamachi/ChangeLog,v 1.11 2009/07/31 09:26:18 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hamachi/ChangeLog,v 1.12 2009/07/31 11:03:01 scarabeus Exp $
+
+ 31 Jul 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ -hamachi-0.9.9.9_p20-r2.ebuild, hamachi-0.9.9.9_p20-r4.ebuild,
+ -files/hamachi.initd, metadata.xml:
+ Rename pentium useflag to sse. Get rid of old ebuild. Thx to sedzimir on
+ sunrise for patch.
*hamachi-0.9.9.9_p20-r4 (31 Jul 2009)
diff --git a/net-misc/hamachi/files/hamachi.initd b/net-misc/hamachi/files/hamachi.initd
deleted file mode 100644
index dd544f00a752..000000000000
--- a/net-misc/hamachi/files/hamachi.initd
+++ /dev/null
@@ -1,58 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-opts="start stop status init"
-
-depend() {
- need net tuncfg
-}
-
-start() {
- check_config
- ebegin "Starting hamachi"
- start-stop-daemon --quiet --start -c ${USER} \
- --exec /usr/bin/hamachi -- \
- -c $CONFDIR start &>${LOG} &
- result=$?
-
- if [ $result == 0 ]; then
- sleep 1
- chown -R $USER:$GROUP $CONFDIR/ipc_sock
- chmod g+rwx $CONFDIR/ipc_sock
- /usr/bin/hamachi -c $CONFDIR login
- if [ -z "$(/usr/bin/hamachi -c $CONFDIR | grep 'logged in')" ]; then
- result=1
- /usr/bin/hamachi -c $CONFDIR stop &>${LOG}
- fi
- fi;
- eend $result
-}
-
-stop() {
- ebegin "Stopping hamachi"
- /usr/bin/hamachi -c $CONFDIR logout &>${LOG}
- /usr/bin/hamachi -c $CONFDIR stop &>${LOG}
- eend $?
-}
-
-init() {
- ebegin "Making initial configuration"
- /usr/bin/hamachi-init -c $CONFDIR 2>&1 >/dev/null
- chown -R $USER:$GROUP $CONFDIR
- chmod g+rx $CONFDIR
- eend $?
-}
-
-check_config() {
- if [ ! -d $CONFDIR ] ; then
- einfo "It seems you don't have configured hamachi yet. Running init now"
- init
- fi
-}
-
-status() {
- service_started "${myservice}" || return 0
- /usr/bin/hamachi -c $CONFDIR
- /usr/bin/hamachi -c $CONFDIR list
-}
diff --git a/net-misc/hamachi/hamachi-0.9.9.9_p20-r2.ebuild b/net-misc/hamachi/hamachi-0.9.9.9_p20-r2.ebuild
deleted file mode 100644
index 07e360052cfd..000000000000
--- a/net-misc/hamachi/hamachi-0.9.9.9_p20-r2.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hamachi/hamachi-0.9.9.9_p20-r2.ebuild,v 1.8 2008/09/10 15:58:53 darkside Exp $
-
-inherit eutils linux-info
-
-# gHamachi GUI
-
-MY_PV=${PV/_p/-}
-MY_P=${PN}-${MY_PV}-lnx
-
-DESCRIPTION="Hamachi is a secure mediated peer to peer."
-HOMEPAGE="http://hamachi.cc"
-LICENSE="as-is"
-SRC_URI=" !pentium? ( http://files.hamachi.cc/linux/${MY_P}.tar.gz )
- pentium? ( http://files.hamachi.cc/linux/${MY_P}-pentium.tar.gz )"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE="pentium"
-RESTRICT="strip mirror"
-
-# Set workdir for both hamachi versions
-if use pentium; then
- S=${WORKDIR}/${MY_P}-pentium
-else
- S=${WORKDIR}/${MY_P}
-fi
-
-pkg_preinst() {
- # Add group "hamachi" & user "hamachi"
- enewgroup ${PN}
- enewuser ${PN} -1 -1 /dev/null ${PN}
-}
-
-pkg_setup() {
- einfo "Checking your kernel configuration for TUN/TAP support."
- CONFIG_CHECK="TUN"
- check_extra_config
-}
-
-src_unpack() {
- # Unpack the correct Hamachi version
- if use !pentium; then
- unpack ${MY_P}.tar.gz
- else
- unpack ${MY_P}-pentium.tar.gz
- fi
-}
-
-src_compile() {
- # Compile Tuncfg
- make -sC "${S}"/tuncfg || die "Compiling of tunecfg failed"
-}
-
-src_install() {
- # Hamachi
- einfo "Installing Hamachi"
- insinto /usr/bin
- insopts -m0755
- doins hamachi
- dosym /usr/bin/hamachi /usr/bin/hamachi-init
-
- # Tuncfg
- einfo "Installing Tuncfg"
- insinto /usr/sbin
- insopts -m0700
- doins tuncfg/tuncfg
-
- # Create log directory
- dodir /var/log/${PN}
-
- # Config files
- einfo "Installing config files"
- newinitd "${FILESDIR}"/tuncfg.initd tuncfg
- newconfd "${FILESDIR}"/hamachi.confd hamachi
- newinitd "${FILESDIR}"/hamachi.initd hamachi
-
- # Docs
- dodoc CHANGES README LICENSE LICENSE.openssh LICENSE.openssl LICENSE.tuncfg
-
-}
-
-pkg_postinst() {
- if use pentium; then
- einfo "Remember, you set the pentium USE flag!"
- einfo So, you installed the version for older x86 systems!
- einfo If your CPU is greater than Intel Pentium / AMD K6,
- einfo remove the pentium USE flag and try this version!
- fi
-
- if use !pentium; then
- ewarn "If you are seeing 'illegal instruction' error when trying"
- ewarn "to run Hamachi client, set the pentium USE flag!"
- ewarn "It enables binaries built specifically for older"
- ewarn "x86 platforms, like Intel Pentium or AMD K6,"
- ewarn "with all optimizations turned off."
- fi
-
- einfo "To start Hamachi just type:"
- einfo "/etc/init.d/hamachi start"
-
- # added for bug #218481
- einfo "If the 'hamachi' command shows no output, use the following command"
- einfo "to extract the hamachi executable either with app-arch/upx or"
- einfo "app-arch/upx-ucl:"
- einfo "/opt/bin/upx -d /usr/bin/hamachi"
-}
diff --git a/net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild b/net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild
index 1e9efc14e5b7..31b47c88cb25 100644
--- a/net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild
+++ b/net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild,v 1.1 2009/07/31 09:26:18 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild,v 1.2 2009/07/31 11:03:01 scarabeus Exp $
inherit eutils linux-info
@@ -12,18 +12,18 @@ MY_P=${PN}-${MY_PV}-lnx
DESCRIPTION="Hamachi is a secure mediated peer to peer."
HOMEPAGE="http://hamachi.cc"
LICENSE="as-is"
-SRC_URI=" !pentium? ( http://files.hamachi.cc/linux/${MY_P}.tar.gz )
- pentium? ( http://files.hamachi.cc/linux/${MY_P}-pentium.tar.gz )"
+SRC_URI="sse? ( http://files.hamachi.cc/linux/${MY_P}.tar.gz )
+ !sse? ( http://files.hamachi.cc/linux/${MY_P}-pentium.tar.gz )"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE="pentium"
+IUSE="sse"
RESTRICT="strip mirror"
# Set workdir for both hamachi versions
-if use pentium; then
- S=${WORKDIR}/${MY_P}-pentium
-else
+if use sse; then
S=${WORKDIR}/${MY_P}
+else
+ S=${WORKDIR}/${MY_P}-pentium
fi
pkg_preinst() {
@@ -38,15 +38,6 @@ pkg_setup() {
check_extra_config
}
-src_unpack() {
- # Unpack the correct Hamachi version
- if use !pentium; then
- unpack ${MY_P}.tar.gz
- else
- unpack ${MY_P}-pentium.tar.gz
- fi
-}
-
src_compile() {
# Compile Tuncfg
make -sC "${S}"/tuncfg || die "Compiling of tunecfg failed"
@@ -81,21 +72,6 @@ src_install() {
}
pkg_postinst() {
- if use pentium; then
- einfo "Remember, you set the pentium USE flag!"
- einfo So, you installed the version for older x86 systems!
- einfo If your CPU is greater than Intel Pentium / AMD K6,
- einfo remove the pentium USE flag and try this version!
- fi
-
- if use !pentium; then
- ewarn "If you are seeing 'illegal instruction' error when trying"
- ewarn "to run Hamachi client, set the pentium USE flag!"
- ewarn "It enables binaries built specifically for older"
- ewarn "x86 platforms, like Intel Pentium or AMD K6,"
- ewarn "with all optimizations turned off."
- fi
-
einfo "To start Hamachi just type:"
einfo "/etc/init.d/hamachi start"
diff --git a/net-misc/hamachi/metadata.xml b/net-misc/hamachi/metadata.xml
index dca1bef8d738..6e5d8c8e15bb 100644
--- a/net-misc/hamachi/metadata.xml
+++ b/net-misc/hamachi/metadata.xml
@@ -7,7 +7,4 @@
</maintainer>
<longdescription>Hamachi is an encrypted tunneling service that allows pseudo networks to be joined together.
</longdescription>
- <use>
- <flag name="pentium">Add support for older Pentium based systems</flag>
- </use>
</pkgmetadata>