summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-09-16 11:38:28 +0000
committerPacho Ramos <pacho@gentoo.org>2012-09-16 11:38:28 +0000
commit3a5524afdfa916adb57100c5fac6a20446190cf0 (patch)
tree834ac4d67aaa3450c31639bf8a04fc596441a3be /net-misc
parentDrop versions still supporting libwww (#320253). (diff)
downloadgentoo-2-3a5524afdfa916adb57100c5fac6a20446190cf0.tar.gz
gentoo-2-3a5524afdfa916adb57100c5fac6a20446190cf0.tar.bz2
gentoo-2-3a5524afdfa916adb57100c5fac6a20446190cf0.zip
Drop libwww support (#320253), install a menu entry.
(Portage version: 2.1.11.17/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/jigdo/ChangeLog9
-rw-r--r--net-misc/jigdo/jigdo-0.7.3-r2.ebuild (renamed from net-misc/jigdo/jigdo-0.7.3.ebuild)21
2 files changed, 17 insertions, 13 deletions
diff --git a/net-misc/jigdo/ChangeLog b/net-misc/jigdo/ChangeLog
index 9ec6e1178535..277b0b786574 100644
--- a/net-misc/jigdo/ChangeLog
+++ b/net-misc/jigdo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/jigdo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/ChangeLog,v 1.27 2012/03/18 17:54:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/ChangeLog,v 1.28 2012/09/16 11:38:28 pacho Exp $
+
+*jigdo-0.7.3-r2 (16 Sep 2012)
+
+ 16 Sep 2012; Pacho Ramos <pacho@gentoo.org> +jigdo-0.7.3-r2.ebuild,
+ -jigdo-0.7.3.ebuild:
+ Drop libwww support (#320253), install a menu entry.
18 Mar 2012; Raúl Porcel <armin76@gentoo.org> jigdo-0.7.3.ebuild,
jigdo-0.7.3-r1.ebuild:
@@ -104,4 +110,3 @@
29 Jul 2003; Jason Wever <weeve@gentoo.org> jigdo-0.7.0.ebuild,
metadata.xml, files/makefile.patch:
Initial import. Resolves bug #21829.
-
diff --git a/net-misc/jigdo/jigdo-0.7.3.ebuild b/net-misc/jigdo/jigdo-0.7.3-r2.ebuild
index 3565aef9dc89..a02e2a6c08e5 100644
--- a/net-misc/jigdo/jigdo-0.7.3.ebuild
+++ b/net-misc/jigdo/jigdo-0.7.3-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/jigdo-0.7.3.ebuild,v 1.10 2012/03/18 17:54:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/jigdo-0.7.3-r2.ebuild,v 1.1 2012/09/16 11:38:28 pacho Exp $
-EAPI=3
+EAPI=4
inherit eutils
DESCRIPTION="Jigsaw Download is a tool designed to ease the distribution of large files, for example DVD images."
@@ -11,30 +11,29 @@ SRC_URI="http://atterer.net/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="gtk nls berkdb libwww"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk nls berkdb"
RDEPEND="gtk? ( x11-libs/gtk+:2 )
- berkdb? ( >=sys-libs/db-3.2 )
- libwww? ( >=net-libs/libwww-5.3.2 )"
+ berkdb? ( >=sys-libs/db-3.2 )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-strip.patch
}
src_configure() {
local myconf
-
- use gtk && use libwww || myconf="${myconf} --without-gui"
use berkdb || myconf="${myconf} --without-libdb"
-
econf $(use_enable nls) ${myconf}
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ emake DESTDIR="${D}" install
+ doicon gfx/jigdo-icon.png
+ make_desktop_entry "${PN}" "${PN}" jigdo-icon
dodoc changelog README THANKS doc/{Hacking,README-bindist,TechDetails}.txt
dohtml doc/*.html
}