summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-06-28 09:50:14 +0000
committerRoy Marples <uberlord@gentoo.org>2006-06-28 09:50:14 +0000
commit386a7c0f516ff4c982e82655bb8dd8e754ccad9d (patch)
treef9d349b75d1b35597a8972f8dfc45f0c7ae9ed30 /net-misc
parentStable on ppc64; bug #137622 (diff)
downloadgentoo-2-386a7c0f516ff4c982e82655bb8dd8e754ccad9d.tar.gz
gentoo-2-386a7c0f516ff4c982e82655bb8dd8e754ccad9d.tar.bz2
gentoo-2-386a7c0f516ff4c982e82655bb8dd8e754ccad9d.zip
Added patch to fix 64 bit DHCP servers, #133905.
(Portage version: 2.1.1_pre1-r3)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcp/ChangeLog8
-rw-r--r--net-misc/dhcp/dhcp-3.0.4-r2.ebuild230
-rw-r--r--net-misc/dhcp/files/dhcp-3.0.4-64bit.patch91
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0.4-r23
4 files changed, 331 insertions, 1 deletions
diff --git a/net-misc/dhcp/ChangeLog b/net-misc/dhcp/ChangeLog
index a61c103457d7..6bfeea1cb7db 100644
--- a/net-misc/dhcp/ChangeLog
+++ b/net-misc/dhcp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/dhcp
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/ChangeLog,v 1.107 2006/06/25 14:37:05 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/ChangeLog,v 1.108 2006/06/28 09:50:14 uberlord Exp $
+
+*dhcp-3.0.4-r2 (28 Jun 2006)
+
+ 28 Jun 2006; Roy Marples <uberlord@gentoo.org>
+ +files/dhcp-3.0.4-64bit.patch, +dhcp-3.0.4-r2.ebuild:
+ Added patch to fix 64 bit DHCP servers, #133905.
25 Jun 2006; Marcus D. Hanwell <cryos@gentoo.org> dhcp-3.0.3-r9.ebuild:
Marked stable on amd64. bug 137689.
diff --git a/net-misc/dhcp/dhcp-3.0.4-r2.ebuild b/net-misc/dhcp/dhcp-3.0.4-r2.ebuild
new file mode 100644
index 000000000000..e4c114e6e6fb
--- /dev/null
+++ b/net-misc/dhcp/dhcp-3.0.4-r2.ebuild
@@ -0,0 +1,230 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0.4-r2.ebuild,v 1.1 2006/06/28 09:50:14 uberlord Exp $
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+MY_PV="${PV//_beta/b}"
+MY_PV="${MY_PV//_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="ISC Dynamic Host Configuration Protocol"
+HOMEPAGE="http://www.isc.org/products/DHCP"
+SRC_URI="ftp://ftp.isc.org/isc/dhcp/${MY_P}.tar.gz"
+
+LICENSE="isc-dhcp"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc minimal static selinux"
+
+DEPEND="selinux? ( sec-policy/selinux-dhcp )
+ kernel_linux? ( sys-apps/net-tools )"
+
+PROVIDE="virtual/dhcpc"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Gentoo patches - these will probably never be accepted upstream
+ # Enable chroot support
+ epatch "${FILESDIR}/${PN}"-3.0-paranoia.patch
+ # Fix some permission issues
+ epatch "${FILESDIR}/${PN}"-3.0-fix-perms.patch
+ # Enable dhclient to equery NTP servers
+ epatch "${FILESDIR}/${PN}"-3.0.3-dhclient-ntp.patch
+ # resolvconf support in dhclient-script
+ epatch "${FILESDIR}/${PN}"-3.0.3-dhclient-resolvconf.patch
+ # Fix setting hostnames on Linux
+ epatch "${FILESDIR}/${PN}"-3.0.3-dhclient-hostname.patch
+ # Allow mtu settings
+ epatch "${FILESDIR}/${PN}"-3.0.3-dhclient-mtu.patch
+ # Allow dhclient to use IF_METRIC to set route metrics
+ epatch "${FILESDIR}/${PN}"-3.0.3-dhclient-metric.patch
+ # Stop downing the interface on Linux as that breaks link dameons
+ # such as wpa_supplicant and netplug
+ epatch "${FILESDIR}/${PN}"-3.0.3-dhclient-no-down.patch
+ # Quiet the isc blurb
+ epatch "${FILESDIR}/${PN}"-3.0.3-no_isc_blurb.patch
+ # Enable dhclient to get extra configuration from stdin
+ epatch "${FILESDIR}/${PN}"-3.0.4-dhclient-stdin-conf.patch
+
+ # General fixes which will probably be accepted upstream eventually
+ # Install libdst, #75544
+ epatch "${FILESDIR}/${PN}"-3.0.3-libdst.patch
+ # Fix building on Gentoo/FreeBSD
+ epatch "${FILESDIR}/${PN}"-3.0.2-gmake.patch
+ # Fix 64-bit servers, #133905
+ epatch "${FILESDIR}/${PN}"-3.0.4-64bit.patch
+
+ # NetworkManager support patches
+ # If they fail to apply to future versions they will be dropped
+ # Enable eXtended options
+ epatch "${FILESDIR}/${PN}"-3.0.3-x-option.patch
+ # Add dbus support to dhclient
+ epatch "${FILESDIR}/${PN}"-3.0.3-dhclient-dbus.patch
+
+ # Brand the version with Gentoo
+ # include revision if >0
+ local newver="${MY_PV}-Gentoo"
+ [[ ${PR} != "r0" ]] && newver="${newver}-${PR}"
+ sed -i '/^#define DHCP_VERSION[ \t]\+/ s/'"${MY_PV}/${newver}/g" \
+ includes/version.h || die
+
+ # Change the hook script locations of the scripts
+ sed -i -e 's,/etc/dhclient-exit-hooks,/etc/dhcp/dhclient-exit-hooks,g' \
+ -e 's,/etc/dhclient-enter-hooks,/etc/dhcp/dhclient-enter-hooks,g' \
+ client/scripts/* || die
+
+ # Remove these options from the sample config
+ sed -i -e "/\(script\|host-name\|domain-name\) / d" \
+ client/dhclient.conf || die
+
+ # Build sed man pages as we don't ever support BSD 4.4 and older, #130251.
+ local x=
+ for x in Makefile.dist $(ls */Makefile.dist) ; do
+ sed -i -e 's/$(CATMANPAGES)/$(SEDMANPAGES)/g' "${x}" || die
+ done
+
+ # Only install different man pages if we don't have en
+ if [[ " ${LINGUAS} " != *" en "* ]]; then
+ # Install Japanese man pages
+ if [[ " ${LINGUAS} " == *" ja "* && -d doc/ja_JP.eucJP ]]; then
+ einfo "Installing Japanese documention"
+ cp doc/ja_JP.eucJP/dhclient* client
+ cp doc/ja_JP.eucJP/dhcp* common
+ fi
+ fi
+
+ # Now remove the non-english docs so there are no errors later
+ [[ -d doc/ja_JP.eucJP ]] && rm -rf doc/ja_JP.eucJP
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ cat <<-END >> includes/site.h
+ #define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
+ #define _PATH_DHCPD_PID "/var/run/dhcp/dhcpd.pid"
+ #define _PATH_DHCPD_DB "/var/lib/dhcp/dhcpd.leases"
+ #define _PATH_DHCLIENT_CONF "/etc/dhcp/dhclient.conf"
+ #define _PATH_DHCLIENT_DB "/var/lib/dhcp/dhclient.leases"
+ #define _PATH_DHCLIENT_PID "/var/run/dhcp/dhclient.pid"
+ #define DHCPD_LOG_FACILITY LOG_LOCAL1
+ END
+
+ cat <<-END > site.conf
+ CC = $(tc-getCC)
+ LFLAGS = ${LDFLAGS}
+ LIBDIR = /usr/$(get_libdir)
+ INCDIR = /usr/include
+ ETC = /etc/dhcp
+ VARDB = /var/lib/dhcp
+ VARRUN = /var/run/dhcp
+ ADMMANDIR = /usr/share/man/man8
+ ADMMANEXT = .8
+ FFMANDIR = /usr/share/man/man5
+ FFMANEXT = .5
+ LIBMANDIR = /usr/share/man/man3
+ LIBMANEXT = .3
+ USRMANDIR = /usr/share/man/man1
+ USRMANEXT = .1
+ MANCAT = man
+ END
+
+ ./configure --copts "-DPARANOIA -DEARLY_CHROOT -DEXTENDED_NEW_OPTION_INFO \
+ ${CFLAGS}" || die "configure failed"
+
+ # Remove server support from the Makefile
+ # We still install some extra crud though
+ if use minimal ; then
+ sed -i -e 's/\(server\|relay\|dhcpctl\)/ /g' work.*/Makefile || die
+ fi
+ emake || die "compile problem"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ use doc && dodoc README RELNOTES doc/*
+
+ insinto /etc/dhcp
+ newins client/dhclient.conf dhclient.conf.sample
+ keepdir /var/{lib,run}/dhcp
+
+ # Install our server files
+ if ! use minimal ; then
+ insinto /etc/dhcp
+ newins server/dhcpd.conf dhcpd.conf.sample
+ newinitd "${FILESDIR}"/dhcpd.init dhcpd
+ newinitd "${FILESDIR}"/dhcrelay.init dhcrelay
+ insinto /etc/conf.d
+ newins "${FILESDIR}"/dhcpd.conf dhcpd
+ newins "${FILESDIR}"/dhcrelay.conf dhcrelay
+ fi
+}
+
+pkg_preinst() {
+ if ! use minimal ; then
+ enewgroup dhcp
+ enewuser dhcp -1 -1 /var/lib/dhcp dhcp
+ fi
+}
+
+pkg_postinst() {
+ use minimal && return
+
+ chown dhcp:dhcp "${ROOT}"/var/{lib,run}/dhcp
+
+ if [[ -e "${ROOT}"/etc/init.d/dhcp ]] ; then
+ ewarn
+ ewarn "WARNING: The dhcp init script has been renamed to dhcpd"
+ ewarn "/etc/init.d/dhcp and /etc/conf.d/dhcp need to be removed and"
+ ewarn "and dhcp should be removed from the default runlevel"
+ ewarn
+ fi
+
+ einfo "You can edit /etc/conf.d/dhcpd to customize dhcp settings."
+ einfo
+ einfo "If you would like to run dhcpd in a chroot, simply configure the"
+ einfo "DHCPD_CHROOT directory in /etc/conf.d/dhcpd and then run:"
+ einfo " emerge --config =${PF}"
+}
+
+pkg_config() {
+ if use minimal ; then
+ eerror "${PN} has not been compiled for server support"
+ eerror "emerge ${PN} without the minimal USE flag to use dhcp sever"
+ return 1
+ fi
+
+ local CHROOT="$(
+ sed -n -e 's/^[[:blank:]]\?DHCPD_CHROOT="*\([^#"]\+\)"*/\1/p' \
+ "${ROOT}"/etc/conf.d/dhcpd
+ )"
+
+ if [[ -z ${CHROOT} ]]; then
+ eerror "CHROOT not defined in /etc/conf.d/dhcpd"
+ return 1
+ fi
+
+ CHROOT="${ROOT}/${CHROOT}"
+
+ if [[ -d ${CHROOT} ]] ; then
+ ewarn "${CHROOT} already exists - aborting"
+ return 0
+ fi
+
+ ebegin "Setting up the chroot directory"
+ mkdir -m 0755 -p "${CHROOT}/"{dev,etc,var/lib,var/run/dhcp}
+ cp /etc/{localtime,resolv.conf} "${CHROOT}"/etc
+ cp -R /etc/dhcp "${CHROOT}"/etc
+ cp -R /var/lib/dhcp "${CHROOT}"/var/lib
+ ln -s ../../var/lib/dhcp "${CHROOT}"/etc/dhcp/lib
+ chown -R dhcp:dhcp "${CHROOT}"/var/{lib,run}/dhcp
+ eend 0
+
+ local logger="$(best_version virtual/logger)"
+ einfo "To enable logging from the dhcpd server, configure your"
+ einfo "logger (${logger}) to listen on ${CHROOT}/dev/log"
+}
diff --git a/net-misc/dhcp/files/dhcp-3.0.4-64bit.patch b/net-misc/dhcp/files/dhcp-3.0.4-64bit.patch
new file mode 100644
index 000000000000..81f50f2f3316
--- /dev/null
+++ b/net-misc/dhcp/files/dhcp-3.0.4-64bit.patch
@@ -0,0 +1,91 @@
+# Fix 64 bit machines, Gentoo bug #133905
+
+--- dhcp-3.0.4/includes/dhcpd.h
++++ dhcp-3.0.4/includes/dhcpd.h
+@@ -339,7 +339,7 @@
+ struct option_state *options;
+ struct data_string parameter_request_list;
+ int max_message_size;
+- TIME expiry, renewal, rebind;
++ unsigned char expiry[4], renewal[4], rebind[4];
+ struct data_string filename, server_name;
+ int got_requested_address;
+ int got_server_identifier;
+--- dhcp-3.0.4/server/dhcp.c
++++ dhcp-3.0.4/server/dhcp.c
+@@ -34,7 +34,7 @@
+
+ #ifndef lint
+ static char copyright[] =
+-"$Id: dhcp-3.0.4-64bit.patch,v 1.1 2006/06/28 09:50:14 uberlord Exp $ Copyright (c) 2004-2006 Internet Systems Consortium. All rights reserved.\n";
++"$Id: dhcp-3.0.4-64bit.patch,v 1.1 2006/06/28 09:50:14 uberlord Exp $ Copyright (c) 2004-2006 Internet Systems Consortium. All rights reserved.\n";
+ #endif /* not lint */
+
+ #include "dhcpd.h"
+@@ -2442,18 +2442,15 @@
+ offered_lease_time =
+ state -> offered_expiry - cur_time;
+
+- putULong ((unsigned char *)&state -> expiry,
+- (unsigned long)offered_lease_time);
++ putULong(state->expiry, (u_int32_t)offered_lease_time);
+ i = DHO_DHCP_LEASE_TIME;
+ if (lookup_option (&dhcp_universe, state -> options, i))
+ log_error ("dhcp-lease-time option for %s overridden.",
+ inet_ntoa (state -> ciaddr));
+ oc = (struct option_cache *)0;
+ if (option_cache_allocate (&oc, MDL)) {
+- if (make_const_data (&oc -> expression,
+- (unsigned char *)&state -> expiry,
+- sizeof state -> expiry,
+- 0, 0, MDL)) {
++ if (make_const_data(&oc->expression, state->expiry,
++ 4, 0, 0, MDL)) {
+ oc -> option = dhcp_universe.options [i];
+ save_option (&dhcp_universe,
+ state -> options, oc);
+@@ -2463,19 +2460,15 @@
+
+ /* Renewal time is lease time * 0.5. */
+ offered_lease_time /= 2;
+- putULong ((unsigned char *)&state -> renewal,
+- (unsigned long)offered_lease_time);
++ putULong(state->renewal, (u_int32_t)offered_lease_time);
+ i = DHO_DHCP_RENEWAL_TIME;
+ if (lookup_option (&dhcp_universe, state -> options, i))
+ log_error ("overriding dhcp-renewal-time for %s.",
+ inet_ntoa (state -> ciaddr));
+ oc = (struct option_cache *)0;
+ if (option_cache_allocate (&oc, MDL)) {
+- if (make_const_data (&oc -> expression,
+- (unsigned char *)
+- &state -> renewal,
+- sizeof state -> renewal,
+- 0, 0, MDL)) {
++ if (make_const_data(&oc->expression, state->renewal,
++ 4, 0, 0, MDL)) {
+ oc -> option = dhcp_universe.options [i];
+ save_option (&dhcp_universe,
+ state -> options, oc);
+@@ -2486,18 +2479,15 @@
+ /* Rebinding time is lease time * 0.875. */
+ offered_lease_time += (offered_lease_time / 2
+ + offered_lease_time / 4);
+- putULong ((unsigned char *)&state -> rebind,
+- (unsigned)offered_lease_time);
++ putULong(state->rebind, (u_int32_t)offered_lease_time);
+ i = DHO_DHCP_REBINDING_TIME;
+ if (lookup_option (&dhcp_universe, state -> options, i))
+ log_error ("overriding dhcp-rebinding-time for %s.",
+ inet_ntoa (state -> ciaddr));
+ oc = (struct option_cache *)0;
+ if (option_cache_allocate (&oc, MDL)) {
+- if (make_const_data (&oc -> expression,
+- (unsigned char *)&state -> rebind,
+- sizeof state -> rebind,
+- 0, 0, MDL)) {
++ if (make_const_data(&oc->expression, state->rebind,
++ 4, 0, 0, MDL)) {
+ oc -> option = dhcp_universe.options [i];
+ save_option (&dhcp_universe,
+ state -> options, oc);
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0.4-r2 b/net-misc/dhcp/files/digest-dhcp-3.0.4-r2
new file mode 100644
index 000000000000..03ec8dae9fa3
--- /dev/null
+++ b/net-misc/dhcp/files/digest-dhcp-3.0.4-r2
@@ -0,0 +1,3 @@
+MD5 004ef935fd54b8046b16bdde31a9e151 dhcp-3.0.4.tar.gz 883245
+RMD160 f5636d87e1e2138bd239157f54d8f73c73af73ac dhcp-3.0.4.tar.gz 883245
+SHA256 89171155b7a9225f5eb81c83ff63f071168b87eacab05fb859b8397d36809bf7 dhcp-3.0.4.tar.gz 883245