summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2005-01-23 20:43:24 +0000
committerSimon Stelling <blubb@gentoo.org>2005-01-23 20:43:24 +0000
commit326b942ac965fe344d07e5c6c2086c92f05a0aae (patch)
treeceba6a87ef4f4a0d5131d71bd82367b344d2567c /net-misc
parentUnstable ppc-macos. Bug #67036 (diff)
downloadgentoo-2-326b942ac965fe344d07e5c6c2086c92f05a0aae.tar.gz
gentoo-2-326b942ac965fe344d07e5c6c2086c92f05a0aae.tar.bz2
gentoo-2-326b942ac965fe344d07e5c6c2086c92f05a0aae.zip
fix 59104
(Portage version: 2.0.51-r14)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gsmlib/ChangeLog8
-rw-r--r--net-misc/gsmlib/files/gsmlib-1.11-include-gcc34-fix.patch52
-rw-r--r--net-misc/gsmlib/gsmlib-1.10-r1.ebuild4
-rw-r--r--net-misc/gsmlib/gsmlib-1.10.ebuild4
-rw-r--r--net-misc/gsmlib/gsmlib-1.11_pre030826.ebuild14
5 files changed, 73 insertions, 9 deletions
diff --git a/net-misc/gsmlib/ChangeLog b/net-misc/gsmlib/ChangeLog
index 37e9cc2c1017..a8e562de04d7 100644
--- a/net-misc/gsmlib/ChangeLog
+++ b/net-misc/gsmlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/gsmlib
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gsmlib/ChangeLog,v 1.8 2004/11/12 20:26:31 gustavoz Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsmlib/ChangeLog,v 1.9 2005/01/23 20:43:15 blubb Exp $
+
+ 23 Jan 2005; Simon Stelling <blubb@gentoo.org>
+ +files/gsmlib-1.11-include-gcc34-fix.patch, gsmlib-1.11_pre030826.ebuild:
+ added Anton Golubtsov's patch to fix bug
12 Nov 2004; Gustavo Zacarias <gustavoz@gentoo.org>
gsmlib-1.11_pre030826.ebuild:
diff --git a/net-misc/gsmlib/files/gsmlib-1.11-include-gcc34-fix.patch b/net-misc/gsmlib/files/gsmlib-1.11-include-gcc34-fix.patch
new file mode 100644
index 000000000000..dda545124859
--- /dev/null
+++ b/net-misc/gsmlib/files/gsmlib-1.11-include-gcc34-fix.patch
@@ -0,0 +1,52 @@
+--- gsmlib-1.11/gsmlib/gsm_map_key.h 2002-05-14 23:38:12.000000000 +0400
++++ gsmlib-1.11-fixed/gsmlib/gsm_map_key.h 2004-08-02 00:56:40.997784696 +0400
+@@ -25,6 +25,16 @@
+
+ // wrapper for map key, can access Sortedtore to get sortOrder()
+
++ // compare two keys
++ template <class SortedStore> class MapKey;
++
++ template <class SortedStore>
++ bool operator<(const MapKey<SortedStore> &x,
++ const MapKey<SortedStore> &y);
++ template <class SortedStore>
++ bool operator==(const MapKey<SortedStore> &x,
++ const MapKey<SortedStore> &y);
++
+ template <class SortedStore> class MapKey
+ {
+ SortedStore &_myStore; // my store
+@@ -47,20 +57,16 @@
+
+ friend
+ bool operator<
+-#ifndef WIN32
+- <>
+-#endif
++ <SortedStore>
+ (const MapKey<SortedStore> &x,
+ const MapKey<SortedStore> &y);
+ friend
+ bool operator==
+-#ifndef WIN32
+- <>
+-#endif
++ <SortedStore>
+ (const MapKey<SortedStore> &x,
+ const MapKey<SortedStore> &y);
+ };
+-
++/*
+ // compare two keys
+ template <class SortedStore>
+ extern bool operator<(const MapKey<SortedStore> &x,
+@@ -68,7 +74,7 @@
+ template <class SortedStore>
+ extern bool operator==(const MapKey<SortedStore> &x,
+ const MapKey<SortedStore> &y);
+-
++ */
+ // MapKey members
+
+ template <class SortedStore>
diff --git a/net-misc/gsmlib/gsmlib-1.10-r1.ebuild b/net-misc/gsmlib/gsmlib-1.10-r1.ebuild
index d2bff18f7c49..19dfd07a5676 100644
--- a/net-misc/gsmlib/gsmlib-1.10-r1.ebuild
+++ b/net-misc/gsmlib/gsmlib-1.10-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gsmlib/gsmlib-1.10-r1.ebuild,v 1.2 2004/07/26 00:59:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsmlib/gsmlib-1.10-r1.ebuild,v 1.3 2005/01/23 20:43:23 blubb Exp $
inherit eutils
diff --git a/net-misc/gsmlib/gsmlib-1.10.ebuild b/net-misc/gsmlib/gsmlib-1.10.ebuild
index b4e7815427b8..323a80ea50ec 100644
--- a/net-misc/gsmlib/gsmlib-1.10.ebuild
+++ b/net-misc/gsmlib/gsmlib-1.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gsmlib/gsmlib-1.10.ebuild,v 1.8 2004/07/15 02:50:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsmlib/gsmlib-1.10.ebuild,v 1.9 2005/01/23 20:43:23 blubb Exp $
IUSE=""
DESCRIPTION="Library and Applications to access GSM mobile phones"
diff --git a/net-misc/gsmlib/gsmlib-1.11_pre030826.ebuild b/net-misc/gsmlib/gsmlib-1.11_pre030826.ebuild
index 125b8b07462e..b93f32b3dcda 100644
--- a/net-misc/gsmlib/gsmlib-1.11_pre030826.ebuild
+++ b/net-misc/gsmlib/gsmlib-1.11_pre030826.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gsmlib/gsmlib-1.11_pre030826.ebuild,v 1.5 2004/11/12 20:26:31 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsmlib/gsmlib-1.11_pre030826.ebuild,v 1.6 2005/01/23 20:43:23 blubb Exp $
+
+inherit eutils
MY_A=${PN}-pre${PV%_pre*}-${PV#*_pre}
@@ -13,10 +15,16 @@ DEPEND="virtual/libc"
IUSE=""
SLOT="0"
LICENSE="LGPL-2"
-KEYWORDS="x86 ~ppc sparc"
+KEYWORDS="x86 ~ppc sparc ~amd64"
S=${WORKDIR}/${PN}-${PV%_pre*}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use amd64 && epatch ${FILESDIR}/gsmlib-1.11-include-gcc34-fix.patch
+}
+
src_compile() {
econf || die
make || die