summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-05 17:09:24 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-05 17:09:24 +0000
commit2d54219a2e4eff9318acfc7b3ee67bd224dce4b6 (patch)
treef7994992e74e1db559cde8c89b351472d1491a2a /net-misc
parentadd local use flag lzo for net-misc/vtun and synchronize lzo use flag in tran... (diff)
downloadgentoo-2-2d54219a2e4eff9318acfc7b3ee67bd224dce4b6.tar.gz
gentoo-2-2d54219a2e4eff9318acfc7b3ee67bd224dce4b6.tar.bz2
gentoo-2-2d54219a2e4eff9318acfc7b3ee67bd224dce4b6.zip
Version bump by seventhguardian, user from Gentoo Sunrise.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vtun/ChangeLog7
-rw-r--r--net-misc/vtun/files/digest-vtun-3.0.13
-rw-r--r--net-misc/vtun/vtun-3.0.1.ebuild44
3 files changed, 53 insertions, 1 deletions
diff --git a/net-misc/vtun/ChangeLog b/net-misc/vtun/ChangeLog
index 34e32e26d19d..d54a9c8ac8e8 100644
--- a/net-misc/vtun/ChangeLog
+++ b/net-misc/vtun/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/vtun
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vtun/ChangeLog,v 1.31 2007/04/29 17:52:39 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vtun/ChangeLog,v 1.32 2007/07/05 17:09:24 drac Exp $
+
+*vtun-3.0.1 (05 Jul 2007)
+
+ 05 Jul 2007; Samuli Suominen <drac@gentoo.org> +vtun-3.0.1.ebuild:
+ Version bump by seventhguardian, user from Gentoo Sunrise.
29 Apr 2007; Torsten Veller <tove@gentoo.org> vtun-2.6.ebuild,
vtun-2.6-r1.ebuild:
diff --git a/net-misc/vtun/files/digest-vtun-3.0.1 b/net-misc/vtun/files/digest-vtun-3.0.1
new file mode 100644
index 000000000000..c55e71ac1bda
--- /dev/null
+++ b/net-misc/vtun/files/digest-vtun-3.0.1
@@ -0,0 +1,3 @@
+MD5 c342ffe77055d4248a38f0b380f28c1b vtun-3.0.1.tar.gz 124829
+RMD160 49e55a084cea6048f14dbc1137f7dbcf012b6bbb vtun-3.0.1.tar.gz 124829
+SHA256 22507499a8f650ef97157977e62fa632d5b0034070629a2d0fd0512e304eaeeb vtun-3.0.1.tar.gz 124829
diff --git a/net-misc/vtun/vtun-3.0.1.ebuild b/net-misc/vtun/vtun-3.0.1.ebuild
new file mode 100644
index 000000000000..340579de149e
--- /dev/null
+++ b/net-misc/vtun/vtun-3.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vtun/vtun-3.0.1.ebuild,v 1.1 2007/07/05 17:09:24 drac Exp $
+
+DESCRIPTION="Create virtual tunnels over TCP/IP networks with traffic shaping, encryption, and compression."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://vtun.sourceforge.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="lzo socks5 ssl zlib"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6c )"
+DEPEND="${RDEPEND}
+ lzo? ( dev-libs/lzo )
+ zlib? ( sys-libs/zlib )
+ socks5? ( net-proxy/dante )
+ sys-devel/bison"
+
+src_compile() {
+ econf $(use_enable ssl) \
+ $(use_enable zlib) \
+ $(use_enable lzo) \
+ $(use_enable socks5 socks) \
+ --enable-shaper
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ChangeLog Credits FAQ README README.Setup README.Shaper TODO
+ newinitd "${FILESDIR}"/vtun.rc vtun
+ insinto etc
+ doins "${FILESDIR}"/vtund-start.conf
+}
+
+pkg_postinst() {
+ elog "You will need the Universal TUN/TAP driver compiled into"
+ elog "your kernel or as a module to use the associated tunnel"
+ elog "modes in vtun."
+ elog
+ elog "Also note that vtun-3 is not compatible with vtun-2."
+}