summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-08-06 20:53:01 +0000
committerDonny Davies <woodchip@gentoo.org>2003-08-06 20:53:01 +0000
commit0e8a018ab64dbe71cb23b693dd528aab33c80419 (patch)
tree43f56c8130b9e7313b16822b4a1773b368d57475 /net-misc
parentAdd X509 cert patch (diff)
downloadgentoo-2-0e8a018ab64dbe71cb23b693dd528aab33c80419.tar.gz
gentoo-2-0e8a018ab64dbe71cb23b693dd528aab33c80419.tar.bz2
gentoo-2-0e8a018ab64dbe71cb23b693dd528aab33c80419.zip
Add X509 cert patch
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/ChangeLog8
-rw-r--r--net-misc/openssh/Manifest4
-rw-r--r--net-misc/openssh/files/digest-openssh-3.6.1_p2-r13
-rw-r--r--net-misc/openssh/openssh-3.6.1_p2-r1.ebuild143
4 files changed, 155 insertions, 3 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index b7325186e13d..b4520b158d67 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/openssh
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.40 2003/06/01 04:37:45 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.41 2003/08/06 20:52:50 woodchip Exp $
+
+*openssh-3.6.1_p2-r1 (06 Aug 2003)
+
+ 06 Aug 2003; Donny Davies <woodchip@gentoo.org> openssh-3.6.1_p2-r1.ebuild:
+ Added new local USE=X509 variable which includes Roumen Petrov's patch
+ providing support for authentication with X.509 certificates.
31 May 2003; Brandon Low <lostlogic@gentoo.org> files/sshd.rc6:
Add 'use dns logger' to the rcscript
diff --git a/net-misc/openssh/Manifest b/net-misc/openssh/Manifest
index a1a8def7e7d7..150799c1d6e8 100644
--- a/net-misc/openssh/Manifest
+++ b/net-misc/openssh/Manifest
@@ -1,6 +1,6 @@
-MD5 2ab01bd8fbf59c6f7139126b96977f6c ChangeLog 6618
+MD5 16b8630d6d475d71d0d0b2935ecfea95 ChangeLog 6661
MD5 d2b32ef014516810bcff0a895cde0d04 openssh-3.5_p1-r1.ebuild 3964
-MD5 56b102a8c5aba7d5a231eddb65a2fa16 openssh-3.6.1_p2-r1.ebuild 4171
+MD5 931213753214e65cd0f67be42d046113 openssh-3.6.1_p2-r1.ebuild 4176
MD5 ad5f45a180d6f310d0c62dbcff6d60c7 openssh-3.6.1_p2.ebuild 3978
MD5 f2472f97f00f203eee538d04a25acac5 files/digest-openssh-3.5_p1-r1 136
MD5 2cb187d8f60994c5e1b5fef2bcb6e85d files/openssh-3.5_p1-gentoo-sshd-gcc3.patch 315
diff --git a/net-misc/openssh/files/digest-openssh-3.6.1_p2-r1 b/net-misc/openssh/files/digest-openssh-3.6.1_p2-r1
new file mode 100644
index 000000000000..b2dfa929a6ac
--- /dev/null
+++ b/net-misc/openssh/files/digest-openssh-3.6.1_p2-r1
@@ -0,0 +1,3 @@
+MD5 f3879270bffe479e1bd057aa36258696 openssh-3.6.1p2.tar.gz 879629
+MD5 c425e65927b359382bf3618d265d45f1 openssh_3.6p1-5.se1.diff.bz2 54985
+MD5 ca8e6e61d71c1680c09aefb0f0fec02f openssh-3.6.1p2+x509g2.diff.gz 82452
diff --git a/net-misc/openssh/openssh-3.6.1_p2-r1.ebuild b/net-misc/openssh/openssh-3.6.1_p2-r1.ebuild
new file mode 100644
index 000000000000..8dae70cfaf5a
--- /dev/null
+++ b/net-misc/openssh/openssh-3.6.1_p2-r1.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-3.6.1_p2-r1.ebuild,v 1.1 2003/08/06 20:52:50 woodchip Exp $
+
+inherit eutils
+
+IUSE="ipv6 static pam tcpd kerberos selinux"
+IUSE="${IUSE} X509"
+
+X509_PATCH=${P/_/}+x509g2.diff.gz
+
+# Make it more portable between straight releases
+# and _p? releases.
+PARCH=${P/_/}
+S=${WORKDIR}/${PARCH}
+DESCRIPTION="Port of OpenBSD's free SSH release"
+HOMEPAGE="http://www.openssh.com/"
+SRC_URI="ftp://ftp.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/${PARCH}.tar.gz
+ selinux? http://lostlogicx.com/gentoo/openssh_3.6p1-5.se1.diff.bz2
+ X509? http://roumenpetrov.info/openssh/x509g2/${X509_PATCH}"
+
+# openssh recognizes when openssl has been slightly upgraded and refuses to run.
+# This new rev will use the new openssl.
+RDEPEND="virtual/glibc
+ pam? ( >=sys-libs/pam-0.73 >=sys-apps/shadow-4.0.2-r2 )
+ kerberos? ( app-crypt/mit-krb5 )
+ selinux? ( sys-apps/selinux-small )
+ >=dev-libs/openssl-0.9.6d
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ sys-apps/groff
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm ~amd64"
+
+src_unpack() {
+ unpack ${PARCH}.tar.gz
+ cd ${S}
+ use selinux && epatch ${DISTDIR}/openssh_3.6p1-5.se1.diff.bz2
+
+ if [ `use alpha` ]; then
+ epatch ${FILESDIR}/${PN}-3.5_p1-gentoo-sshd-gcc3.patch || die
+ fi
+
+ if [ `use X509` ]; then
+ epatch ${DISTDIR}/${X509_PATCH} || die
+ fi
+}
+
+src_compile() {
+ local myconf
+ use tcpd || myconf="${myconf} --without-tcp-wrappers"
+ use tcpd && myconf="${myconf} --with-tcp-wrappers"
+ use pam || myconf="${myconf} --without-pam"
+ use pam && myconf="${myconf} --with-pam"
+ use ipv6 || myconf="${myconf} --with-ipv4-default"
+
+ # app-crypt/mit-krb5
+ use kerberos && myconf="${myconf} --with-kerberos5"
+
+ # app-crypt/kth-krb
+ # KTH's implementation of kerberos IV
+ # KTH_KRB="yes" emerge openssh-3.5_p1-r1.ebuild
+ if [ ! -z $KTH_KRB ]; then
+ myconf="${myconf} --with-kerberos4=/usr/athena"
+ fi
+
+ use selinux && CFLAGS="${CFLAGS} -DWITH_SELINUX"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/ssh \
+ --mandir=/usr/share/man \
+ --libexecdir=/usr/lib/misc \
+ --datadir=/usr/share/openssh \
+ --disable-suid-ssh \
+ --with-privsep-path=/var/empty \
+ --with-privsep-user=sshd \
+ --with-md5-passwords \
+ --host=${CHOST} ${myconf} || die "bad configure"
+
+ if [ "`use static`" ]
+ then
+ # statically link to libcrypto -- good for the boot cd
+ perl -pi -e "s|-lcrypto|/usr/lib/libcrypto.a|g" Makefile
+ fi
+
+ if [ "`use selinux`" ]
+ then
+ #add -lsecure
+ sed "s:LIBS=\(.*\):LIBS=\1 -lsecure:" < Makefile > Makefile.new
+ mv Makefile.new Makefile
+ fi
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make install-files DESTDIR=${D} || die
+ chmod 600 ${D}/etc/ssh/sshd_config
+ dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
+ insinto /etc/pam.d ; newins ${FILESDIR}/sshd.pam sshd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/sshd.rc6 sshd
+ touch ${D}/var/empty/.keep
+}
+
+pkg_preinst() {
+
+ userdel sshd 2> /dev/null
+ if ! groupmod sshd; then
+ groupadd -g 90 sshd 2> /dev/null || \
+ die "Failed to create sshd group"
+ fi
+ useradd -u 22 -g sshd -s /dev/null -d /var/empty -c "sshd" sshd || \
+ die "Failed to create sshd user"
+
+}
+
+pkg_postinst() {
+
+ # empty dir for the new priv separation auth chroot..
+ install -d -m0755 -o root -g root ${ROOT}/var/empty
+
+ einfo
+ einfo "Remember to merge your config files in /etc/ssh!"
+ einfo "As of version 3.4 the default is to enable the UsePrivelegeSeparation"
+ einfo "functionality, but please ensure that you do not explicitly disable"
+ einfo "this in your configuration as disabling it opens security holes"
+ einfo
+ einfo "This revision has removed your sshd user id and replaced it with a"
+ einfo "new one with UID 22. If you have any scripts or programs that"
+ einfo "that referenced the old UID directly, you will need to update them."
+ einfo
+ if use pam >/dev/null 2>&1; then
+ einfo "Please be aware users need a valid shell in /etc/passwd"
+ einfo "in order to be allowed to login."
+ einfo
+ fi
+}