summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-07 07:36:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-07 07:36:28 +0000
commit0e129f52feae3a59c64457b572a203d6de7c492a (patch)
treefaa139c79524fad730d5ed4828bf50ecc8252db6 /net-misc
parentCleanup + fixing #51489 (Manifest recommit) (diff)
downloadgentoo-2-0e129f52feae3a59c64457b572a203d6de7c492a.tar.gz
gentoo-2-0e129f52feae3a59c64457b572a203d6de7c492a.tar.bz2
gentoo-2-0e129f52feae3a59c64457b572a203d6de7c492a.zip
patch for gcc3 (bug #53013); tidy
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tn5250/ChangeLog5
-rw-r--r--net-misc/tn5250/files/gcc3.patch76
-rw-r--r--net-misc/tn5250/tn5250-0.16.5.ebuild56
3 files changed, 105 insertions, 32 deletions
diff --git a/net-misc/tn5250/ChangeLog b/net-misc/tn5250/ChangeLog
index 703f38e49770..0ddacd9a4124 100644
--- a/net-misc/tn5250/ChangeLog
+++ b/net-misc/tn5250/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for net-misc/tn5250
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
# $Header
+ 07 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> tn5250-0.16.5.ebuild:
+ patch for gcc3 (bug #53013); tidy
+
*tn5250-0.16.5 (11 Dec 2002)
11 Dec 2002; Matt Keadle <mkeadle@gentoo.org> tn5250-0.16.5.ebuild
diff --git a/net-misc/tn5250/files/gcc3.patch b/net-misc/tn5250/files/gcc3.patch
new file mode 100644
index 000000000000..c2ac5c03d11a
--- /dev/null
+++ b/net-misc/tn5250/files/gcc3.patch
@@ -0,0 +1,76 @@
+--- tn5250.c.orig 2004-06-07 00:24:59.000000000 -0700
++++ tn5250.c 2004-06-07 00:28:22.000000000 -0700
+@@ -174,17 +174,17 @@
+ Tn5250CharMap *m;
+ int i = 0;
+
+- printf ("tn5250 - TCP/IP 5250 emulator\n\
+-Syntax:\n\
+- tn5250 [options] HOST[:PORT]\n");
++ printf ("tn5250 - TCP/IP 5250 emulator\n"
++ "Syntax:\n"
++ " tn5250 [options] HOST[:PORT]\n");
+ #ifdef HAVE_LIBSSL
+- printf("\
+- To connect using ssl prefix HOST with 'ssl:'. Example:
+- tn5250 +ssl_verify_server ssl:as400.example.com\n");
++ printf("\n"
++ " To connect using ssl prefix HOST with 'ssl:'. Example:\n"
++ " tn5250 +ssl_verify_server ssl:as400.example.com\n");
+ #endif
+- printf ("\n\
+-Options:\n\
+- map=NAME Character map (default is '37'):");
++ printf ("\n"
++ "Options:\n"
++ " map=NAME Character map (default is '37'):");
+ m = tn5250_transmaps;
+ while (m->name != NULL) {
+ if (i % 5 == 0)
+@@ -192,28 +192,28 @@
+ printf ("%s, ", m->name);
+ m++; i++;
+ }
+- printf ("\n\
+- env.DEVNAME=NAME Use NAME as session name (default: none).\n");
++ printf ("\n"
++ " env.DEVNAME=NAME Use NAME as session name (default: none).\n");
+ #ifndef NDEBUG
+- printf ("\
+- trace=FILE Log session to FILE.\n");
++ printf (
++ " trace=FILE Log session to FILE.\n");
+ #endif
+ #ifdef HAVE_LIBSSL
+- printf ("\
+- +/-ssl_verify_server Verify/don't verify the server's SSL certificate\n\
+- ssl_ca_file=FILE Use certificate authority (CA) certs from FILE\n\
+- ssl_cert_file=FILE File containing SSL certificate in PEM format to\n\
+- use if the AS/400 requires client authentication.\n\
+- ssl_pem_pass=PHRASE Passphrase to use when decrypting a PEM private\n\
+- key. Used in conjunction with ssl_cert_file\n");
++ printf (
++" +/-ssl_verify_server Verify/don't verify the server's SSL certificate\n"
++" ssl_ca_file=FILE Use certificate authority (CA) certs from FILE\n"
++" ssl_cert_file=FILE File containing SSL certificate in PEM format to\n"
++" use if the AS/400 requires client authentication.\n"
++" ssl_pem_pass=PHRASE Passphrase to use when decrypting a PEM private\n"
++" key. Used in conjunction with ssl_cert_file\n");
+ #endif
+- printf ("\
+- +/-underscores Use/don't use underscores instead of underline\n\
+- attribute.\n\
+- +/-ruler Draw a ruler pointing to the cursor position\n\
+- +/-version Show emulator version and exit.\n\
+- env.NAME=VALUE Set telnet environment string NAME to VALUE.\n\
+- env.TERM=TYPE Emulate IBM terminal type (default: depends)");
++ printf (
++" +/-underscores Use/don't use underscores instead of underline\n"
++" attribute.\n"
++" +/-ruler Draw a ruler pointing to the cursor position\n"
++" +/-version Show emulator version and exit.\n"
++" env.NAME=VALUE Set telnet environment string NAME to VALUE.\n"
++" env.TERM=TYPE Emulate IBM terminal type (default: depends)");
+ p = valid_terms;
+ while (p->name) {
+ printf ("\n %s (%s)", p->name, p->descr);
diff --git a/net-misc/tn5250/tn5250-0.16.5.ebuild b/net-misc/tn5250/tn5250-0.16.5.ebuild
index 74390e0b439c..fb283c79cf23 100644
--- a/net-misc/tn5250/tn5250-0.16.5.ebuild
+++ b/net-misc/tn5250/tn5250-0.16.5.ebuild
@@ -1,14 +1,16 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tn5250/tn5250-0.16.5.ebuild,v 1.4 2003/09/05 22:01:49 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tn5250/tn5250-0.16.5.ebuild,v 1.5 2004/06/07 07:36:28 mr_bones_ Exp $
+
+inherit eutils
DESCRIPTION="Telnet client for the IBM AS/400 that emulates 5250 terminals and printers."
HOMEPAGE="http://tn5250.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86"
-
IUSE="X ssl slang"
DEPEND="sys-libs/ncurses
@@ -16,51 +18,43 @@ DEPEND="sys-libs/ncurses
ssl? ( dev-libs/openssl )
slang? ( sys-libs/slang )"
-S="${WORKDIR}/${P}"
-
src_unpack() {
unpack ${A}
# First, for some reason, TRUE and FALSE aren't defined
# for the compile. This causes some problems. ???
- echo >> ${S}/src/tn5250-config.h.in
- echo "/* Define TRUE and FALSE */" >> ${S}/src/tn5250-config.h.in
- echo "#define FALSE 0" >> ${S}/src/tn5250-config.h.in
- echo "#define TRUE !FALSE" >> ${S}/src/tn5250-config.h.in
+ echo >> "${S}/src/tn5250-config.h.in"
+ echo "/* Define TRUE and FALSE */" >> "${S}/src/tn5250-config.h.in"
+ echo "#define FALSE 0" >> "${S}/src/tn5250-config.h.in"
+ echo "#define TRUE !FALSE" >> "${S}/src/tn5250-config.h.in"
# Next, the Makefile for the terminfo settings tries to remove
# some files it doesn't have access to. We can just remove those
# lines.
- cd ${S}/linux
- cp Makefile.in Makefile.in.orig
- sed -e "/rm -f \/usr\/.*\/terminfo.*5250/d" \
- Makefile.in.orig > Makefile.in
+ cd "${S}/linux"
+ sed -i \
+ -e "/rm -f \/usr\/.*\/terminfo.*5250/d" Makefile.in \
+ || die "sed Makefile.in failed"
+ cd "${S}/src"
+ epatch "${FILESDIR}/gcc3.patch"
}
src_compile() {
- local myconf
- myconf=""
- use X && myconf="${myconf} --with-x"
- use ssl && myconf="${myconf} --with-ssl"
- use slang && myconf="${myconf} --with-slang"
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --sysconfdir=/etc \
- ${myconf} || die "./configure failed"
- emake || die
+ econf \
+ $(use_with X x) \
+ $(use_with ssl) \
+ $(use_with slang) || die
+ emake || die "emake failed"
}
src_install() {
-
# The TERMINFO variable needs to be defined for the install
# to work, because the install calls "tic." man tic for
# details.
- mkdir -p ${D}/usr/share/terminfo
- make DESTDIR=${D} \
- TERMINFO=${D}/usr/share/terminfo install || die
- dodoc AUTHORS BUGS COPYING INSTALL NEWS README README.ssl TODO
+ dodir /usr/share/terminfo
+ make DESTDIR="${D}" \
+ TERMINFO="${D}/usr/share/terminfo" install \
+ || die "make install failed"
+ dodoc AUTHORS BUGS NEWS README README.ssl TODO
dohtml -r doc/*
}