summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-09-16 12:41:57 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-09-16 12:41:57 +0000
commit0d2ae4c4e85626eedd95005bf9eab4c9dc5b8fdb (patch)
tree39cf73fca7f7332f5977c2927f23c4f5771205ab /net-misc
parentDrop masked for removal package. (diff)
downloadgentoo-2-0d2ae4c4e85626eedd95005bf9eab4c9dc5b8fdb.tar.gz
gentoo-2-0d2ae4c4e85626eedd95005bf9eab4c9dc5b8fdb.tar.bz2
gentoo-2-0d2ae4c4e85626eedd95005bf9eab4c9dc5b8fdb.zip
Version bump
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vtun/ChangeLog8
-rw-r--r--net-misc/vtun/files/vtun-3.0.3-includes.patch62
-rw-r--r--net-misc/vtun/vtun-3.0.3.ebuild54
3 files changed, 123 insertions, 1 deletions
diff --git a/net-misc/vtun/ChangeLog b/net-misc/vtun/ChangeLog
index b8690df16227..d5bd70da3772 100644
--- a/net-misc/vtun/ChangeLog
+++ b/net-misc/vtun/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/vtun
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vtun/ChangeLog,v 1.51 2012/09/16 12:12:02 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vtun/ChangeLog,v 1.52 2012/09/16 12:41:57 pinkbyte Exp $
+
+*vtun-3.0.3 (16 Sep 2012)
+
+ 16 Sep 2012; Sergey Popov <pinkbyte@gentoo.org> +vtun-3.0.3.ebuild,
+ +files/vtun-3.0.3-includes.patch:
+ Version bump
16 Sep 2012; Sergey Popov <pinkbyte@gentoo.org> -files/vtun-2.6-lzo2.patch,
-files/vtun-2.6-makefile.patch:
diff --git a/net-misc/vtun/files/vtun-3.0.3-includes.patch b/net-misc/vtun/files/vtun-3.0.3-includes.patch
new file mode 100644
index 000000000000..cd7cf6a2a2ee
--- /dev/null
+++ b/net-misc/vtun/files/vtun-3.0.3-includes.patch
@@ -0,0 +1,62 @@
+--- a/lfd_encrypt.c 2008-01-07 23:35:32.000000000 +0100
++++ b/lfd_encrypt.c 2010-09-18 04:53:31.000000000 +0200
+@@ -44,6 +44,7 @@
+ #include <strings.h>
+ #include <string.h>
+ #include <time.h>
++#include <arpa/inet.h> /* htonl() */
+
+ #include "vtun.h"
+ #include "linkfd.h"
+--- a/lib.c 2008-01-07 23:35:40.000000000 +0100
++++ b/lib.c 2010-09-18 04:52:51.000000000 +0200
+@@ -34,6 +34,7 @@
+ #include <sys/wait.h>
+ #include <syslog.h>
+ #include <errno.h>
++#include <time.h> /* nanosleep() */
+
+ #include "vtun.h"
+ #include "linkfd.h"
+--- a/lib.h 2008-01-07 23:35:41.000000000 +0100
++++ b/lib.h 2010-09-18 04:56:50.000000000 +0200
+@@ -26,6 +26,7 @@
+ #include <sys/types.h>
+ #include <signal.h>
+ #include <errno.h>
++#include <unistd.h> /* read(), write() */
+
+ #ifdef HAVE_LIBUTIL_H
+ #include <libutil.h>
+--- a/vtun.h 2008-01-07 23:36:07.000000000 +0100
++++ b/vtun.h 2010-09-18 04:56:08.000000000 +0200
+@@ -232,5 +232,9 @@
+ int read_config(char *file);
+ struct vtun_host * find_host(char *host);
+ inline void clear_nat_hack_flags(int svr);
++int send_msg(int len, char *in, char **out);
++int send_ib_mesg(int *len, char **in);
++int recv_msg(int len, char *in, char **out);
++int recv_ib_mesg(int *len, char **in);
+
+ #endif
+--- a/lock.c 2008-01-07 23:35:50.000000000 +0100
++++ b/lock.c 2010-09-18 05:01:21.000000000 +0200
+@@ -32,6 +32,7 @@
+ #include <sys/types.h>
+ #include <signal.h>
+ #include <errno.h>
++#include <time.h> /* nanosleep() */
+
+ #include "vtun.h"
+ #include "linkfd.h"
+--- a/lfd_shaper.c 2008-01-07 23:35:36.000000000 +0100
++++ b/lfd_shaper.c 2010-09-18 05:07:12.000000000 +0200
+@@ -27,6 +27,7 @@
+ #include <stdlib.h>
+ #include <sys/time.h>
+ #include <syslog.h>
++#include <time.h> /* nanosleep() */
+
+ #include "vtun.h"
+ #include "linkfd.h"
diff --git a/net-misc/vtun/vtun-3.0.3.ebuild b/net-misc/vtun/vtun-3.0.3.ebuild
new file mode 100644
index 000000000000..e55288d01049
--- /dev/null
+++ b/net-misc/vtun/vtun-3.0.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vtun/vtun-3.0.3.ebuild,v 1.1 2012/09/16 12:41:57 pinkbyte Exp $
+
+EAPI=4
+
+inherit eutils linux-info
+
+DESCRIPTION="Create virtual tunnels over TCP/IP networks with traffic shaping, encryption, and compression"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://vtun.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="lzo socks5 ssl zlib"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ lzo? ( dev-libs/lzo:2 )
+ zlib? ( sys-libs/zlib )
+ socks5? ( net-proxy/dante )"
+DEPEND="${RDEPEND}
+ sys-devel/bison"
+
+DOCS="ChangeLog Credits FAQ README README.Setup README.Shaper TODO"
+
+CONFIG_CHECK="~TUN"
+
+src_prepare() {
+ sed -i Makefile.in \
+ -e '/^LDFLAGS/s|=|+=|g' \
+ || die "sed Makefile"
+ epatch "${FILESDIR}"/${P}-includes.patch
+ # remove unneeded checking for /etc/vtund.conf
+ epatch "${FILESDIR}"/${PN}-3.0.2-remove-config-presence-check.patch
+ # portage takes care about striping binaries itself
+ sed -i 's:$(BIN_DIR)/strip $(DESTDIR)$(SBIN_DIR)/vtund::' Makefile.in
+}
+
+src_configure() {
+ econf \
+ $(use_enable ssl) \
+ $(use_enable zlib) \
+ $(use_enable lzo) \
+ $(use_enable socks5 socks) \
+ --enable-shaper
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/vtun.rc vtun
+ insinto etc
+ doins "${FILESDIR}"/vtund-start.conf
+}