summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2007-12-02 17:56:44 +0000
committerTorsten Veller <tove@gentoo.org>2007-12-02 17:56:44 +0000
commit0a85f312989e1836466aaf8783b78f40e39283df (patch)
tree611009c7a4e1fc0e0e1749a8cff33797aae6942d /net-misc
parentinitial ebuild; fixed bug 201012 (diff)
downloadgentoo-2-0a85f312989e1836466aaf8783b78f40e39283df.tar.gz
gentoo-2-0a85f312989e1836466aaf8783b78f40e39283df.tar.bz2
gentoo-2-0a85f312989e1836466aaf8783b78f40e39283df.zip
Version bump
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/chrony/ChangeLog7
-rw-r--r--net-misc/chrony/chrony-1.23.ebuild60
-rw-r--r--net-misc/chrony/files/digest-chrony-1.233
3 files changed, 69 insertions, 1 deletions
diff --git a/net-misc/chrony/ChangeLog b/net-misc/chrony/ChangeLog
index e93693a847e7..7e841c03cb1e 100644
--- a/net-misc/chrony/ChangeLog
+++ b/net-misc/chrony/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/chrony
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.37 2007/08/20 12:55:42 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.38 2007/12/02 17:56:44 tove Exp $
+
+*chrony-1.23 (02 Dec 2007)
+
+ 02 Dec 2007; Torsten Veller <tove@gentoo.org> +chrony-1.23.ebuild:
+ Version bump.
20 Aug 2007; Torsten Veller <tove@gentoo.org> files/chronyd.conf:
Fix bug #189037
diff --git a/net-misc/chrony/chrony-1.23.ebuild b/net-misc/chrony/chrony-1.23.ebuild
new file mode 100644
index 000000000000..b7ab14465064
--- /dev/null
+++ b/net-misc/chrony/chrony-1.23.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/chrony-1.23.ebuild,v 1.1 2007/12/02 17:56:44 tove Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/_pre/-pre}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="http://chrony.sunsite.dk/"
+SRC_URI="http://chrony.sunsite.dk/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="readline"
+
+DEPEND="readline? ( >=sys-libs/readline-4.1-r4 )"
+
+src_unpack() {
+ unpack ${A} ; cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.20-conf.c-gentoo.diff
+ epatch "${FILESDIR}"/${PN}-1.20-chrony.conf.example-gentoo.diff
+ epatch "${FILESDIR}"/${PN}-1.21-makefile.diff
+
+ sed -i "s:/etc/chrony:/etc/chrony/chrony:g" \
+ chrony*.{1,5,8} faq.txt chrony.texi || die "sed failed"
+ epatch "${FILESDIR}"/${PN}-1.21-hppa.patch
+}
+
+src_compile() {
+ tc-export CC
+ local myconf
+ # selfwritten configure
+ use readline || myconf="--disable-readline"
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} ${EXTRA_ECONF} || die "configure failed"
+ emake all || die "make failed"
+ emake docs || die "make docs failed"
+}
+
+src_install() {
+ dobin chronyc || die
+ dosbin chronyd || die
+
+ dodoc chrony.txt README examples/chrony.{conf,keys}.example || die
+ dohtml chrony.html || die
+ doman *.{1,5,8}
+ doinfo chrony.info*
+
+ newinitd "${FILESDIR}"/chronyd.rc chronyd || die
+ dosed "s:the documentation directory:/usr/share/doc/${PF}/:" \
+ /etc/init.d/chronyd || die "doc sed failed"
+ newconfd "${FILESDIR}"/chronyd.conf chronyd || die
+
+ keepdir /var/{lib,log}/chrony /etc/chrony
+}
diff --git a/net-misc/chrony/files/digest-chrony-1.23 b/net-misc/chrony/files/digest-chrony-1.23
new file mode 100644
index 000000000000..0b341a42da74
--- /dev/null
+++ b/net-misc/chrony/files/digest-chrony-1.23
@@ -0,0 +1,3 @@
+MD5 ffce77695e55d8efda19ab0b78309c23 chrony-1.23.tar.gz 321015
+RMD160 6f92aeac15d252821ff72a02f340fc0e562eddc1 chrony-1.23.tar.gz 321015
+SHA256 889f292458ccb3f20ae4f5872110d776a639f1cda2d1df694eb88a14726832c5 chrony-1.23.tar.gz 321015