summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-02-14 19:14:11 +0000
committerJustin Lecher <jlec@gentoo.org>2012-02-14 19:14:11 +0000
commit0739e1a78197951c5803fc16cf6a1950a006dd9d (patch)
tree10131dcd30a8babaa70699327e49efa633dc4721 /net-misc
parentRequire pypy[bzip2], for quickpkg. (diff)
downloadgentoo-2-0739e1a78197951c5803fc16cf6a1950a006dd9d.tar.gz
gentoo-2-0739e1a78197951c5803fc16cf6a1950a006dd9d.tar.bz2
gentoo-2-0739e1a78197951c5803fc16cf6a1950a006dd9d.zip
Version Bump, #392999, fix for compilation with as-needed, respect CC, ensure correct deps, #397511
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vpnc/ChangeLog12
-rw-r--r--net-misc/vpnc/files/vpnc-0.5.3_p514-as-needed.patch47
-rw-r--r--net-misc/vpnc/metadata.xml34
-rw-r--r--net-misc/vpnc/vpnc-0.5.3_p457-r2.ebuild9
-rw-r--r--net-misc/vpnc/vpnc-0.5.3_p514.ebuild68
5 files changed, 147 insertions, 23 deletions
diff --git a/net-misc/vpnc/ChangeLog b/net-misc/vpnc/ChangeLog
index f79231c48221..8cde8984d35c 100644
--- a/net-misc/vpnc/ChangeLog
+++ b/net-misc/vpnc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/vpnc
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/ChangeLog,v 1.98 2011/07/03 17:30:21 fauli Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/ChangeLog,v 1.99 2012/02/14 19:14:11 jlec Exp $
+
+*vpnc-0.5.3_p514 (14 Feb 2012)
+
+ 14 Feb 2012; Justin Lecher <jlec@gentoo.org> vpnc-0.5.3_p457-r2.ebuild,
+ +vpnc-0.5.3_p514.ebuild, +files/vpnc-0.5.3_p514-as-needed.patch,
+ metadata.xml:
+ Version Bump, #392999, fix for compilation with as-needed, respect CC, ensure
+ correct deps, #397511
*vpnc-0.5.3_p457-r2 (03 Jul 2011)
diff --git a/net-misc/vpnc/files/vpnc-0.5.3_p514-as-needed.patch b/net-misc/vpnc/files/vpnc-0.5.3_p514-as-needed.patch
new file mode 100644
index 000000000000..18bc90a99587
--- /dev/null
+++ b/net-misc/vpnc/files/vpnc-0.5.3_p514-as-needed.patch
@@ -0,0 +1,47 @@
+ Makefile | 12 ++++++------
+ 1 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 270d7e1..578884e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -60,16 +60,16 @@ BINSRCS = $(addsuffix .c,$(BINS))
+ VERSION := $(shell sh mk-version)
+ RELEASE_VERSION := $(shell cat VERSION)
+
+-CC=gcc
++CC?=gcc
+ CFLAGS ?= -O3 -g
+ CFLAGS += -W -Wall -Wmissing-declarations -Wwrite-strings
+ CFLAGS += $(shell libgcrypt-config --cflags) $(CRYPTO_CFLAGS)
+ CPPFLAGS += -DVERSION=\"$(VERSION)\"
+ LDFLAGS ?= -g
+-LDFLAGS += $(shell libgcrypt-config --libs) $(CRYPTO_LDADD)
++LIBS += $(shell libgcrypt-config --libs) $(CRYPTO_LDADD)
+
+ ifeq ($(shell uname -s), SunOS)
+-LDFLAGS += -lnsl -lresolv -lsocket
++LIBS += -lnsl -lresolv -lsocket
+ endif
+ ifneq (,$(findstring Apple,$(shell $(CC) --version)))
+ # enabled in FSF GCC, disabled by default in Apple GCC
+@@ -79,16 +79,16 @@ endif
+ all : $(BINS) vpnc.8
+
+ vpnc : $(OBJS) vpnc.o
+- $(CC) -o $@ $^ $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ vpnc.8 : vpnc.8.template makeman.pl vpnc
+ ./makeman.pl
+
+ cisco-decrypt : cisco-decrypt.o decrypt-utils.o
+- $(CC) -o $@ $^ $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ test-crypto : sysdep.o test-crypto.o crypto.o $(CRYPTO_OBJS)
+- $(CC) -o $@ $^ $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ .depend: $(SRCS) $(BINSRCS)
+ $(CC) -MM $(SRCS) $(BINSRCS) $(CFLAGS) $(CPPFLAGS) > $@
diff --git a/net-misc/vpnc/metadata.xml b/net-misc/vpnc/metadata.xml
index e5dbbff438b0..5e6fc5290abe 100644
--- a/net-misc/vpnc/metadata.xml
+++ b/net-misc/vpnc/metadata.xml
@@ -1,21 +1,21 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>ljakab@ac.upc.edu</email>
- <name>Loránd Jakab</name>
- </maintainer>
- <maintainer>
- <email>mmokrejs@fold.natur.cuni.cz</email>
- <name>Martin Mokrejs</name>
- </maintainer>
- <maintainer>
- <email>fauli@gentoo.org</email>
- <name>Christian Faulhammer</name>
- </maintainer>
- <use>
- <flag name="openssl">Use <pkg>dev-libs/openssl</pkg> for hybrid-auth instead of <pkg>net-libs/gnutls, may cause license issues when redistributing</pkg>.</flag>
- <flag name="hybrid-auth">Enable hybrid authentication (certificates), only if not redistributed as compiled binary</flag>
- <flag name="resolvconf">Enable support for DNS managing framework <pkg>net-dns/openresolv</pkg></flag>
- </use>
+ <maintainer>
+ <email>ljakab@ac.upc.edu</email>
+ <name>Loránd Jakab</name>
+ </maintainer>
+ <maintainer>
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <maintainer>
+ <email>fauli@gentoo.org</email>
+ <name>Christian Faulhammer</name>
+ </maintainer>
+ <use>
+ <flag name="openssl">Use <pkg>dev-libs/openssl</pkg> for hybrid-auth instead of <pkg>net-libs/gnutls, may cause license issues when redistributing</pkg>.</flag>
+ <flag name="hybrid-auth">Enable hybrid authentication (certificates), only if not redistributed as compiled binary</flag>
+ <flag name="resolvconf">Enable support for DNS managing framework <pkg>net-dns/openresolv</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/net-misc/vpnc/vpnc-0.5.3_p457-r2.ebuild b/net-misc/vpnc/vpnc-0.5.3_p457-r2.ebuild
index 37c4e6b1869d..db7c51f4f877 100644
--- a/net-misc/vpnc/vpnc-0.5.3_p457-r2.ebuild
+++ b/net-misc/vpnc/vpnc-0.5.3_p457-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/vpnc-0.5.3_p457-r2.ebuild,v 1.1 2011/07/03 17:30:21 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/vpnc-0.5.3_p457-r2.ebuild,v 1.2 2012/02/14 19:14:11 jlec Exp $
EAPI=3
@@ -21,8 +21,9 @@ IUSE="resolvconf openssl bindist"
DEPEND=">=dev-libs/libgcrypt-1.1.91
>=sys-apps/iproute2-2.6.19.20061214[-minimal]
bindist? ( net-libs/gnutls )
- openssl? (
- !bindist? ( dev-libs/openssl )
+ !bindist? (
+ openssl? ( dev-libs/openssl )
+ !openssl? ( net-libs/gnutls )
)"
RDEPEND="${DEPEND}
diff --git a/net-misc/vpnc/vpnc-0.5.3_p514.ebuild b/net-misc/vpnc/vpnc-0.5.3_p514.ebuild
new file mode 100644
index 000000000000..369ef34409b1
--- /dev/null
+++ b/net-misc/vpnc/vpnc-0.5.3_p514.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/vpnc-0.5.3_p514.ebuild,v 1.1 2012/02/14 19:14:11 jlec Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Free client for Cisco VPN routing software"
+HOMEPAGE="http://www.unix-ag.uni-kl.de/~massar/vpnc/"
+# Modified vpnc-script taken from
+# http://git.infradead.org/users/dwmw2/vpnc-scripts.git, supports Solaris and IP v6, as reported in bug
+# Additionally added patches to fix some dead lock problems taken from
+# http://lists.unix-ag.uni-kl.de/pipermail/vpnc-devel/2010-March/003445.html
+# TODO: Create proper patchset!
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${PF}.tar.xz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="resolvconf openssl bindist"
+
+DEPEND="
+ dev-lang/perl
+ dev-libs/libgcrypt
+ >=sys-apps/iproute2-2.6.19.20061214[-minimal]
+ bindist? ( net-libs/gnutls )
+ !bindist? (
+ openssl? ( dev-libs/openssl )
+ !openssl? ( net-libs/gnutls )
+ )"
+RDEPEND="${DEPEND}
+ resolvconf? ( net-dns/openresolv )"
+
+src_prepare() {
+ if use openssl && ! use bindist; then
+ sed -i -e '/^#OPENSSL_GPL_VIOLATION/s:#::g' "${S}"/Makefile || die
+ ewarn "Building SSL support with OpenSSL instead of GnuTLS. This means that"
+ ewarn "you are not allowed to re-distibute the binaries due to conflicts between BSD license and GPL,"
+ ewarn "see the vpnc Makefile and http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440318"
+ else
+ elog "Will build with GnuTLS (default) instead of OpenSSL so you may even redistribute binaries."
+ elog "See the Makefile itself and http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440318"
+ fi
+
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+
+ tc-export CC
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+ dodoc README TODO VERSION
+ keepdir /etc/vpnc/scripts.d
+ newinitd "${FILESDIR}/vpnc-3.init" vpnc
+ newconfd "${FILESDIR}/vpnc.confd" vpnc
+ sed -e "s:/usr/local:/usr:" -i "${D}"/etc/vpnc/vpnc-script || die
+ # COPYING file resides here, should not be installed
+ rm -rf "${D}"/usr/share/doc/vpnc/ || die
+}
+
+pkg_postinst() {
+ elog "You can generate a configuration file from the original Cisco profiles of your"
+ elog "connection by using /usr/bin/pcf2vpnc to convert the .pcf file"
+ elog "A guide is available in http://www.gentoo.org/doc/en/vpnc-howto.xml"
+ echo
+ elog "Don't forget to turn on TUN support in the kernel."
+}