summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-07-28 14:52:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-07-28 14:52:40 +0000
commit32572e5ca0909cff5e058ea02ea50128f5989f48 (patch)
tree61039835eb1134d79ad1594a83088681a93d9807 /net-misc/zaptel/zaptel-1.2.27-r1.ebuild
parentx11-drivers -> x11. (diff)
downloadgentoo-2-32572e5ca0909cff5e058ea02ea50128f5989f48.tar.gz
gentoo-2-32572e5ca0909cff5e058ea02ea50128f5989f48.tar.bz2
gentoo-2-32572e5ca0909cff5e058ea02ea50128f5989f48.zip
Use emake -j1, bug #279480.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/zaptel/zaptel-1.2.27-r1.ebuild')
-rw-r--r--net-misc/zaptel/zaptel-1.2.27-r1.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/net-misc/zaptel/zaptel-1.2.27-r1.ebuild b/net-misc/zaptel/zaptel-1.2.27-r1.ebuild
index db63923e3497..af246f2ed15a 100644
--- a/net-misc/zaptel/zaptel-1.2.27-r1.ebuild
+++ b/net-misc/zaptel/zaptel-1.2.27-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/zaptel-1.2.27-r1.ebuild,v 1.2 2009/07/27 22:05:02 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/zaptel-1.2.27-r1.ebuild,v 1.3 2009/07/28 14:52:40 flameeyes Exp $
inherit toolchain-funcs eutils linux-mod flag-o-matic multilib
@@ -252,19 +252,20 @@ src_compile() {
export MYLIBDIR="$(get_libdir)"
# build
- make KVERS=${KV_FULL} \
- KSRC=${KV_DIR} ARCH=$(tc-arch-kernel) || die
+ # bug #279480
+ emake -j1 KVERS=${KV_FULL} \
+ KSRC=${KV_DIR} ARCH=$(tc-arch-kernel) || die
if use astribank; then
cd "${S}"/xpp/utils
- make || die "make xpp utils failed"
+ emake -j1 || die "make xpp utils failed"
fi
if use bri; then
cd ${S_BRI}
for x in cwain qozap zaphfc; do
einfo "Building ${x}..."
- make KVERS=${KV_FULL} \
+ emake -j1 KVERS=${KV_FULL} \
KSRC=/usr/src/linux \
ARCH=$(tc-arch-kernel) \
-C ${x} || die "make ${x} failed"
@@ -277,7 +278,7 @@ src_install() {
mkdir -p "${D}"/lib/firmware/
kernel_is 2 4 && cp /etc/modules.conf "${D}"/etc
- make DESTDIR="${D}" ARCH=$(tc-arch-kernel) \
+ emake -j1 DESTDIR="${D}" ARCH=$(tc-arch-kernel) \
KVERS=${KV_FULL} KSRC=/usr/src/linux devices firmware \
install-modules install-programs || die
@@ -338,7 +339,7 @@ src_install() {
if use astribank; then
cd "${S}"/xpp/utils
eval `perl '-V:installarchlib'`
- make DESTDIR="${D}" PERLLIBDIR=${installarchlib} install || die "failed xpp utils install"
+ emake -j1 DESTDIR="${D}" PERLLIBDIR=${installarchlib} install || die "failed xpp utils install"
dosbin zt_registration xpp_sync lszaptel
fi
}