summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRajiv Aaron Manglani <rajiv@gentoo.org>2008-08-24 19:30:05 +0000
committerRajiv Aaron Manglani <rajiv@gentoo.org>2008-08-24 19:30:05 +0000
commit5ad95ef2f79682817fe98e300d9d5fa85b92fbbe (patch)
tree44f3601c46e182649a183488141923e229e3b621 /net-misc/zaptel/files
parentVersion bump (diff)
downloadgentoo-2-5ad95ef2f79682817fe98e300d9d5fa85b92fbbe.tar.gz
gentoo-2-5ad95ef2f79682817fe98e300d9d5fa85b92fbbe.tar.bz2
gentoo-2-5ad95ef2f79682817fe98e300d9d5fa85b92fbbe.zip
fix for multilib, bug #208190. thanks to gentoofan23 for the patch.
(Portage version: 2.1.5.4)
Diffstat (limited to 'net-misc/zaptel/files')
-rw-r--r--net-misc/zaptel/files/zaptel-1.2.26-gentoo.diff76
1 files changed, 76 insertions, 0 deletions
diff --git a/net-misc/zaptel/files/zaptel-1.2.26-gentoo.diff b/net-misc/zaptel/files/zaptel-1.2.26-gentoo.diff
new file mode 100644
index 000000000000..bea20d0b6912
--- /dev/null
+++ b/net-misc/zaptel/files/zaptel-1.2.26-gentoo.diff
@@ -0,0 +1,76 @@
+diff -uNr zaptel-1.2.26/build_tools/genmodconf zaptel-1.2.26-gentoo/build_tools/genmodconf
+--- zaptel-1.2.26/build_tools/genmodconf 2007-07-11 14:58:09.000000000 -0400
++++ zaptel-1.2.26-gentoo/build_tools/genmodconf 2008-08-24 14:24:16.000000000 -0400
+@@ -79,20 +79,6 @@
+
+ echo Building ${target}...
+
+-if [ "${1}" = "linux24" ]; then
+- for mod in ${3}; do
+- if ! grep -q "post-install ${mod} " ${target}; then
+- echo "post-install ${mod} /sbin/ztcfg" >> ${target}
+- fi
+- done
+-elif [ "${1}" = "linux26" ]; then
+- for mod in ${3}; do
+- if ! grep -q "install ${mod} " ${target}; then
+- echo "install ${mod} /sbin/modprobe --ignore-install ${mod} ${cmdopts} && /sbin/ztcfg" >> ${target}
+- fi
+- done
+-fi
+-
+ if [ -z "${combined}" ]; then
+ echo "***"
+ echo "*** WARNING:"
+diff -uNr zaptel-1.2.26/Makefile zaptel-1.2.26-gentoo/Makefile
+--- zaptel-1.2.26/Makefile 2008-03-31 20:08:21.000000000 -0400
++++ zaptel-1.2.26-gentoo/Makefile 2008-08-24 14:27:44.000000000 -0400
+@@ -121,7 +121,7 @@
+
+ INSTALL_PREFIX := /usr
+
+-CFLAGS+=-I. -O4 -g -fPIC -Wall
++CFLAGS+=-I. -g -Wall
+ ifneq (,$(findstring ppc,$(MACHINE)))
+ CFLAGS += -fsigned-char
+ KFLAGS += -msoft-float -fsigned-char
+@@ -209,7 +209,7 @@
+ LIBTONEZONE_SO_MAJOR_VER:=1
+ LIBTONEZONE_SO_MINOR_VER:=0
+
+-LIBDIR := $(INSTALL_PREFIX)/lib
++LIBDIR := $(INSTALL_PREFIX)/$(MYLIBDIR)
+ INCLUDE_DIR := $(INSTALL_PREFIX)/include
+ # Note: Zaptel's use of /sbin is slightly non-standard:
+ SBINDIR := /sbin
+@@ -302,7 +302,7 @@
+ $(CC) $(KFLAGS) -o $@ -c $<
+
+ zonedata.lo tonezone.lo: %.lo: %.c
+- $(CC) -c $(CFLAGS) -o $@ $^
++ $(CC) -c $(CFLAGS) -fPIC -o $@ $^
+
+ tones.h: gendigits
+ ./gendigits > $@
+@@ -412,7 +412,7 @@
+ else # DYNFS
+ ifdef UDEVRULES
+ install -d $(DESTDIR)/etc/udev/rules.d
+- build_tools/genudevrules > $(DESTDIR)/etc/udev/rules.d/zaptel.rules
++ build_tools/genudevrules > $(DESTDIR)/etc/udev/rules.d/10-zaptel.rules
+ else # !UDEVRULES
+ @echo "**** Dynamic filesystem detected -- not creating device nodes"
+ endif
+@@ -481,11 +481,10 @@
+ rm -f $(DESTDIR)$(MODS_DIR)/wcfxsusb.o
+ endif
+ rm -f $(DESTDIR)$(MODS_DIR)/wcfxs.o
+- [ `id -u` = 0 ] && /sbin/depmod -a $(KVERS) || :
+
+ install-libs: libs
+ install -D -m 755 $(LIBTONEZONE_SO) $(DESTDIR)$(LIBDIR)/$(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER).$(LIBTONEZONE_SO_MINOR_VER)
+- [ `id -u` = 0 ] && /sbin/ldconfig || :
++ [ `id -u` = 0 ] && /sbin/ldconfig -n $(DESTDIR)$(LIBDIR) || :
+ rm -f $(DESTDIR)$(LIBDIR)/$(LIBTONEZONE_SO)
+ ln -sf $(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER).$(LIBTONEZONE_SO_MINOR_VER) \
+ $(DESTDIR)$(LIBDIR)/$(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER)