summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-03-22 15:32:52 +0000
committerSven Wegener <swegener@gentoo.org>2005-03-22 15:32:52 +0000
commit201b8c513fbb03bd6de89de7c461e718617947f9 (patch)
tree8557349360243318c46cb0afbf699ad714624024 /net-misc/yate
parent(Portage version: 2.0.51.19) (Manifest recommit) (diff)
downloadgentoo-2-201b8c513fbb03bd6de89de7c461e718617947f9.tar.gz
gentoo-2-201b8c513fbb03bd6de89de7c461e718617947f9.tar.bz2
gentoo-2-201b8c513fbb03bd6de89de7c461e718617947f9.zip
Fixed invalid atom in *DEPEND. Replaced myconf with use_with magic.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/yate')
-rw-r--r--net-misc/yate/ChangeLog5
-rw-r--r--net-misc/yate/yate-0.8.7.ebuild61
2 files changed, 20 insertions, 46 deletions
diff --git a/net-misc/yate/ChangeLog b/net-misc/yate/ChangeLog
index b5a0903a8143..a481fb1d885d 100644
--- a/net-misc/yate/ChangeLog
+++ b/net-misc/yate/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/yate
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/yate/ChangeLog,v 1.2 2005/03/21 19:19:28 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/yate/ChangeLog,v 1.3 2005/03/22 15:32:52 swegener Exp $
+
+ 22 Mar 2005; Sven Wegener <swegener@gentoo.org> yate-0.8.7.ebuild:
+ Fixed invalid atom in *DEPEND. Replaced myconf with use_with magic.
21 Mar 2005; Stefan Knoblich <stkn@gentoo.org> yate-0.8.7.ebuild:
Now that there's a working spandsp version on amd64 we can keyword this
diff --git a/net-misc/yate/yate-0.8.7.ebuild b/net-misc/yate/yate-0.8.7.ebuild
index 4f15aad56e00..e952829fe3b0 100644
--- a/net-misc/yate/yate-0.8.7.ebuild
+++ b/net-misc/yate/yate-0.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/yate/yate-0.8.7.ebuild,v 1.2 2005/03/21 19:19:28 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/yate/yate-0.8.7.ebuild,v 1.3 2005/03/22 15:32:52 swegener Exp $
IUSE="h323 postgres zaptel fax qt gtk gsm ortp"
@@ -21,64 +21,35 @@ DEPEND="media-sound/sox
zaptel? ( >=net-libs/libpri-1.0.0
>=net-misc/zaptel-1.0.0 )
h323? ( >=net-libs/openh323-1.13.0 )
- fax? ( >=media-libs/spandsp )
+ fax? ( media-libs/spandsp )
qt? ( x11-libs/qt )
gtk? ( <x11-libs/gtk+-2.0.0 )
gsm? ( media-sound/gsm )
ortp? ( net-libs/ortp )"
-
src_compile() {
- local myconf
-
- use postgres \
- && myconf="${myconf} --with-libpq=/usr" \
- || myconf="${myconf} --without-libpq"
-
- use fax \
- && myconf="${myconf} --with-spandsp=/usr" \
- || myconf="${myconf} --without-spandsp"
-
- use qt \
- && myconf="${myconf} --with-libqt=${QTDIR}" \
- || myconf="${myconf} --without-libqt"
-
- use gtk \
- && myconf="${myconf} --with-libgtk" \
- || myconf="${myconf} --without-libgtk"
-
- use h323 \
- && myconf="${myconf} --with-openh323=/usr --with-pwlib=/usr" \
- || myconf="${myconf} --without-openh323 --without-pwlib"
-
- use zaptel \
- && myconf="${myconf} --with-libpri" \
- || myconf="${myconf} --without-libpri"
-
- use gsm \
- && myconf="${myconf} --with-libgsm" \
- || myconf="${myconf} --without-libgsm"
-
- use ortp \
- && myconf="${myconf} --with-libortp=/usr" \
- || myconf="${myconf} --without-libortp"
-
- econf ${myconf} || die "Configure failed"
+ econf \
+ $(use_with postgres libpq /usr) \
+ $(use_with fax spandsp /usr) \
+ $(use_with qt libqt "${QTDIR}") \
+ $(use_with gtk libgtk) \
+ $(use_with h323 openh323 /usr) \
+ $(use_with h323 pwlib /usr) \
+ $(use_with zaptel libpri) \
+ $(use_with gsm libgsm) \
+ $(use_with ortp libortp /usr) \
+ || die "Configure failed"
emake everything || die "Make failed"
}
src_install() {
emake DESTDIR=${D} install || die "Make install failed"
- exeinto /etc/init.d
- newexe ${FILESDIR}/yate.rc6 yate
-
- insinto /etc/conf.d
- newins ${FILESDIR}/yate.confd yate
+ newinitd ${FILESDIR}/yate.rc6 yate
+ newconfd ${FILESDIR}/yate.confd yate
# install standard docs...
- dodoc README ChangeLog
- dodoc docs/*
+ dodoc README ChangeLog docs/*
docinto scripts
dodoc scripts/*