summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-10-21 02:05:00 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-10-21 02:05:00 +0000
commitbacfd56fe26c5075729674436eb5a23bfd80e9fa (patch)
treebfa030d59e109cf94b3b282234c6410b2bd007a0 /net-misc/wxdfast
parentVersion bump for 2.6.23. (diff)
downloadgentoo-2-bacfd56fe26c5075729674436eb5a23bfd80e9fa.tar.gz
gentoo-2-bacfd56fe26c5075729674436eb5a23bfd80e9fa.tar.bz2
gentoo-2-bacfd56fe26c5075729674436eb5a23bfd80e9fa.zip
Patch configure to get location of wxrc from wx-config.
(Portage version: 2.1.3.15)
Diffstat (limited to 'net-misc/wxdfast')
-rw-r--r--net-misc/wxdfast/ChangeLog6
-rw-r--r--net-misc/wxdfast/files/wxdfast-0.6.0-wxrc-configure.patch30
-rw-r--r--net-misc/wxdfast/wxdfast-0.6.0.ebuild11
3 files changed, 39 insertions, 8 deletions
diff --git a/net-misc/wxdfast/ChangeLog b/net-misc/wxdfast/ChangeLog
index 8f6eb49b55ed..dc10c97b6ade 100644
--- a/net-misc/wxdfast/ChangeLog
+++ b/net-misc/wxdfast/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/wxdfast
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wxdfast/ChangeLog,v 1.1 2007/10/19 04:53:14 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wxdfast/ChangeLog,v 1.2 2007/10/21 02:04:59 dirtyepic Exp $
+
+ 21 Oct 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +files/wxdfast-0.6.0-wxrc-configure.patch, wxdfast-0.6.0.ebuild:
+ Patch configure to get location of wxrc from wx-config.
*wxdfast-0.6.0 (19 Oct 2007)
diff --git a/net-misc/wxdfast/files/wxdfast-0.6.0-wxrc-configure.patch b/net-misc/wxdfast/files/wxdfast-0.6.0-wxrc-configure.patch
new file mode 100644
index 000000000000..c6e535b32c8b
--- /dev/null
+++ b/net-misc/wxdfast/files/wxdfast-0.6.0-wxrc-configure.patch
@@ -0,0 +1,30 @@
+diff -Naur wxdfast-0.6.0-orig/configure.in wxdfast-0.6.0/configure.in
+--- wxdfast-0.6.0-orig/configure.in 2007-03-11 16:45:25.000000000 -0600
++++ wxdfast-0.6.0/configure.in 2007-10-20 19:35:30.000000000 -0600
+@@ -64,13 +64,19 @@
+ ])
+ fi
+
+-AC_PATH_PROG([WXRC], [wxrc --version])
+- if test "x$WXRC" = "x"; then
+- AC_MSG_ERROR([
+- wxrc could not be found. This program gets build together with wxWidgets.
+- Please make sure wxrc is within your path.
+- ])
+- fi
++AC_ARG_VAR(WXRC, Path to wxrc resource compiler)
++AC_MSG_CHECKING([for wxrc])
++if test "x$WXRC" = x ; then
++ WXRC=`$WX_CONFIG_WITH_ARGS --utility=wxrc`
++ if test "x$WXRC" = x ; then
++ AC_MSG_RESULT([not found])
++ AC_MSG_ERROR([
++ wxrc could not be found. This program gets build together with wxWidgets.
++ Please make sure wxrc is within your path.
++ ])
++ fi
++fi
++AC_MSG_RESULT([$WXRC])
+
+ AC_OUTPUT([
+ Makefile
diff --git a/net-misc/wxdfast/wxdfast-0.6.0.ebuild b/net-misc/wxdfast/wxdfast-0.6.0.ebuild
index 5fe7cfacbe10..b86ac241fac7 100644
--- a/net-misc/wxdfast/wxdfast-0.6.0.ebuild
+++ b/net-misc/wxdfast/wxdfast-0.6.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wxdfast/wxdfast-0.6.0.ebuild,v 1.1 2007/10/19 04:53:14 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wxdfast/wxdfast-0.6.0.ebuild,v 1.2 2007/10/21 02:04:59 dirtyepic Exp $
WX_GTK_VER="2.6"
-inherit wxwidgets
+inherit autotools eutils wxwidgets
DESCRIPTION="A multi-treaded cross-platform download manager"
HOMEPAGE="http://dfast.sourceforge.net"
@@ -25,11 +25,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
- # temporary kludge until all wxGTK versions in tree install wxrc
- if [[ ! -e /usr/bin/wxrc ]]; then
- sed -i -e "/wxrc --version/ s:wxrc:wxrc-${WX_GTK_VER}:" configure
- sed -i -e "/^WXRC/ s:wxrc:wxrc-${WX_GTK_VER}:" Makefile.gcc
- fi
+ epatch "${FILESDIR}"/${P}-wxrc-configure.patch
+ eautoreconf
}
src_install() {