summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-09-29 22:07:26 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-09-29 22:07:26 +0000
commit631e0070fc209a5b111b7479cff0e14243490b6c (patch)
tree357c8701290cb102555467a930bf420815430098 /net-misc/wicd
parentPatch dev-util/darcs-1.0.9 to add support for >=dev-lang/ghc-6.8 (diff)
downloadgentoo-2-631e0070fc209a5b111b7479cff0e14243490b6c.tar.gz
gentoo-2-631e0070fc209a5b111b7479cff0e14243490b6c.tar.bz2
gentoo-2-631e0070fc209a5b111b7479cff0e14243490b6c.zip
add patch to install new man page, submitted upstream. bring ~ppc kw forward to new version as well
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'net-misc/wicd')
-rw-r--r--net-misc/wicd/ChangeLog10
-rw-r--r--net-misc/wicd/files/wicd-1.5.3-wicd-client-manpage.patch32
-rw-r--r--net-misc/wicd/wicd-1.5.3-r1.ebuild (renamed from net-misc/wicd/wicd-1.5.3.ebuild)11
3 files changed, 50 insertions, 3 deletions
diff --git a/net-misc/wicd/ChangeLog b/net-misc/wicd/ChangeLog
index 9c519556935b..a3b3ecf45099 100644
--- a/net-misc/wicd/ChangeLog
+++ b/net-misc/wicd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/wicd
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.11 2008/09/29 18:49:08 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.12 2008/09/29 22:07:21 darkside Exp $
+
+*wicd-1.5.3-r1 (29 Sep 2008)
+
+ 29 Sep 2008; Jeremy Olexa <darkside@gentoo.org>
+ +files/wicd-1.5.3-wicd-client-manpage.patch, -wicd-1.5.3.ebuild,
+ +wicd-1.5.3-r1.ebuild:
+ add patch to install new man page, submitted upstream. bring ~ppc kw forward
+ to new version as well
29 Sep 2008; Brent Baude <ranger@gentoo.org> wicd-1.5.2.ebuild:
keyworded ~arch for ppc, bug 237837
diff --git a/net-misc/wicd/files/wicd-1.5.3-wicd-client-manpage.patch b/net-misc/wicd/files/wicd-1.5.3-wicd-client-manpage.patch
new file mode 100644
index 000000000000..767d6201c737
--- /dev/null
+++ b/net-misc/wicd/files/wicd-1.5.3-wicd-client-manpage.patch
@@ -0,0 +1,32 @@
+Index: setup.py
+===================================================================
+--- setup.py (revision 488)
++++ setup.py (working copy)
+@@ -311,6 +311,7 @@
+ if not wpath.no_install_init:
+ data.append(( wpath.init, [ wpath.initfile ]))
+ if not wpath.no_install_man:
++ data.append(( wpath.mandir + 'man1/', [ 'man/wicd-client.1' ]))
+ data.append(( wpath.mandir + 'man8/', [ 'man/wicd.8' ]))
+ data.append(( wpath.mandir + 'man5/', [ 'man/wicd-manager-settings.conf.5' ]))
+ data.append(( wpath.mandir + 'man5/', [ 'man/wicd-wired-settings.conf.5' ]))
+Index: in/man=wicd-client.1.in
+===================================================================
+--- in/man=wicd-client.1.in (revision 0)
++++ in/man=wicd-client.1.in (revision 0)
+@@ -0,0 +1,15 @@
++.TH WICD-CLIENT "1" "September 2008" "wicd-client " "User Commands"
++.SH NAME
++wicd-client \- manual page for wicd-client
++.SH DESCRIPTION
++wireless (and wired) connection daemon front\-end.
++.SS "Arguments:"
++.TP
++\fB\-n\fR \fB\-\-no\-tray\fR
++Run wicd without the tray icon.
++.TP
++\fB\-h\fR \fB\-\-help\fR
++Print this help information.
++.TP
++\fB\-a\fR \fB\-\-no\-animate\fR
++Run the tray without network traffic tray animations.
diff --git a/net-misc/wicd/wicd-1.5.3.ebuild b/net-misc/wicd/wicd-1.5.3-r1.ebuild
index 63267ed5ee01..5961b99ae2ce 100644
--- a/net-misc/wicd/wicd-1.5.3.ebuild
+++ b/net-misc/wicd/wicd-1.5.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/wicd-1.5.3.ebuild,v 1.1 2008/09/29 16:25:29 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/wicd-1.5.3-r1.ebuild,v 1.1 2008/09/29 22:07:21 darkside Exp $
inherit distutils eutils
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
RDEPEND="dev-python/dbus-python
@@ -27,6 +27,13 @@ RDEPEND="dev-python/dbus-python
sys-apps/net-tools
)"
+src_unpack() {
+ distutils_src_unpack
+ # patch to install new man page - submitted upstream
+ epatch "${FILESDIR}/${P}-wicd-client-manpage.patch"
+
+}
+
src_compile() {
${python} ./setup.py configure --no-install-init --no-install-docs --resume=/usr/share/wicd/scripts/ --suspend=/usr/share/wicd/scripts/ --verbose
distutils_src_compile