summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-12-01 13:35:56 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-12-01 13:35:56 +0000
commit68ac8269a3b0d113d3d0e7efd69abb00b8d79839 (patch)
tree7332324000df2578c51477865b582b2d3de17cd6 /net-misc/wicd/wicd-1.5.5.ebuild
parentFix Manifest. (diff)
downloadgentoo-2-68ac8269a3b0d113d3d0e7efd69abb00b8d79839.tar.gz
gentoo-2-68ac8269a3b0d113d3d0e7efd69abb00b8d79839.tar.bz2
gentoo-2-68ac8269a3b0d113d3d0e7efd69abb00b8d79839.zip
version bump
(Portage version: 2.2_rc15/cvs/Linux 2.6.27.7 x86_64)
Diffstat (limited to 'net-misc/wicd/wicd-1.5.5.ebuild')
-rw-r--r--net-misc/wicd/wicd-1.5.5.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/wicd/wicd-1.5.5.ebuild b/net-misc/wicd/wicd-1.5.5.ebuild
new file mode 100644
index 000000000000..e3d4cf212b57
--- /dev/null
+++ b/net-misc/wicd/wicd-1.5.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/wicd-1.5.5.ebuild,v 1.1 2008/12/01 13:35:56 darkside Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="A lightweight wired and wireless network manager for Linux"
+HOMEPAGE="http://wicd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-python/dbus-python
+ dev-python/pygtk
+ || (
+ net-misc/dhcpcd
+ net-misc/dhcp
+ net-misc/pump
+ )
+ net-wireless/wireless-tools
+ net-wireless/wpa_supplicant
+ || (
+ sys-apps/net-tools
+ sys-apps/ethtool
+ )
+ || ( x11-misc/ktsuss x11-libs/gksu kde-base/kdesu )"
+
+src_compile() {
+ ${python} ./setup.py configure --no-install-init --no-install-docs --resume=/usr/share/wicd/scripts/ --suspend=/usr/share/wicd/scripts/ --verbose
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="CHANGES"
+ distutils_src_install
+ newinitd "${FILESDIR}/wicd-init.d" wicd || die "newinitd failed"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "You may need to restart the dbus service after upgrading wicd."
+ echo
+ elog "To start wicd at boot, add /etc/init.d/wicd to a runlevel and:"
+ elog "- Remove all net.* initscripts (except for net.lo) from all runlevels"
+ elog "- Add these scripts to the RC_PLUG_SERVICES line in /etc/conf.d/rc"
+ elog "(For example, RC_PLUG_SERVICES=\"!net.eth0 !net.wlan0\")"
+}