summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-22 04:18:08 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-22 04:18:08 +0000
commit55327fa00fa308957d4cd0274d851fe00fbea9d5 (patch)
tree4e285b60831f9638c1c7d14e6863d476de48635a /net-misc/whois
parentBump (diff)
downloadgentoo-2-55327fa00fa308957d4cd0274d851fe00fbea9d5.tar.gz
gentoo-2-55327fa00fa308957d4cd0274d851fe00fbea9d5.tar.bz2
gentoo-2-55327fa00fa308957d4cd0274d851fe00fbea9d5.zip
Version bump.
(Portage version: 2.2.0_alpha175/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'net-misc/whois')
-rw-r--r--net-misc/whois/ChangeLog7
-rw-r--r--net-misc/whois/whois-5.0.25.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/net-misc/whois/ChangeLog b/net-misc/whois/ChangeLog
index 5071490400d6..6e1dcb887c9c 100644
--- a/net-misc/whois/ChangeLog
+++ b/net-misc/whois/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/whois
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.186 2013/04/30 19:01:15 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.187 2013/05/22 04:18:08 radhermit Exp $
+
+*whois-5.0.25 (22 May 2013)
+
+ 22 May 2013; Tim Harder <radhermit@gentoo.org> +whois-5.0.25.ebuild:
+ Version bump.
*whois-5.0.24 (30 Apr 2013)
diff --git a/net-misc/whois/whois-5.0.25.ebuild b/net-misc/whois/whois-5.0.25.ebuild
new file mode 100644
index 000000000000..dda3eb8914a0
--- /dev/null
+++ b/net-misc/whois/whois-5.0.25.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-5.0.25.ebuild,v 1.1 2013/05/22 04:18:08 radhermit Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="improved Whois Client"
+HOMEPAGE="http://www.linux.it/~md/software/"
+SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="iconv idn nls"
+RESTRICT="test" #59327
+
+RDEPEND="iconv? ( virtual/libiconv )
+ idn? ( net-dns/libidn )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=dev-lang/perl-5
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.7.2-config-file.patch
+
+ if use nls ; then
+ sed -i -e 's:#\(.*pos\):\1:' Makefile || die
+ else
+ sed -i -e '/ENABLE_NLS/s:define:undef:' config.h || die
+
+ # don't generate po files when nls is disabled (bug #419889)
+ sed -i -e '/^all:/s/ pos//' \
+ -e '/^install:/s/ install-pos//' Makefile || die
+ fi
+}
+
+src_configure() { :;} # expected no-op
+
+src_compile() {
+ unset HAVE_ICONV HAVE_LIBIDN
+ use iconv && export HAVE_ICONV=1
+ use idn && export HAVE_LIBIDN=1
+ tc-export CC
+ emake CFLAGS="${CFLAGS} ${CPPFLAGS}"
+}
+
+src_install() {
+ emake BASEDIR="${ED}" prefix=/usr install
+ insinto /etc
+ doins whois.conf
+ dodoc README debian/changelog
+
+ if [[ ${USERLAND} != "GNU" ]]; then
+ mv "${ED}"/usr/share/man/man1/{whois,mdwhois}.1 || die
+ mv "${ED}"/usr/bin/{whois,mdwhois} || die
+ fi
+}