summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-12-15 20:26:58 +0000
committerFabian Groffen <grobian@gentoo.org>2011-12-15 20:26:58 +0000
commit53021f23da77bf3e08b28c638b50aee901d97b92 (patch)
tree4d56c02f50ef4b38a5fc6b0a93b95907a24a843b /net-misc/whois
parentFix cross-compile issues with ospeed offset too. (diff)
downloadgentoo-2-53021f23da77bf3e08b28c638b50aee901d97b92.tar.gz
gentoo-2-53021f23da77bf3e08b28c638b50aee901d97b92.tar.bz2
gentoo-2-53021f23da77bf3e08b28c638b50aee901d97b92.zip
Fix compilation on platforms not needing -lcrypt, bug #330235. Call emake correctly for Prefix.
(Portage version: 2.2.01.19941-prefix/cvs/Darwin i386)
Diffstat (limited to 'net-misc/whois')
-rw-r--r--net-misc/whois/ChangeLog6
-rw-r--r--net-misc/whois/whois-5.0.8.ebuild7
2 files changed, 10 insertions, 3 deletions
diff --git a/net-misc/whois/ChangeLog b/net-misc/whois/ChangeLog
index fdcab13b4805..c59034ff9b6a 100644
--- a/net-misc/whois/ChangeLog
+++ b/net-misc/whois/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/whois
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.164 2011/12/05 09:36:47 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.165 2011/12/15 20:26:58 grobian Exp $
+
+ 15 Dec 2011; Fabian Groffen <grobian@gentoo.org> whois-5.0.8.ebuild:
+ Fix compilation on platforms not needing -lcrypt, bug #330235. Call emake
+ correctly for Prefix.
*whois-5.0.13 (05 Dec 2011)
diff --git a/net-misc/whois/whois-5.0.8.ebuild b/net-misc/whois/whois-5.0.8.ebuild
index 065a149338f3..ce0e70daf3d6 100644
--- a/net-misc/whois/whois-5.0.8.ebuild
+++ b/net-misc/whois/whois-5.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-5.0.8.ebuild,v 1.7 2011/03/01 00:33:08 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-5.0.8.ebuild,v 1.8 2011/12/15 20:26:58 grobian Exp $
EAPI=3
inherit eutils toolchain-funcs
@@ -28,6 +28,9 @@ src_prepare() {
else
sed -i -e '/ENABLE_NLS/s:define:undef:' config.h
fi
+
+ echo "int main() {}" | $(tc-getCC) ${CFLAGS} ${LDFLAGS} -xc -o /dev/null - -lcrypt >& /dev/null \
+ || sed -i -e 's/-lcrypt//' Makefile
}
src_configure() { :;} # expected no-op
@@ -41,7 +44,7 @@ src_compile() {
}
src_install() {
- emake BASEDIR="${ED}" prefix=/usr install || die
+ emake BASEDIR="${D}" prefix="${EPREFIX}"/usr install || die
insinto /etc
doins whois.conf
dodoc README debian/changelog