summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-01-23 07:41:32 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-01-23 07:41:32 +0000
commitea3f2efefa84253444a588583b88eb09656ddb66 (patch)
tree6408b3a10d17e7662fd0b386042ddfaab83b5ea5 /net-misc/wget
parentAdd sys-firmware/iwl7260-ucode. Thanks to Thomas Kear for the initial ebuild,... (diff)
downloadgentoo-2-ea3f2efefa84253444a588583b88eb09656ddb66.tar.gz
gentoo-2-ea3f2efefa84253444a588583b88eb09656ddb66.tar.bz2
gentoo-2-ea3f2efefa84253444a588583b88eb09656ddb66.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/ChangeLog8
-rw-r--r--net-misc/wget/files/wget-1.15-pkg-config.patch185
-rw-r--r--net-misc/wget/files/wget-1.15-test_fix.patch26
-rw-r--r--net-misc/wget/wget-1.15.ebuild78
4 files changed, 296 insertions, 1 deletions
diff --git a/net-misc/wget/ChangeLog b/net-misc/wget/ChangeLog
index 260b6be272ad..91e312bc50f2 100644
--- a/net-misc/wget/ChangeLog
+++ b/net-misc/wget/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/wget
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.181 2014/01/18 05:35:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.182 2014/01/23 07:41:32 polynomial-c Exp $
+
+*wget-1.15 (23 Jan 2014)
+
+ 23 Jan 2014; Lars Wendler <polynomial-c@gentoo.org> +wget-1.15.ebuild,
+ +files/wget-1.15-pkg-config.patch, +files/wget-1.15-test_fix.patch:
+ Version bump.
18 Jan 2014; Mike Frysinger <vapier@gentoo.org> wget-1.14-r1.ebuild,
wget-1.14.ebuild:
diff --git a/net-misc/wget/files/wget-1.15-pkg-config.patch b/net-misc/wget/files/wget-1.15-pkg-config.patch
new file mode 100644
index 000000000000..560556c30920
--- /dev/null
+++ b/net-misc/wget/files/wget-1.15-pkg-config.patch
@@ -0,0 +1,185 @@
+From 0f3c2a0720dd6dd86837d72f032644058e56cacd Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Wed, 22 Jan 2014 14:01:24 +0100
+Subject: [PATCH] detect openssl/pcre/libuuid/zlib via pkg-config if it's
+ available
+
+Newer versions of these packages ship with pkg-config files, so if we can
+detect it via those, do so. If that fails, fall back to the old methods.
+
+Forward-ported to 1.15 release from b97942cd6b496501b396ea3bc2710010f4591542
+(Mon, 21 May 2012 18:39:59 -0400)
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ configure.ac | 102 +++++++++++++++++++++++++++++++++++++++++------------------
+ 1 file changed, 72 insertions(+), 30 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index b24588f..088ef22 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -68,6 +68,9 @@ AC_ARG_WITH(ssl,
+ AC_ARG_WITH(zlib,
+ [[ --without-zlib disable zlib ]])
+
++AC_ARG_ENABLE(pcre, AC_HELP_STRING([--disable-pcre],
++ [Disable PCRE style regular expressions]))
++
+ AC_ARG_ENABLE(opie,
+ [ --disable-opie disable support for opie or s/key FTP login],
+ ENABLE_OPIE=$enableval, ENABLE_OPIE=yes)
+@@ -237,12 +240,26 @@ dnl
+ dnl Checks for libraries.
+ dnl
+
++PKG_PROG_PKG_CONFIG
++
+ AS_IF([test x"$with_zlib" != xno], [
+ with_zlib=yes
+- AC_CHECK_LIB(z, compress)
++ PKG_CHECK_MODULES([ZLIB], zlib, [
++ LIBS="$ZLIB_LIBS $LIBS"
++ CFLAGS="$ZLIB_CFLAGS $CFLAGS"
++ ], [
++ AC_CHECK_LIB(z, compress)
++ ])
+ ])
+
+ AS_IF([test x"$with_ssl" = xopenssl], [
++ PKG_CHECK_MODULES([OPENSSL], [openssl], [
++ AC_MSG_NOTICE([compiling in support for SSL via OpenSSL])
++ AC_LIBOBJ([openssl])
++ LIBS="$OPENSSL_LIBS $LIBS"
++ CFLAGS="$OPENSSL_CFLAGS -DHAVE_LIBSSL $CFLAGS"
++ LIBSSL=" " # ntlm check below wants this
++ ], [
+ dnl As of this writing (OpenSSL 0.9.6), the libcrypto shared library
+ dnl doesn't record its dependency on libdl, so we need to make sure
+ dnl -ldl ends up in LIBS on systems that have it. Most OSes use
+@@ -276,9 +293,9 @@ AS_IF([test x"$with_ssl" = xopenssl], [
+ ;;
+ esac
+
+- AS_IF([test x$ssl_found != xyes], [
+- dnl Now actually check for -lssl if it wasn't already found
+- AC_LIB_HAVE_LINKFLAGS([ssl], [crypto], [
++ AS_IF([test x$ssl_found != xyes], [
++ dnl Now actually check for -lssl if it wasn't already found
++ AC_LIB_HAVE_LINKFLAGS([ssl], [crypto], [
+ #include <openssl/ssl.h>
+ #include <openssl/x509.h>
+ #include <openssl/err.h>
+@@ -286,17 +303,18 @@ AS_IF([test x"$with_ssl" = xopenssl], [
+ #include <openssl/des.h>
+ #include <openssl/md4.h>
+ #include <openssl/md5.h>
+- ], [SSL_library_init ()])
+- if test x"$LIBSSL" != x
+- then
+- ssl_found=yes
+- AC_MSG_NOTICE([compiling in support for SSL via OpenSSL])
+- AC_LIBOBJ([openssl])
+- LIBS="$LIBSSL $LIBS"
+- elif test x"$with_ssl" != x
+- then
+- AC_MSG_ERROR([--with-ssl=openssl was given, but SSL is not available.])
+- fi
++ ], [SSL_library_init ()])
++ if test x"$LIBSSL" != x
++ then
++ ssl_found=yes
++ AC_MSG_NOTICE([compiling in support for SSL via OpenSSL])
++ AC_LIBOBJ([openssl])
++ LIBS="$LIBSSL $LIBS"
++ elif test x"$with_ssl" != x
++ then
++ AC_MSG_ERROR([--with-ssl=openssl was given, but SSL is not available.])
++ fi
++ ])
+ ])
+
+ ], [
+@@ -305,6 +323,13 @@ AS_IF([test x"$with_ssl" = xopenssl], [
+ dnl default is -lgnutls
+ with_ssl=gnutls
+
++ PKG_CHECK_MODULES([GNUTLS], [gnutls], [
++ AC_MSG_NOTICE([compiling in support for SSL via GnuTLS])
++ AC_LIBOBJ([gnutls])
++ LIBS="$GNUTLS_LIBS $LIBS"
++ CFLAGS="$GNUTLS_CFLAGS -DHAVE_LIBGNUTLS $CFLAGS"
++ ], [
++
+ dnl Now actually check for -lgnutls
+ AC_LIB_HAVE_LINKFLAGS([gnutls], [], [
+ #include <gnutls/gnutls.h>
+@@ -319,6 +344,8 @@ AS_IF([test x"$with_ssl" = xopenssl], [
+ AC_MSG_ERROR([--with-ssl=gnutls was given, but GNUTLS is not available.])
+ fi
+
++ ])
++
+ AC_CHECK_FUNCS(gnutls_priority_set_direct)
+ ]) # endif: --with-ssl != no?
+ ]) # endif: --with-ssl == openssl?
+@@ -535,26 +562,41 @@ dnl
+ dnl Check for UUID
+ dnl
+
+-AC_CHECK_HEADER(uuid/uuid.h,
+- AC_CHECK_LIB(uuid, uuid_generate,
+- [LIBS="${LIBS} -luuid"
+- AC_DEFINE([HAVE_LIBUUID], 1,
+- [Define if libuuid is available.])
+- ])
+-)
++AC_ARG_WITH(libuuid, AC_HELP_STRING([--without-libuuid],
++ [Generate UUIDs for WARC files via libuuid]))
++AS_IF([test "X$with_libuuid" != "Xno"],[
++ PKG_CHECK_MODULES([UUID], uuid, [
++ LIBS="$UUID_LIBS $LIBS"
++ CFLAGS="$UUID_CFLAGS $CFLAGS"
++ ], [
++ AC_CHECK_HEADER(uuid/uuid.h,
++ AC_CHECK_LIB(uuid, uuid_generate,
++ [LIBS="${LIBS} -luuid"
++ AC_DEFINE([HAVE_LIBUUID], 1,
++ [Define if libuuid is available.])
++ ])
++ )
++ ])
++])
+
+ dnl
+ dnl Check for PCRE
+ dnl
+
+-AC_CHECK_HEADER(pcre.h,
+- AC_CHECK_LIB(pcre, pcre_compile,
+- [LIBS="${LIBS} -lpcre"
+- AC_DEFINE([HAVE_LIBPCRE], 1,
+- [Define if libpcre is available.])
+- ])
+-)
+-
++AS_IF([test "X$enable_pcre" != "Xno"],[
++ PKG_CHECK_MODULES([PCRE], libpcre, [
++ LIBS="$PCRE_LIBS $LIBS"
++ CFLAGS="$PCRE_CFLAGS $CFLAGS"
++ ], [
++ AC_CHECK_HEADER(pcre.h,
++ AC_CHECK_LIB(pcre, pcre_compile,
++ [LIBS="${LIBS} -lpcre"
++ AC_DEFINE([HAVE_LIBPCRE], 1,
++ [Define if libpcre is available.])
++ ])
++ )
++ ])
++])
+
+ dnl Needed by src/Makefile.am
+ AM_CONDITIONAL([IRI_IS_ENABLED], [test "X$iri" != "Xno"])
+--
+1.8.5.3
+
diff --git a/net-misc/wget/files/wget-1.15-test_fix.patch b/net-misc/wget/files/wget-1.15-test_fix.patch
new file mode 100644
index 000000000000..754e44f2d92e
--- /dev/null
+++ b/net-misc/wget/files/wget-1.15-test_fix.patch
@@ -0,0 +1,26 @@
+From 3a47a1a918e9076133c046f8792cf68973f7c585 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Wed, 22 Jan 2014 22:07:18 +0100
+Subject: [PATCH] Don't use --debug in Test--post-file.px
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ tests/Test--post-file.px | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/Test--post-file.px b/tests/Test--post-file.px
+index 1c017b7..1212af6 100755
+--- a/tests/Test--post-file.px
++++ b/tests/Test--post-file.px
+@@ -8,7 +8,7 @@ use HTTPTest;
+
+ ###############################################################################
+
+-my $cmdline = $WgetTest::WGETPATH . " -d --post-file=nofile http://localhost:{{port}}/";
++my $cmdline = $WgetTest::WGETPATH . " --post-file=nofile http://localhost:{{port}}/";
+
+ my $expected_error_code = 3;
+
+--
+1.8.5.3
+
diff --git a/net-misc/wget/wget-1.15.ebuild b/net-misc/wget/wget-1.15.ebuild
new file mode 100644
index 000000000000..d767052e39e4
--- /dev/null
+++ b/net-misc/wget/wget-1.15.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.15.ebuild,v 1.1 2014/01/23 07:41:32 polynomial-c Exp $
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs autotools
+
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="http://www.gnu.org/software/wget/"
+SRC_URI="mirror://gnu/wget/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug gnutls idn ipv6 nls ntlm pcre +ssl static uuid zlib"
+
+LIB_DEPEND="idn? ( net-dns/libidn[static-libs(+)] )
+ pcre? ( dev-libs/libpcre[static-libs(+)] )
+ ssl? (
+ gnutls? ( net-libs/gnutls[static-libs(+)] )
+ !gnutls? ( dev-libs/openssl:0[static-libs(+)] )
+ )
+ uuid? ( sys-apps/util-linux[static-libs(+)] )
+ zlib? ( sys-libs/zlib[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ static? ( ${LIB_DEPEND} )
+ nls? ( sys-devel/gettext )"
+
+REQUIRED_USE="ntlm? ( !gnutls ssl ) gnutls? ( ssl )"
+
+DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.15-pkg-config.patch \
+ "${FILESDIR}"/${PN}-1.15-test_fix.patch
+ eautoreconf
+}
+
+src_configure() {
+ # openssl-0.9.8 now builds with -pthread on the BSD's
+ use elibc_FreeBSD && use ssl && append-ldflags -pthread
+ # fix compilation on Solaris, we need filio.h for FIONBIO as used in
+ # the included gnutls -- force ioctl.h to include this header
+ [[ ${CHOST} == *-solaris* ]] && append-flags -DBSD_COMP=1
+
+ if use static ; then
+ append-ldflags -static
+ tc-export PKG_CONFIG
+ PKG_CONFIG+=" --static"
+ fi
+ econf \
+ --disable-rpath \
+ $(use_with ssl ssl $(usex gnutls gnutls openssl)) \
+ $(use_enable ssl opie) \
+ $(use_enable ssl digest) \
+ $(use_enable idn iri) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable ntlm) \
+ $(use_enable pcre) \
+ $(use_enable debug) \
+ $(use_with uuid libuuid) \
+ $(use_with zlib)
+}
+
+src_install() {
+ default
+
+ sed -i \
+ -e "s:/usr/local/etc:${EPREFIX}/etc:g" \
+ "${ED}"/etc/wgetrc \
+ "${ED}"/usr/share/man/man1/wget.1 \
+ "${ED}"/usr/share/info/wget.info
+}