summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-11-06 15:49:54 +0000
committerMike Frysinger <vapier@gentoo.org>2014-11-06 15:49:54 +0000
commit9995610d5f9d247b50557e2207ee70a2a429e0ca (patch)
tree4b9b48701e11d63fa859a4aebddde9b1a3e7ecf0 /net-misc/wget
parentVersion bump wrt security bug 528450; Drop old (diff)
downloadgentoo-2-9995610d5f9d247b50557e2207ee70a2a429e0ca.tar.gz
gentoo-2-9995610d5f9d247b50557e2207ee70a2a429e0ca.tar.bz2
gentoo-2-9995610d5f9d247b50557e2207ee70a2a429e0ca.zip
Fix by Mike Gilbert to require python-3 in order to run tests #528348#1 by Nikoli.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/ChangeLog6
-rw-r--r--net-misc/wget/wget-1.16.ebuild16
2 files changed, 18 insertions, 4 deletions
diff --git a/net-misc/wget/ChangeLog b/net-misc/wget/ChangeLog
index 5cc8cc2500c3..213a9edf5bf4 100644
--- a/net-misc/wget/ChangeLog
+++ b/net-misc/wget/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/wget
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.194 2014/11/03 05:57:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.195 2014/11/06 15:49:54 vapier Exp $
+
+ 06 Nov 2014; Mike Frysinger <vapier@gentoo.org> wget-1.16.ebuild:
+ Fix by Mike Gilbert to require python-3 in order to run tests #528348#1 by
+ Nikoli.
02 Nov 2014; Mike Frysinger <vapier@gentoo.org> wget-1.16.ebuild:
Mark arm64/m68k/s390/sh stable.
diff --git a/net-misc/wget/wget-1.16.ebuild b/net-misc/wget/wget-1.16.ebuild
index 2b6e8838672d..1bf420a52e07 100644
--- a/net-misc/wget/wget-1.16.ebuild
+++ b/net-misc/wget/wget-1.16.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.16.ebuild,v 1.11 2014/11/03 05:57:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.16.ebuild,v 1.12 2014/11/06 15:49:54 vapier Exp $
EAPI="4"
+PYTHON_COMPAT=( python{3_3,3_4} )
-inherit flag-o-matic toolchain-funcs autotools
+inherit flag-o-matic python-any-r1 toolchain-funcs autotools
DESCRIPTION="Network utility to retrieve files from the WWW"
HOMEPAGE="http://www.gnu.org/software/wget/"
@@ -13,7 +14,7 @@ SRC_URI="mirror://gnu/wget/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ~ppc ~ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug gnutls idn ipv6 nls ntlm pcre +ssl static uuid zlib"
+IUSE="debug gnutls idn ipv6 nls ntlm pcre +ssl static test uuid zlib"
LIB_DEPEND="idn? ( net-dns/libidn[static-libs(+)] )
pcre? ( dev-libs/libpcre[static-libs(+)] )
@@ -28,12 +29,17 @@ DEPEND="${RDEPEND}
app-arch/xz-utils
virtual/pkgconfig
static? ( ${LIB_DEPEND} )
+ test? ( ${PYTHON_DEPS} )
nls? ( sys-devel/gettext )"
REQUIRED_USE="ntlm? ( !gnutls ssl ) gnutls? ( ssl )"
DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.16-pkg-config.patch
epatch "${FILESDIR}"/${PN}-1.16-openssl-header.patch
@@ -70,6 +76,10 @@ src_configure() {
$(use_with zlib)
}
+src_test() {
+ emake check
+}
+
src_install() {
default