summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-09-01 09:24:29 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-09-01 09:24:29 +0000
commit17cb96e39706044041e43854c4df971b310a1c23 (patch)
treec873ce5f715cec00ad317185b65b8a6a8797d52c /net-misc/wget
parentFix breakage introduced by Prefix changes. 1.4 ebuild cannot be migrated to ... (diff)
downloadgentoo-2-17cb96e39706044041e43854c4df971b310a1c23.tar.gz
gentoo-2-17cb96e39706044041e43854c4df971b310a1c23.tar.bz2
gentoo-2-17cb96e39706044041e43854c4df971b310a1c23.zip
Version bump. EAPI 4 port by Tomáš "scarabeus" Chvátal in bug #381405.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/ChangeLog7
-rw-r--r--net-misc/wget/wget-1.13.3.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/net-misc/wget/ChangeLog b/net-misc/wget/ChangeLog
index 8d5b5ae63ff4..3fd0c5ebb53b 100644
--- a/net-misc/wget/ChangeLog
+++ b/net-misc/wget/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/wget
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.139 2011/02/28 23:40:41 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.140 2011/09/01 09:24:29 chainsaw Exp $
+
+*wget-1.13.3 (01 Sep 2011)
+
+ 01 Sep 2011; Tony Vroon <chainsaw@gentoo.org> +wget-1.13.3.ebuild:
+ Version bump. EAPI 4 port by Tomáš "scarabeus" Chvátal in bug #381405.
28 Feb 2011; Brent Baude <ranger@gentoo.org> wget-1.12-r3.ebuild:
stable ppc64, bug 349114
diff --git a/net-misc/wget/wget-1.13.3.ebuild b/net-misc/wget/wget-1.13.3.ebuild
new file mode 100644
index 000000000000..0e990eca446c
--- /dev/null
+++ b/net-misc/wget/wget-1.13.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.13.3.ebuild,v 1.1 2011/09/01 09:24:29 chainsaw Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="http://www.gnu.org/software/wget/"
+SRC_URI="mirror://gnu/wget/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="debug idn ipv6 nls ntlm +ssl static"
+
+RDEPEND="idn? ( net-dns/libidn )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+REQUIRED_USE="ntlm? ( ssl )"
+
+DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
+
+src_configure() {
+ # openssl-0.9.8 now builds with -pthread on the BSD's
+ use elibc_FreeBSD && use ssl && append-ldflags -pthread
+
+ use static && append-ldflags -static
+ econf \
+ --disable-rpath \
+ $(use_with ssl) $(use_enable ssl opie) $(use_enable ssl digest) \
+ $(use_enable idn iri) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable ntlm) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ use ipv6 && cat "${FILESDIR}"/wgetrc-ipv6 >> "${ED}"/etc/wgetrc
+
+ sed -i \
+ -e "s:/usr/local/etc:${EROOT}/etc:g" \
+ "${ED}"/etc/wgetrc \
+ "${ED}"/usr/share/man/man1/wget.1 \
+ "${ED}"/usr/share/info/wget.info
+}
+
+pkg_preinst() {
+ ewarn "The /etc/wget/wgetrc file has been relocated to /etc/wgetrc"
+ if [[ -e ${EROOT}/etc/wget/wgetrc ]] ; then
+ if [[ -e ${EROOT}/etc/wgetrc ]] ; then
+ ewarn "You have both /etc/wget/wgetrc and /etc/wgetrc ... you should delete the former"
+ else
+ einfo "Moving /etc/wget/wgetrc to /etc/wgetrc for you"
+ mv "${EROOT}"/etc/wget/wgetrc "${EROOT}"/etc/wgetrc
+ rmdir "${EROOT}"/etc/wget 2>/dev/null
+ fi
+ fi
+}