summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-31 17:27:53 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-31 17:27:53 +0000
commit4c3234ca0c7d435d95ff6df896aeb6f283c7dc48 (patch)
treea7c2cd62ef99da2c74867a01ef90ea6c0f471ef5 /net-misc/wget/wget-1.8.2-r1.ebuild
parentadded einfo thanks to j2ee (diff)
downloadgentoo-2-4c3234ca0c7d435d95ff6df896aeb6f283c7dc48.tar.gz
gentoo-2-4c3234ca0c7d435d95ff6df896aeb6f283c7dc48.tar.bz2
gentoo-2-4c3234ca0c7d435d95ff6df896aeb6f283c7dc48.zip
added ipv6 patch from debian
Diffstat (limited to 'net-misc/wget/wget-1.8.2-r1.ebuild')
-rw-r--r--net-misc/wget/wget-1.8.2-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-misc/wget/wget-1.8.2-r1.ebuild b/net-misc/wget/wget-1.8.2-r1.ebuild
new file mode 100644
index 000000000000..979e4eadf036
--- /dev/null
+++ b/net-misc/wget/wget-1.8.2-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.8.2-r1.ebuild,v 1.1 2002/10/31 17:27:53 seemant Exp $
+
+IUSE="ssl nls static ipv6"
+
+NPVER=20011209
+S=${WORKDIR}/${P}
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
+SRC_URI="ftp://prep.ai.mit.edu/gnu/wget/${P}.tar.gz
+ ftp://gatekeeper.dec.com/pub/GNU/wget/${P}.tar.gz
+ http://www.biscom.net/~cade/away/wget-new-percentage/wget-new-percentage-cvs-${NPVER}.tar.gz
+ ipv6? mirror://gentoo/${P}-ipv6-debian.patch.bz2"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src
+ patch -p0 < ${WORKDIR}/wget-new-percentage/wnp-20011208-2.diff || die
+
+ if use ipv6
+ then
+ cd ${S}
+ patch -p1 < ${WORKDIR}/${P}-ipv6-debian.patch || die
+ fi
+}
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+ use ssl && myconf="${myconf} --with-ssl"
+ use ssl || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
+ [ -z "$DEBUG" ] && myconf="${myconf} --disable-debug"
+ use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
+ ./configure --prefix=/usr --sysconfdir=/etc/wget \
+ --infodir=/usr/share/info --mandir=usr/share/man $myconf || die
+ if use static; then
+ make LDFLAGS="--static" || die
+ else
+ make || die
+ fi
+}
+
+src_install() {
+ if use build; then
+ insinto /usr
+ dobin ${S}/src/wget
+ return
+ fi
+ make prefix=${D}/usr sysconfdir=${D}/etc/wget \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install || die
+ dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
+ dodoc doc/sample.wgetrc
+}