summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-01-04 20:03:05 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-01-04 20:03:05 +0000
commit9c90b7b4906521d5c0359a0f3b8cd26a815a0fb5 (patch)
treef85928b06ab33478e6e535912963c3807ee68af2 /net-misc/vnc
parentMark -sparc the revisions that use xulrunner-1.9, bug #253541 (diff)
downloadgentoo-2-9c90b7b4906521d5c0359a0f3b8cd26a815a0fb5.tar.gz
gentoo-2-9c90b7b4906521d5c0359a0f3b8cd26a815a0fb5.tar.bz2
gentoo-2-9c90b7b4906521d5c0359a0f3b8cd26a815a0fb5.zip
Fix bug #242350, thanks to Eric Bosch <eric dot bosch at comcast dot net> for the patch
(Portage version: 2.1.6.4/cvs/Linux 2.6.26-gentoo-r2 ia64)
Diffstat (limited to 'net-misc/vnc')
-rw-r--r--net-misc/vnc/ChangeLog8
-rw-r--r--net-misc/vnc/vnc-4.1.2-r5.ebuild23
2 files changed, 27 insertions, 4 deletions
diff --git a/net-misc/vnc/ChangeLog b/net-misc/vnc/ChangeLog
index 3541544ab1c0..902edc4b2b8c 100644
--- a/net-misc/vnc/ChangeLog
+++ b/net-misc/vnc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/vnc
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/ChangeLog,v 1.113 2008/12/19 17:40:11 jer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/ChangeLog,v 1.114 2009/01/04 20:03:05 armin76 Exp $
+
+ 04 Jan 2009; Raúl Porcel <armin76@gentoo.org> vnc-4.1.2-r5.ebuild:
+ Fix bug #242350, thanks to Eric Bosch <eric dot bosch at comcast dot net>
+ for the patch
19 Dec 2008; Jeroen Roovers <jer@gentoo.org> vnc-4.1.2-r5.ebuild:
Marked ~hppa (bug #240425).
diff --git a/net-misc/vnc/vnc-4.1.2-r5.ebuild b/net-misc/vnc/vnc-4.1.2-r5.ebuild
index 2b54268a2da4..8756a3732490 100644
--- a/net-misc/vnc/vnc-4.1.2-r5.ebuild
+++ b/net-misc/vnc/vnc-4.1.2-r5.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/vnc-4.1.2-r5.ebuild,v 1.4 2008/12/19 17:40:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/vnc-4.1.2-r5.ebuild,v 1.5 2009/01/04 20:03:05 armin76 Exp $
EAPI="1"
inherit eutils toolchain-funcs multilib autotools
+OPENGL_DIR="xorg-x11"
XSERVER_VERSION="1.5.3"
PATCH="${P}-r5-patches-0.1"
@@ -26,6 +27,7 @@ RDEPEND="sys-libs/zlib
media-libs/freetype
x11-libs/libSM
x11-libs/libXtst
+ app-admin/eselect-opengl
server? (
x11-libs/libXi
x11-libs/libXfont
@@ -78,9 +80,21 @@ pkg_setup() {
einfo "Stop the build now if you need to add 'server' to USE flags.\n"
ebeep
epause 5
+ else
+ ewarn "Forcing on xorg-x11 for new enough glxtokens.h..."
+ OLD_IMPLEM="$(eselect opengl show)"
+ eselect opengl set --impl-headers ${OPENGL_DIR}
fi
}
+switch_opengl_implem() {
+ # Switch to the xorg implementation.
+ # Use new opengl-update that will not reset user selected
+ # OpenGL interface ...
+ echo
+ eselect opengl set ${OLD_IMPLEM}
+}
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -193,3 +207,8 @@ src_install() {
rm "${D}"/usr/$(get_libdir)/librfb.{a,la,so}
}
+
+pkg_postinst() {
+ use server && switch_opengl_implem
+}
+