summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-01-30 21:13:26 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-01-30 21:13:26 +0000
commitc4357b59a2f1579805e0608c4bb18c2ef1bc4868 (patch)
treefb7b96330999de09748271f1ef89ec568cd5e6e9 /net-misc/vino
parentStable on amd64 wrt bug #133260. (diff)
downloadgentoo-2-c4357b59a2f1579805e0608c4bb18c2ef1bc4868.tar.gz
gentoo-2-c4357b59a2f1579805e0608c4bb18c2ef1bc4868.tar.bz2
gentoo-2-c4357b59a2f1579805e0608c4bb18c2ef1bc4868.zip
Pull upstream patch to stop vino forgetting it's password. Bug #162905
(Portage version: 2.1.2-r5)
Diffstat (limited to 'net-misc/vino')
-rw-r--r--net-misc/vino/ChangeLog8
-rw-r--r--net-misc/vino/files/digest-vino-2.16.0-r13
-rw-r--r--net-misc/vino/files/vino-2.16.0-keep-password.patch11
-rw-r--r--net-misc/vino/vino-2.16.0-r1.ebuild57
4 files changed, 78 insertions, 1 deletions
diff --git a/net-misc/vino/ChangeLog b/net-misc/vino/ChangeLog
index e8b18e12866e..aea3ffa8370c 100644
--- a/net-misc/vino/ChangeLog
+++ b/net-misc/vino/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/vino
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vino/ChangeLog,v 1.78 2007/01/21 20:26:53 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vino/ChangeLog,v 1.79 2007/01/30 21:13:26 dang Exp $
+
+*vino-2.16.0-r1 (30 Jan 2007)
+
+ 30 Jan 2007; Daniel Gryniewicz <dang@gentoo.org>
+ +files/vino-2.16.0-keep-password.patch, +vino-2.16.0-r1.ebuild:
+ Pull upstream patch to stop vino forgetting it's password. Bug #162905
21 Jan 2007; Bryan Østergaard <kloeri@gentoo.org> vino-2.16.0.ebuild:
Stable on IA64, bug 156662.
diff --git a/net-misc/vino/files/digest-vino-2.16.0-r1 b/net-misc/vino/files/digest-vino-2.16.0-r1
new file mode 100644
index 000000000000..78f3c8779f63
--- /dev/null
+++ b/net-misc/vino/files/digest-vino-2.16.0-r1
@@ -0,0 +1,3 @@
+MD5 89937e6d6cd8f658d037da0a7cfd3f4e vino-2.16.0.tar.bz2 593224
+RMD160 047829b29e078ee46f3c3a16f25c88938e40d2c9 vino-2.16.0.tar.bz2 593224
+SHA256 bcf62f1121fe704a019363467f9182e29931ee6779f3b65e996171f4caa11369 vino-2.16.0.tar.bz2 593224
diff --git a/net-misc/vino/files/vino-2.16.0-keep-password.patch b/net-misc/vino/files/vino-2.16.0-keep-password.patch
new file mode 100644
index 000000000000..9afc879b046a
--- /dev/null
+++ b/net-misc/vino/files/vino-2.16.0-keep-password.patch
@@ -0,0 +1,11 @@
+diff --exclude-from=/home/dang/.diffrc -up -ruN vino-2.16.0.orig/server/vino-prefs.c vino-2.16.0/server/vino-prefs.c
+--- vino-2.16.0.orig/server/vino-prefs.c 2006-08-14 04:47:27.000000000 -0400
++++ vino-2.16.0/server/vino-prefs.c 2007-01-30 15:38:12.000000000 -0500
+@@ -306,7 +306,6 @@ vino_prefs_init (gboolean view_only)
+ VINO_PREFS_VNC_PASSWORD,
+ NULL);
+ dprintf (PREFS, "Encoded password: %s\n", vino_vnc_password ? vino_vnc_password : "(null)");
+- g_free (vino_vnc_password);
+
+ vino_listeners [i] =
+ gconf_client_notify_add (vino_client,
diff --git a/net-misc/vino/vino-2.16.0-r1.ebuild b/net-misc/vino/vino-2.16.0-r1.ebuild
new file mode 100644
index 000000000000..3729d3df09e3
--- /dev/null
+++ b/net-misc/vino/vino-2.16.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vino/vino-2.16.0-r1.ebuild,v 1.1 2007/01/30 21:13:26 dang Exp $
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=1.9
+inherit eutils gnome2 autotools
+
+DESCRIPTION="An integrated VNC server for GNOME"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86"
+IUSE="avahi crypt gnutls jpeg zlib"
+
+RDEPEND=">=x11-libs/gtk+-2
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomeui-2.5.2
+ >=gnome-base/orbit-2
+ >=gnome-base/libbonobo-2
+ || ( x11-libs/libXtst virtual/x11 )
+ avahi? ( >=net-dns/avahi-0.6 )
+ crypt? ( >=dev-libs/libgcrypt-1.1.90 )
+ gnutls? ( >=net-libs/gnutls-1 )
+ jpeg? ( media-libs/jpeg )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+pkg_setup() {
+ if use avahi && ! built_with_use net-dns/avahi dbus; then
+ einfo "avahi support in vino requires USE=dbus in avahi"
+ die "Please rebuild net-dns/avahi with USE=dbus"
+ fi
+ G2CONF="$(use_with jpeg) $(use_enable gnutls) $(use_enable crypt gcrypt) \
+ $(use_with zlib) $(use_with zlib libz) $(use_enable avahi) \
+ --enable-session-support"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Don't forget server password. Bug #162905
+ epatch "${FILESDIR}"/${P}-keep-password.patch
+
+ cp aclocal.m4 old_macros.m4
+ # rename some things so they get regenerated and we don't get a mismatch
+ sed -i -e 's:AM_AUTOMAKE_VERSION:AM_AUTOMAKE_VERSION2:' old_macros.m4
+ sed -i -e 's:AM_INIT_AUTOMAKE:AM_INIT_AUTOMAKE2:' old_macros.m4
+ sed -i -e 's:AM_SET_CURRENT_AUTOMAKE_VERSION:AM_SET_CURRENT_AUTOMAKE_VERSION2:' old_macros.m4
+ AT_M4DIR="." eautoreconf
+}